nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GeForce2 w/NVIDIA driver & bttv (video4linux) = mess (http://www.nvnews.net/vbulletin/showthread.php?t=6737)

AutoPilot 01-27-03 01:29 PM

GeForce2 w/NVIDIA driver & bttv (video4linux) = mess
 
Am I the only person using a video capture card with NVIDIA graphics cards under Linux? (well, my friend and I)

I first experienced this problem on a friend's machine, but didn't dig into it enough at the time to know what was going on.

The problem is, when viewing video (through the TV tuner, direct video capture, whatever), the video on the right side of the window gets updated VERY slowly, to the point that it might as well just be cut off. You'll get stripes of video 1 pixel high occasionnally, it's hard to describe. If needed, I'll post a snapshot somewhere for people to see.

The problem does NOT occur using the open-source "nv" driver that comes with XFree86, I switched back and forth between them without altering anything else to verify this. It is definately specific to the NVIDIA supplied driver.

The hardware doesn't seem to matter, as my friend is using a Bt848 card, and I'm using a Bt878 card. He's using a Geforce2 MX 200 and I'm using a Geforce2 GTS. Both systems are dual-pentium-III 1GHz systems, though they have different motherboards. His has 2GB of RAM, mine has 1.5GB. He's running RedHat 7.3, I'm using 8.0. We're both using 2.4.20 built from the unaltered kernel sources (kernel.org), not the customized/patched-up RedHat kernels. I've seen this behaviour on his machine with many kernel versions though.

Everything else seems to work great... the 3d is phenomenal (Unreal Tournament and bzflag)... even the installation was a breeze
(source RPMs, can't get much easier).

Is anyone else experiencing this problem? I haven't been able to find anything using google in newsgroups or on the web.

Thanks for any help anyone may be able to offer.

AutoPilot 01-27-03 01:42 PM

Screenshot of the bttv/video4linux display
 
1 Attachment(s)
This is what I see when I watch TV using my Bt878 card with the NVIDIA drivers. The left half is updated real-time (as it should). The right is self explanatory.

richunger 01-28-03 03:41 AM

If you hadn't said it worked under the nv driver, I would've guessed that the tuner module was selecting the wrong tuner type. I'm running with an AverTV studio (another bttv board), and had to try several different tuner types before I got one that worked perfectly.

I had strange problems with other tuners, like all the channels would tune video okay, but channel 2 would have audio from an fm station.

Anyway, you might check that out, just in case.

AutoPilot 01-28-03 11:19 PM

I'm sure I have the correct configuration for the video capture card... I've been using this one for some time with other video cards with no problem at all, as well as with the nv driver.

The tuner is clearly labeled, so it's hard to select the wrong one. ;) As I said in the original article, I'm seeing this with two different boards, one of which I've used for many months, the other for many years (I gave my friend my old bt848 card when I got the bt878 card - and just copied the config over to his box).

Thanks for the suggestion though.

a_j_j 01-29-03 04:15 PM

I've got a bt878-based TV card (Hauppauge WinTV, no radio) and a GeForce 4, and I can't say I've experienced any of the problems you describe...

I'm using kernel 2.4.20 and NVidia driver 4191 with the kernel AGPGART module.

Out of interest, are you running bttv with Xv enabled or disabled? Have you got the "extmod" and "v4l" modules set to load in your XF86Config?

richunger 01-30-03 04:12 AM

Hey, speaking of Xv... I've noticed that when I run with Xv enabled, and I quit a program that uses the tuner (xawtv, radio, etc), the audio keeps on going. When I disable Xv, the audio stops correctly along with the video.

So, when I have Xv enabled, if I want to get the audio to stop, I have to do a xawtv -noxv, and then quit again.

Ever run into that?

AutoPilot 01-30-03 03:27 PM

reply to a_j_j THANKS!
 
Thanks for the tip... I had "extmod" but not "v4l" loaded in XF86Config. Wierd that it's not needed with the banshee or the nv drivers.

Thank you _very_ much!


All times are GMT -5. The time now is 05:39 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.