nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   TV-out ceased to work in 8756 release (http://www.nvnews.net/vbulletin/showthread.php?t=67964)

Belegdol 04-08-06 12:47 PM

TV-out ceased to work in 8756 release
 
2 Attachment(s)
I have found a few people who report tv-out not working in latest driver release, so I thought a sepearate thread would be nice. Similar thing has happened for me. In 8174, this xorg.conf entries allowed me to enjoy movies on TV:
Quote:

Option "TwinView"
Option "MetaModes" "1600x1200, NULL; 1280x960, NULL; 1024x768, NULL; 800x600, 800x600"
Option "TwinViewOrientation" "Clone"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorRefreshRate" "60"
Option "TVStandard" "PAL-B"
Option "TVOutFormat" "SVIDEO"
Option "ConnectedMonitor" "CRT-0, TV-0"
Now it just seems to disregard ConnectedMonitor option - there is no TV-0 in nvidia-settings as it used to be before. I'm attaching my Xorg.log and nvidia-bug.report.log. I am running Fedora Core 5 and I have installed the driver using rpm.livna.org packages.

hayaka 04-08-06 12:56 PM

Re: TV-out ceased to work in 8756 release
 
How did you test the TV output because the log file detected a TV
[cdoe]
(--) NVIDIA(0): Connected display device(s) on GeForce FX 5700VE at
(--) NVIDIA(0): PCI:1:0:0:
(--) NVIDIA(0): CRT-0
(--) NVIDIA(0): NVIDIA TV Encoder (TV-0)
(--) NVIDIA(0): CRT-0: 400 MHz maximum pixel clock
(--) NVIDIA(0): NVIDIA TV Encoder (TV-0): 400 MHz maximum pixel clock
(--) NVIDIA(0): TV encoder: NVIDIA
[/code]

Belegdol 04-08-06 01:10 PM

Re: TV-out ceased to work in 8756 release
 
In two ways:
1. Running nvidia-settings and checking if there is TV-0 below CRT-0 in the tree (there is not)
2. Switching to the last metamode (xrandr -s 3) - there is no output to the TV. Everything was working in the previous driver.

netllama 04-08-06 03:59 PM

Re: TV-out ceased to work in 8756 release
 
Belegdol,
I have a few questions:
0) If you remove the ConnectedMonitor and SecondMonitorHorizSync options, does that have any impact?
1) Is your SVIDEO cable running directly between the TV and videocard, or are you using any intermediary cabled/devices?
2) If you use two modes ( 800x600, 800x600 ) in your first pair of MetaModes, instead of NULL, does that have any impact?
3) What kind of TV and CRT are you using?

Thanks,
Lonni

jeisom 04-08-06 04:01 PM

Re: TV-out ceased to work in 8756 release
 
Tv out with multiple screens worked for me after I switched
Option "ConnectedMonitor" "tv"
to:
Option "UseDisplayDevice" "TV"

Hope this helps

Belegdol 04-09-06 01:50 AM

Re: TV-out ceased to work in 8756 release
 
Quote:

Originally Posted by netllama
Belegdol,
I have a few questions:
0) If you remove the ConnectedMonitor and SecondMonitorHorizSync options, does that have any impact?
1) Is your SVIDEO cable running directly between the TV and videocard, or are you using any intermediary cabled/devices?
2) If you use two modes ( 800x600, 800x600 ) in your first pair of MetaModes, instead of NULL, does that have any impact?
3) What kind of TV and CRT are you using?

Thanks,
Lonni

It's nice to see someone frome nvidia has replied so fast.
0) No impact, apart from the fact that the TV has to be connected to be detected in Xorg.0.log
1) It is connected directly between TV and videocard using single, 10 m long cable
2) I tried commenting out my metamode line and adding one with only 800x600, 800x600 entry, but it has not helped
3) CRT: Samsung Syncmaster 959NF; TV: LOEWE Art Vision 70 (quite an old one, but was working with previous driver with no problems).
BTW x.org is unable to fetch EDID for the CRT, is any special option needed?

[edit]As suggested I have tried the following:
Quote:

Option UseDisplayDevice "TV-0"
Option MetaModes "800x600, 800x600"
I got signal output only to the TV. So it seems something is screwed up with TwinView.

ijuma82 04-09-06 03:58 AM

Re: TV-out ceased to work in 8756 release
 
TV-out also stopped working for me with TwinView. Using the following option solves it for me, but then I only get a picture in the tv.

Option "UseDisplayDevice" "TV"

beck 04-09-06 06:29 AM

Re: TV-out ceased to work in 8756 release
 
The problem is idem with two screens in xorg.conf , one screen 0 CRT + one screen 1 TV ....

Belegdol 04-09-06 06:31 AM

Re: TV-out ceased to work in 8756 release
 
Could you rephrase that? I don't understand...

beck 04-09-06 07:03 AM

Re: TV-out ceased to work in 8756 release
 
Quote:

Originally Posted by Belegdol
Could you rephrase that? I don't understand...

I don't use twinview but i have two configured screen .

But I switched
Option "ConnectedMonitor" "TV-0"
to:
Option "UseDisplayDevice" "TV-0"

And the problem is solved :-)

Cym 04-09-06 07:36 AM

Re: TV-out ceased to work in 8756 release
 
I also noticed tv out is not working the same as it was with the previous version. Here are my observations:

1) I have my setup with dual X screens on a single GeForge FX 5200
2) If I comment the following lines in xorg.conf, then it works as before:

from the first device:
# Option "ConnectedMonitor" "CRT"
from the second device:
# Option "ConnectedMonitor" "TV"

3) The tv drivers do not recognize 800x600 resolution any longer. The tv is now only recognizing 720x480 and 600x400.

Belegdol 04-10-06 01:27 AM

Re: TV-out ceased to work in 8756 release
 
I have managed to get 800x600 output to the TV, as described in the previous post. As for
Quote:

Option "UseDisplayDevice" "TV-0"
it allows me to get tv output, but only it - no crt display. The whole point of using
Quote:

Option "ConnectedMonitor" "CRT-0, TV-0"
here is to enable the tv output if the tv is not connected, so that I can connect it anytime without the necessity to restart X.


All times are GMT -5. The time now is 10:52 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.