nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Vanishing fonts with the newest Xorg builds (http://www.nvnews.net/vbulletin/showthread.php?t=68026)

vherva 04-09-06 03:26 AM

Vanishing fonts with the newest Xorg builds
 
I'm running Fedora rawhide that has the newest Xorg CVS builds. Upgrading to
1.0.99.2-2 broke font rendering for me. Basically everything works, but
about half of the fontsą show a peculiar problem: they don't show up, but
when I select text with mouse, they appear. Or when I wave a window over
them. Then they vanish again. It looks like a caching / backing-store
problem. At least firefox, kate, gkrellm and opera show this.

Just to give you an idea what it looks like:

http://iki.fi/v/tmp/vf/kate_dialog_vanished_fonts.png
and after I hover mouse over the buttons:
http://iki.fi/v/tmp/vf/kate_dialog.png

http://iki.fi/v/tmp/vf/firefox_vanished_fonts.png
and after I selct text and hover mouse over the menu
http://iki.fi/v/tmp/vf/firefox.png

I'm running up-to-date Fedora Rawhide (devel release), kernel 2.6.17-rc1,
enlightenment 17-cvs and nvidia 8756. Downgrading kernel to 2.5.15-rc7,
nvidia driver to 8178, or running fvwm instead of E does not change the
behaviour. Disabling BackingStore, Composite or RenderAccel from xorg.conf
doesn't seem to help.

Xorg is slightly more of a hassle to downgrade, I haven't tried that yet.

I was almost sure it wasn't an NVIDIA problem since 8756 -> 8178 downgrade
didn't help, but sure enough "nv" driver doesn't exhibit this problem.

However, with older xorg-server, "nvidia" driver did work.

vnywn 04-09-06 04:00 AM

Re: Vanishing fonts with the newest Xorg builds
 
I have the same problem. Disabling render acceleration helps though.

http://www.nvnews.net/vbulletin/showthread.php?t=65564

sangu 04-09-06 04:22 AM

Re: Vanishing fonts with the newest Xorg builds
 
See Also : http://www.nvnews.net/vbulletin/showthread.php?t=66968
The same problem happens.

vnywn : Disabling RenderAccel, this problem doesn't be fixed in my linux box. :(

cat /var/log/Xorg.0.log
Code:

[...]
(**) NVIDIA(0): Option "RenderAccel" "False"
(**) NVIDIA(0): Disabling RENDER acceleration
[...]


d4rk74m4 04-09-06 05:24 AM

Re: Vanishing fonts with the newest Xorg builds
 
This is a completely different problem to the RENDER related one (which iirc, should be fixed in the latest driver).

I believe this problem is caused by ABI changes in Xorg. Anyone at nvidia able to confirm this?

nadavkav 04-09-06 07:14 AM

Re: Vanishing fonts with the newest Xorg builds
 
i have the same issue.

disabling RENDER extention solve it, but i get all the desktop icons and fonts in a non-antialised view.

i'm using fx5200 on p3 450 with fc-rawhide , after upgrading from 8178 to 8756.
2.6.16-1.2080_2.rhfc5.cubbi_suspend2

kindly,
nadav :-)

vherva 04-09-06 09:35 AM

Re: Vanishing fonts with the newest Xorg builds
 
Quote:

Originally Posted by sangu
(**) NVIDIA(0): Option "RenderAccel" "False"

Option "RenderAccel" "FALSE"
workaround works for me, too.

AaronP 04-09-06 02:10 PM

Re: Vanishing fonts with the newest Xorg builds
 
d4rk74m4 is right; there have been ABI changes in the X.org 7.1 release candidates that will break font rendering, and might break XV (I haven't tried it). Full support for the new ABI will have to wait for a future driver release.

_tf_ 04-09-06 05:24 PM

Re: Vanishing fonts with the newest Xorg builds
 
using gnome, switching font antialiasing to subpixel fixed it for me.
this works ok here with RenderAccel enabled.


All times are GMT -5. The time now is 09:30 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.