nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   More FC5 problems (http://www.nvnews.net/vbulletin/showthread.php?t=68282)

brblueser 04-12-06 07:15 AM

More FC5 problems
 
1 Attachment(s)
Hi,

I just upgraded from FC4 to FC5, and I am trying to make it work with my GT 6800, but nvidia driver refuses to work.

8756 driver installation went by just fine, and "modprobe nvidia" does work, but judging from X logs, it seems that it is trying to load its own glx module, and not nvidia's:

...
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2

Also, it tries to load GLCore, even though I removed it from /etc/X11/xorg.conf:

(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(WW) Warning, couldn't open module GLcore
(II) UnloadModule: "GLcore"
(II) UnloadModule: "glx"

Could it be that X11 7.0 looks for modules at a different location than the one the driver installer used?

nvidia-bug-report.log is attached. Any help will be much appreciated.

TIA

Andre

brblueser 04-12-06 08:06 AM

Re: More FC5 problems
 
BTW: the same glx module loading problem happens if I rollback to 8178 (patched) on FC5, so it does seem like Xorg 7.0.0 changed something the installer isn't aware of.

... OTOH I wouldn't be the only one experiencing this if the cause is simply an installation screw up. Could it be due to the way I am installing the driver? (./NVIDIA-Linux-x86-1.0-8756-pkg1.run.bin -aqn)

TIA

Andre

mrkh 04-12-06 09:42 AM

Re: More FC5 problems
 
I had a similar issue.
The NVIDIA installer was putting the modules in /usr/X11R6/lib, but xorg was looking for them in /usr/lib/xorg/modules

There's an installer option to specify where the modules should go, I can't remember it exactly, but run ./NVIDIA-Linux-x86-1.0-8756-pkg1.run.bin -A and it will list all the options.

Use /usr/lib/xorg/modules as the modules directory.

brblueser 04-12-06 12:16 PM

Re: More FC5 problems [SOLVED]
 
Nice, you just solved my problem =) _Now_ I feel I am running FC5 =) The option we want is:

--x-module-path=/usr/lib/xorg/modules

Attention NVIDIA folks: you'd better put this tip somewhere until a patch comes out, it will save users (and you ;-)) some headaches...

Thks a lot for the help,

Andre

SebKaine 04-12-06 01:01 PM

Re: More FC5 problems
 
(nana2)

You Rocks Guys ! After 5 hours i got it ! you deserve the Nobel Prize Dudes ,,,

Thanks A LOT :)

brblueser 04-12-06 01:05 PM

Re: More FC5 problems
 
=) I know what you mean... feels good to be back on track again, doesn't it? ;-) (I went through the same hell yesterday, but now all is fine)

BTW: all credit goes to mrkh, he solved the problem.

netllama 04-12-06 03:55 PM

Re: More FC5 problems
 
Installing the xorg-server-x11-sdk RPM before installing the driver would eliminate the need to install the driver without any additional options. Note that this has been discussed in other threads on this forum.

Thanks,
Lonni

brblueser 04-24-06 02:35 PM

Re: More FC5 problems
 
Hi Lonni,

sorry for the late reply, I overlooked your message. Indeed, I didn't know about xorg-server-x11-sdk RPM. Will it help if I install it now? (I mean, the way it is today I still have to provide --x-module-path everytime I upgrade the kernel)

TIA

Andre

arokh 04-24-06 03:41 PM

Re: More FC5 problems
 
Obviously you didn't read the sticky netllama put up:

http://www.nvnews.net/vbulletin/showthread.php?t=68681

It clearly says to install the sdk package. The package contains xorg-server.pc, which tells the nvidia-installer where to put the driver files.

brblueser 04-24-06 10:03 PM

Re: More FC5 problems
 
Indeed, I haven't read netllama's sticky, thks for the pointer.


All times are GMT -5. The time now is 05:58 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.