nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Xorg crashes upon init of GLX on gentoo (http://www.nvnews.net/vbulletin/showthread.php?t=68403)

octothorp 04-13-06 07:36 PM

Xorg crashes upon init of GLX on gentoo
 
3 Attachment(s)
My Xorg (xorg-server-1.0.99.2) crashes badly upon init of the GLX extension. Please help!

I've attached the bugreport, the log, the conf... If there's anything else, please let me know!

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/timmay:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.16-gentoo x86_64
Current Operating System: Linux timmay 2.6.16-gentoo #1 PREEMPT Thu Apr 6 07:17:41 CDT 2006 x86_64
Build Date: 13 April 2006
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 13 18:19:30 2006
(++) Using config file: "/etc/X11/xorg.conf-nvidia"

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Backtrace:
0: X(xf86SigHandler+0x95) [0x477245]
1: /lib/libc.so.6 [0x2afca3dc1260]
2: /usr/lib64/xorg/modules/drivers/nvidia_drv.so(_nv000158X+0xda) [0x2afca55d92ba]

Fatal server error:
Caught signal 11. Server aborting

[1] 4277 abort (core dumped) X -config /etc/X11/xorg.conf-nvidia

octothorp 04-13-06 08:36 PM

Re: Xorg crashes upon init of GLX on gentoo
 
I've downgraded Xorg and it works again.

After that I discovered my nice 1600x1200 went away, so I downgraded nvidia drivers and I'm back to normal.

To recap, it's the newest branch of Xorg that broke everything, and I just have to massage the configs to get the newer drivers to give me 1600x1200 I guess.

AaronP 04-13-06 09:39 PM

Re: Xorg crashes upon init of GLX on gentoo
 
Quote:

Originally Posted by octothorp
I've downgraded Xorg and it works again.

The NVIDIA drivers don't yet support the new ABI in xorg-server 1.0.99.1 and higher.

pichus 04-22-06 12:44 AM

Re: Xorg crashes upon init of GLX on gentoo
 
Hey, I got the exact same problem, no matter how many times I tried to reinstall/reupgrade xorg7/gentoo... Do you guys have any remedies to this problem beside just going back to xorg-6.8 or downgrading to nv driver?

the backtrace:
0: X(xf86SigHandler+0xb1) [0x469f48]
1: /lib/libc.so.6 [0x2b0b8639ae00]
2: [0x86e94f]

-=-=-=-=-

The system is
Linux-2.6.16-gentoo-r3 x86-64 (EM64t)
Pentium-4 3.6GHz (P4-660)
nVidia Geforce Go 6800 256MB

I can get "nv" driver to work, but "nvidia" driver doesn't work; after it shows the nvidia logo, the system would just crash, showing this backtrace error. Any ideas?

When changing to an older xorg-6.8.2, the driver works fine. I really want to get xorg-7.0 to work =/


Other people I have spoken with got this nvidia to work in xorg-7 (different setup though)... so is there anything i did wrong? I even tried to reinstall gentoo without any USE flags just to make sure that nothing is installed extra. That still didn't help the situation at all.
- Thanks.

energyman76b 04-22-06 02:35 PM

Re: Xorg crashes upon init of GLX on gentoo
 
You have to install 7.0

xorg-xserver 1.0.2
AND NOT THE DEVELOPMENT 1.0.99 VERSION

unmask properly and not 'everything' and install xorg-server 1.0.2 and related packages.


All times are GMT -5. The time now is 04:56 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.