nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Please help! Random freezing when running openGL applications (http://www.nvnews.net/vbulletin/showthread.php?t=68588)

xawen 04-16-06 10:35 PM

Please help! Random freezing when running openGL applications
 
1 Attachment(s)
Hey all...I really hope someone can help me out here...

I'm running a Fedora Core 5 system with the 8756 drivers installed from Livna and the 2.6.16-1.2080 kernel from the official repository. On the hardware side, I've got a PNY GeForce 6600 card with a Dell 1907FP on the DVI port and a 1905FP on the analog port.

Hardware acceleration is working and I'm getting a good FPS in glxgears. But when I run an openGL application the entire system will lock up after a few (2-30) minutes. No mouse, keyboard...hard reboot is the only way out. The frustrating part is that I can't find a scrap of information in ANY log file. I don't think the system ever gets the chance to report a problem. I'm relatively sure it's not a hardware problem since I do not have a similar problem in Windows.

Strangely, openGL based screensavers and glxgears seem to be exceptions, but it may just be a matter of time.

The only thing I've been able to confirm is that it's not an overheat issue.

I've tried everything I can think of (or read about)...here's the list:
NvAGP instead of agpgart
acpi=off
apm=off
turning off all services not needed to startup and run X
reverting to driver 8178
enable dpms
disable Sync to VBlank
disable Allow Flipping
set Override Antialiasing Settings
set Override Anisotropic Filtering
system BIOS upgrade
IRQ setting changes

None of this has had any effect. :banghead:

I've got nothing left I can think of to try. If anyone can help, I'd love some suggestions. The bug report from my system is attached, but since the problem is a hard lockup I couldn't take it right after the crash (had to reboot first).

Thanks!

netllama 04-16-06 10:46 PM

Re: Please help! Random freezing when running openGL applications
 
Which applications trigger the instability?

Thanks,
Lonni

xawen 04-16-06 11:45 PM

Re: Please help! Random freezing when running openGL applications
 
With the exception of the screensavers, it seems to be any openGL app running for a significant time.

I've been able to reliably reproduce the freeze with the games GL-117, Neverball and Scorched 3d. The Second Life Linux client was also able to lock the system up pretty quickly.

quetzyg 04-17-06 03:16 AM

Re: Please help! Random freezing when running openGL applications
 
Same problem here!

xawen 04-17-06 07:31 AM

Re: Please help! Random freezing when running openGL applications
 
Good to hear I'm not crazy then :D ...

Adding to the "things that didn't help list":

-edited my xorg.conf to disable twinview
-booted with just the DVI port plugged in
-booted with just the analog port plugged in

Still don't see any change. What I wouldn't give for one error in a log...

xawen 04-17-06 03:00 PM

Re: Please help! Random freezing when running openGL applications
 
Just for kicks I got rid of the libGL.so files that shipped with the Fedora install (part of mesa I think). I don't think they were being used though.

It doesn't seem to have changed anything, but I can't test the screensavers now (had to remove them for the rpm dependency on mesa).

I'm still seeing the same lockups on the other openGL apps mentioned above...

Anyone have any suggestions for me?

xawen 04-17-06 11:26 PM

Re: Please help! Random freezing when running openGL applications
 
And it continues...

-Completely removed xscreensavers
-re-re-reinstalled the Nvidia drivers from Livna (just to make sure they were working after deleting all the libGL.so files)
-Tried different AGP aperture settings
-Ran memtest86...no errors

I'm about ready to kick this thing out the window... Is there anything specific I can look at or change to track this down?

olger901 04-18-06 05:15 AM

Re: Please help! Random freezing when running openGL applications
 
Could you post your type of PSU?

xawen 04-18-06 07:41 AM

Re: Please help! Random freezing when running openGL applications
 
It is only a 300 Watt ATX supply. It's below the specs on the box, but I disconnected the unused drives to save power after I started havin problems. Also I don't have these lockups when running the equivalent apps (Doom 3, SL) in Windows.

I'll borrow a bigger PSU from a friend a give that a try (may take a few days) and update the thread...or hook the 6600 up to a dedicated psu.

Even though I'm not seeing this in Windows, are these lockups something you would expect from a power shortage?

Thanks...

xawen 04-20-06 05:52 PM

Re: Please help! Random freezing when running openGL applications
 
Ok...well I got my hands on a 400 watt power supply (a nice Antec one too) and I have the same freezing.

I just don't know what else to try. My last resort is going to be a reinstall of Fedora (just in case I messed something up along the way) but I really really don't want to do that.

Anyone have any ideas?

goghgoner 04-29-06 09:15 PM

Re: Please help! Random freezing when running openGL applications
 
Sorry, no help here. I am using the latest nvidia driver on FC5_64. I have a ASUS CSM mobo w/ 6150 GPU. When I run any gl game or glxgears for 5 minutes the system freezes. It happened on FC4_64, too. No problem playing 3D games in Windows.

kenbo 07-31-06 08:21 PM

Re: Please help! Random freezing when running openGL applications
 
For what it's worth, I'm having the exact same prob. with an ATI card! no solution as of yet.


All times are GMT -5. The time now is 02:03 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.