nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Blank screen of death - nvidia and Redhat 8 (http://www.nvnews.net/vbulletin/showthread.php?t=6860)

ahenders 01-29-03 12:09 AM

Blank screen of death - nvidia and Redhat 8
 
I running Redhat 8 with kernel 2.4.18-19, and installed a nvidia driver by source. The card is a RIVA TNT2 M64.

Now X starts up just fine, and I assume that the hardware accel and openGL are working as the "gears" demo runs very nicely but when I try to run other openGL apps the screen goes completely blank. It almost sounds like it has switched to a different screen mode - the click and hiss of static?

At this stage the screen res <ctl><alt><+> or <-> does not help, nor does switching apps or windows. There is simply nothing left to do but reset the machine. :confused:

Wolfman [TWP] 01-29-03 08:37 AM

Have you tried the ctrl-alt-Fx approch??

Switch to the screen, where you started X, and press ctrl-C.

Then restart X.

ahenders 01-29-03 05:45 PM

1 Attachment(s)
Thanx Wolfman I hadn't tried the old fn key approach. When I switch back to the original screen that x was started from I now find the xserver has aborted - caught signal 11. This at least explains why my screen was going blank.

The XFree86.0.log file doesn't really show the last thing the server tried to do - the two GetModeLine lines were there before the crash - see attached.

Wolfman [TWP] 01-30-03 06:11 AM

After looking at your XFree86.0.log.txt file. I noticed that you are also running a HW frame buffer. Try running X with the fbdevhw module in your XF86Config file disabled. And see how that goes. I've read on the forums that alot of people seem to have problems with that. (I checked mine and it was enabled too, so I removed it, without any change).. But then my system uses an AMD chipset, and the fbdevhw module reacts differently, from chipset to chipset...

ahenders 01-31-03 01:46 AM

Thanks Wolfman but unfortunately the x-server still crashes. I have more or less worked my way through all the FAQs. I did notice one thing I have two different versions of the openGL header files:-

ll /usr/share/doc/NVIDIA_GLX-1.0/include/GL/
-r--r--r-- 1 root root 148924 Jan 29 10:13 gl.h
-r--r--r-- 1 root root 9827 Jan 29 10:13 glx.h
-r--r--r-- 1 root root 10978 Jan 29 10:13 glxtokens.h

and also

-r--r--r-- 1 root root 77761 Sep 6 13:28
/usr/include/GL/gl.h
-r--r--r-- 1 root root 15916 Sep 6 13:28
/usr/include/GL/glx.h
-r--r--r-- 1 root root 8370 Sep 6 13:28
/usr/include/GL/glxtokens.h

Could this be part of the problem?

Wolfman [TWP] 01-31-03 07:42 AM

I don't think that will be a problem, as I have the same type of files in the same directories.

The only thing different being the creation dates.

This is a list of my files in the:
/usr/share/doc/NVIDIA_GLX-1.0/include/GL/ directory.

-r--r--r-- 1 root root 148924 Dec 9 10:26 gl.h
-r--r--r-- 1 root root 9827 Dec 9 10:26 glx.h
-r--r--r-- 1 root root 10978 Dec 9 10:26 glxtokens.h

I believe that the others are for the MESA driver, which is not used.


All times are GMT -5. The time now is 03:53 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.