nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problems with any drivers >1.0-7667 on Geforce FX Go5200 (http://www.nvnews.net/vbulletin/showthread.php?t=68947)

BinaryMan 04-22-06 05:22 PM

Problems with any drivers >1.0-7667 on Geforce FX Go5200
 
1 Attachment(s)
Hello everybody! :)

I've been searching the web for quite a long time and didn't find a solution to my problem yet - I hope you can help me out somehow..:

I am running a Samsung M40 WVM1500 notebook with an integrated NVidia Geforce FX Go5200 graphics board. lspci identifies it as: "VGA compatible controller: nVidia Corporation NV34M [GeForce FX Go5200 32M/64M] (rev a1)".

I am currently running Gentoo Linux with kernel 2.6.11.12, the last kernel of the 2.6.11.x series together with 1.0-7667 of the nvidia drivers. Everything works stable and fine using this combination.

Any other kernel >=2.6.12 and any nvidia driver newer than 1.0-7667 makes X hang on boot or - if it initializes X successfully - makes the system freeze when leaving X. I'm left off with a garbled screen or no video at all.

The current version of the nvidia drivers (1.0-8756) together with the newest available kernel (2.6.16.9) won't let me initialize X at all. After 5-10 seconds the lcd displays a fancy plasma-effect, starting from the lower right corner of the screen, then it spreads over the whole display. I've attached a photo showing this effect. The system is already locked up before this effect starts. I can't even access the notebook from another host.

I tried configuring kernels with and without framebuffer, agpgart on/off and played around with the nvagp setting in the xorg.conf.
I up and downgraded the notebook's bios - nothing helped.

The funny thing is: If I attach an external monitor to the notebook, everything works perfectly, X starts up and I can switch back to console as often as I want to.

I suppose I've spent about a week or so trying to figure out what the problem is - I can't find a solution.
Do you have any idea what else I could try out or if I am making a fundamental mistake? Unfortunately I can't post a bug-report because the system always locks up.

Thanks in advance for your help!

Binary

oli993 04-23-06 03:21 AM

Re: Problems with any drivers >1.0-7667 on Geforce FX Go5200
 
I had exactly this screen problem years ago on my Uniwill L372N1 All-in-one-PC with an integrated Geforce4 420 Go 32M, up to the 5xxx drivers if i remember correctly.
With later drivers (up to 8178) the problem switched to a black screen when trying to start X.
But now with the new 8756 drivers my problems are finally solved, thank god :)

A hint for you: Try

options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=1 NVreg_FlatPanelMode=0

in /etc/modprobe.conf, maybe this fixes your problem. Especially playing around with the NVreg_Mobile option is worth a try.

Greetings and good luck
Oli.

PS: Try starting X with "startx -- -verbose 6 -logverbose 6". Even after a hard reboot i was able to read the logs at /var/log/Xorg.0.log.

BinaryMan 04-23-06 08:36 AM

Re: Problems with any drivers >1.0-7667 on Geforce FX Go5200
 
Thanks, Oli!

Kernel 2.6.16.9 and the newest nvidia drivers are running fine with your module parameters!

What a beautiful sunday :-))


Greets
Binary


All times are GMT -5. The time now is 04:05 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.