nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   gcc-version-check failed (FC5) (http://www.nvnews.net/vbulletin/showthread.php?t=69004)

stephen_wq 04-23-06 08:01 PM

gcc-version-check failed (FC5)
 
In an attempt to install the drivers, and got the following:
gcc-version-check failed:
Could not compile gcc-version-check.c. Please be sure you have your distrubutions libc development package installed and that 'cc' is a valid c compiler name.
i have done what is in the sticky, but the install doesnt work, so i tried a search. This led me to use
export CC=gcc-3.4
which i then ran it again.
Result:
Could not compile gcc-version-check.c. Please be sure you have your distrubutions libc development package installed and that 'gcc-3.4' is a valid c compiler name.
I tried using gcc, and back to cc, and everything.
I even tried downloading any packages named gcc, or gcc-3.4 or anything of the like off yum, but it still doesnt work.
So what do i do, where do i get this compiler from, because i cant find it in the install packages for things off the disc, and its not in yum.
Ideas?
Distrubution: Fedora Core 5
Graphics chip: Geforce 4 mx440

edit: Dont know if this helps, but
gcc returns:
gcc: no input files
cc returns:
cc: no input files

So that must mean they are there?

edit2: I just installed the headers for glibc or whatever off yum, and tried again. Same result.
So i chose no to continue, and it tells me i dont have libc headers?
Why can there not be a precompiled one for the latest kernel? It would make things so much easier.

netllama 04-23-06 08:19 PM

Re: gcc-version-check failed (FC5)
 
Please post the installer log.

Thanks,
Lonni

Lithorus 04-23-06 08:27 PM

Re: gcc-version-check failed (FC5)
 
I would be very surprised if the kernel in FC5 is compiled with gcc-3.4, but rather gcc-4.1. Also I would suspect it to be called gcc41 or something like that. gcc-4.0 and gcc-3.4 is from Debian based distros AFAIK.

stephen_wq 04-23-06 08:48 PM

Re: gcc-version-check failed (FC5)
 
1 Attachment(s)
Please find attached the log

netllama 04-23-06 09:40 PM

Re: gcc-version-check failed (FC5)
 
Do you have glibc-devel installed?

-Lonni

stephen_wq 04-23-06 10:27 PM

Re: gcc-version-check failed (FC5)
 
Deleted original post

Yum removal tool tells me i have the following installed:
glibc
Version 2.4-5
glibc-common
Version 2.4-5
glibc-devel
Version 2.4-5
glibc-kernheaders
Version 3.0-5.2
glibc-utils
Version 2.4-5

And due to the sticky, everything in yum is up to date, using yumex default settings

edit:
Added more repos, and i am updating now, looks like theres new versions
Updated the versions

netllama 04-23-06 10:31 PM

Re: gcc-version-check failed (FC5)
 
Do you have gcc installed?

-Lonni

Lithorus 04-23-06 10:44 PM

Re: gcc-version-check failed (FC5)
 
What do you get when running 'gcc -v'?

stephen_wq 04-23-06 11:23 PM

Re: gcc-version-check failed (FC5)
 
the above command returns:
gcc version 4.1.0
yum remove says:
gcc version 4.1.0-3
libgcc version 4.1.0-3

is there any commands you think i should run before the installer, like that export CC="blahblah" one?

netllama 04-23-06 11:33 PM

Re: gcc-version-check failed (FC5)
 
You also need to install the glibc-headers RPM.

-Lonni

stephen_wq 04-23-06 11:45 PM

Re: gcc-version-check failed (FC5)
 
Installed the headers.
I tried an install with the standard cc as compiler, gcc as compiler, gcc-4.1 as compiler and none worked for version check.
so i hit no and continued, but it stills says i dont have the libc headers installed.
What do i do? what compiler should it be trying to use? cc?

Lithorus 04-24-06 08:38 AM

Re: gcc-version-check failed (FC5)
 
cc is just a symlink to gcc.
What kind of system are you running amd64(64-bit) or i386(32-bit)? Also you did not mention which driver version you are trying to install.


All times are GMT -5. The time now is 07:47 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.