nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [SOLVED] Multihead problems since update to 1.0-8756 (http://www.nvnews.net/vbulletin/showthread.php?t=69053)

ckrueger 04-24-06 03:16 PM

[SOLVED] Multihead problems since update to 1.0-8756
 
In earlier driver versions (1.0-8174 and prior), I was able to configure each output on a dual-head card as its own individual device. This was useful because the two displays on this card are totally different (one DVI, 1280x1024, the other standard D-sub, 1024x768 ). Also, this is a tri-head setup, so not having to mess with TwinView made the setup unbelievably easy. Below are the device sections in my xorg.conf as they were before the driver update (which was included in the update to 6.04):

Code:

Section "Device"
        Identifier      "NVIDIA GeForceFX 5600 Center"
        Driver          "nvidia"
        BusID          "PCI:1:0:0"
        Option          "ConnectedMonitor"      "dfp"
        Screen          0
        Option          "RenderAccel"  "true"
EndSection

Section "Device"
        Identifier      "NVIDIA GeForceFX 5600 Left"
        Driver          "nvidia"
        BusID          "PCI:1:0:0"
        Option          "ConnectedMonitor"      "crt"
        Screen          1
        Option          "RenderAccel"  "true"
EndSection

Since the update, I have rewritten both device statements from scratch screwing with the presence (and settings) of the "Screen" and "ConnectedMonitor" arguments, but nothing has yielded the correct effect. Whenever starting X now, it says that the device PCI:1:0:0 is already in use, and removing that statement keeps the device from even being acknowledged.

Also, I tried changing the "ConnectedMonitor" statements to what I was told replaced that flag - "UseDisplayDevice":

Code:

Section "Device"
        Identifier      "Center"
        Driver          "nvidia"
        BusID          "PCI:1:0:0"
        Option          "RenderAccel"  "true"
        Option          "UseDisplayDevice"      "DFP-0"
EndSection

Section "Device"
        Identifier      "Left"
        Driver          "nvidia"
        BusID          "PCI:1:0:0"
        Option          "RenderAccel"  "true"
        Option          "UseDisplayDevice"      "CRT-0"
EndSection

Has anyone successfully configured their nVidia setup with the new 8756 driver *WITHOUT* using TwinView? I'd appreciate any help I can get. Thanks!

Regards,
Campbell Krueger

ckrueger 04-24-06 03:32 PM

Re: Multihead problems since update to 1.0-8756
 
It looks like I answered my own questions after another ~10 minutes of dickin around with it. Hopefully my X config will help answer other peoples' questions in the future:

Code:

Section "Device"
        Identifier      "Center"
        Driver          "nvidia"
        BusID          "PCI:1:0:0"
        Option          "RenderAccel"  "true"
        Option          "UseDisplayDevice"      "DFP-0"
        Screen  0
EndSection

Section "Device"
        Identifier      "Left"
        Driver          "nvidia"
        BusID          "PCI:1:0:0"
        Option          "RenderAccel"  "true"
        Option          "UseDisplayDevice"      "CRT-0"
        Screen  1
EndSection

Section "Device"
        Identifier      "Right"
        Driver          "nvidia"
        BusID          "PCI:2:1:0"
        Option          "RenderAccel"  "true"
EndSection

Section "Monitor"
        Identifier      "Monitor"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Center Screen"
        Device          "Center"
        Monitor        "Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth          24
        EndSubSection
EndSection

Section "Screen"
        Identifier      "Left Screen"
        Device          "Left"
        Monitor        "Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth          24
        EndSubSection
EndSection

Section "Screen"
        Identifier      "Right Screen"
        Device          "Right"
        Monitor        "Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth          24
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Center Screen"
        Screen          "Left Screen" LeftOf "Center Screen"
        Screen          "Right Screen" RightOf "Center Screen"
        InputDevice    "Generic Keyboard"
        InputDevice    "Configured Mouse"
EndSection

Section "ServerFlags"
        Option          "Xinerama"      "on"
EndSection

Regards,
Campbell Krueger


All times are GMT -5. The time now is 01:40 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.