nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Twinview not working anymore (http://www.nvnews.net/vbulletin/showthread.php?t=69089)

mg007 04-25-06 08:49 AM

Twinview not working anymore
 
Hi,

after updating to xorg-7.0 on debian unstable and to nvidia drivers 8756 I only get output on one of my screens (the internal DFP of my laptop or the external CRT, this can be switched via UseDisplayDevice). What I see in the xorg-logfile is a suspicious warning about the mode "512x384" being too large for DFP-0 and it seems to be discarded.

this is from the xorg.conf:
Section "Device"
Identifier "GeForce4"
Driver "nvidia"
Option "UseEdidFreqs" "true"
Option "TwinView" "true"
Option "MetaModes" "1280x960 ,1024x768 @1024x960 +1280+0;,1024x768 @1024x768"
Option "SecondMonitorHorizSync" "31.5-68"
Option "SecondMonitorVertRefresh" "70"
Option "TwinViewOrientation" "LeftOf"
Option "NoTwinViewXineramaInfo" "false"
Option "NvAGP" "1"
Option "ConnectedMonitor" "CRT, DFP"
Option "UseDisplayDevice" "CRT, DFP"
EndSection
and this is an excerpt of the logfile:
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Option "UseEdidFreqs" "true"
(**) NVIDIA(0): Option "TwinView" "true"
(**) NVIDIA(0): Option "TwinViewOrientation" "LeftOf"
(**) NVIDIA(0): Option "SecondMonitorHorizSync" "31.5-68"
(**) NVIDIA(0): Option "SecondMonitorVertRefresh" "70"
(**) NVIDIA(0): Option "MetaModes" "1280x960 ,1024x768 @1024x960 +1280+0;,1024x768 @1024x
768"
(**) NVIDIA(0): Option "NoTwinViewXineramaInfo" "false"
(**) NVIDIA(0): Option "UseDisplayDevice" "CRT, DFP"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
(**) NVIDIA(0): enabled on all display devices.
(**) NVIDIA(0): TwinView enabled
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(II) NVIDIA(0): NVIDIA GPU GeForce4 420 Go 32M at PCI:1:0:0
(--) NVIDIA(0): VideoRAM: 32768 kBytes
(--) NVIDIA(0): VideoBIOS: 04.17.00.59.41
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 420 Go 32M at
(--) NVIDIA(0): PCI:1:0:0:
(--) NVIDIA(0): Samsung SyncMaster (CRT-0)
(--) NVIDIA(0): NVIDIA Default Flat Panel (DFP-0)
(--) NVIDIA(0): Samsung SyncMaster (CRT-0): 350 MHz maximum pixel clock
(--) NVIDIA(0): NVIDIA Default Flat Panel (DFP-0): 224 MHz maximum pixel
(--) NVIDIA(0): clock
(--) NVIDIA(0): NVIDIA Default Flat Panel (DFP-0): Internal Single Link LVDS
(II) NVIDIA(0): Option "UseDisplayDevice" "CRT, DFP" converted to "CRT-0,
(II) NVIDIA(0): DFP-0".
(WW) NVIDIA(0): Mode "512x384" is too large for NVIDIA Default Flat Panel
(WW) NVIDIA(0): (DFP-0); discarding.
(II) NVIDIA(0): Assigned Display Devices: CRT-0, DFP-0
(WW) NVIDIA(0): No valid modes for ",1024x768@1024x768"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1280x960,1024x768@1024x960+1280+0"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 960
(--) NVIDIA(0): DPI set to (95, 96); computed from "UseEdidDpi" X config option
Any help is appreciated

Martin

mg007 04-25-06 11:12 AM

Re: Twinview not working anymore
 
Hi,

found the answer myself after looking at the extended logfile. Changing SecondMonitorVertRefresh from 70 to 60 Hz made the edid values valid.

Before, the check for valid modes complained about modes needing 60 Hz being invalid because the monitor was capable of 70 Hz?!

Martin


All times are GMT -5. The time now is 11:47 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.