nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Any solutions for GCC 3.2? (http://www.nvnews.net/vbulletin/showthread.php?t=6976)

Regression01 01-31-03 01:14 PM

Any solutions for GCC 3.2?
 
My situation:

I am building a custom GNU/Linux OS involving no compilers besides GCC 3.2.1. Consequently, this means no libraries from GCC 2.x.x, meaning I don't have the old C++ ABI libs such as libstdc++-libc*. Thus, what I need is a copy of the GLX driver linked against the new ABI from GCC 3.2.1. Can anybody help me out here?

Thanks in advance.

bwkaz 01-31-03 04:22 PM

3123 works fine for me without the gcc 2.x libs. I've got gcc 3.2 only.

4191, though, gives me a "libGLcore.so: symbol __divdi3() not found" when I try to load the libglx.so X extension. I haven't seen anyone else with that error, though.

2960 did the same thing, and 3123 fixed it. I don't know how 4191 managed to regress, but it did for me at least. You might try it at least. If "glx" doesn't load (with a libGLcore.so error in your X log file), then try 3123.

Regression01 01-31-03 06:03 PM

Thanks for the idea; I'll give this a try tonight when I have a chance. The GLX module from 4191 is loading fine when I startx, but the issue is coming when I try to, say, build some app that uses the GL library, xlockmore for example. I get a typical "libstdc++-libcwhatever: library not found" error during linking.

bwkaz 01-31-03 11:58 PM

OK... libGL shouldn't have been compiled using C++, so it shouldn't care about the libstdc++ library. It's more likely the fault of the app you're compiling...

Does tuxracer work? It is a bit of a chore to get going (it requires a bunch of stuff, including tcl, which requires tcsh -- but there's a hint somewhere at hints.linuxfromscratch.org on how to get it all working), but it should be a decent test, as it compiled fine here.

Otherwise I can try that xlockmore package, and see if I can find something.

Regression01 02-01-03 02:17 PM

nevermind nevermind!!! damn... i miscalled this one....


OK. xlockmore wants libGLU.so, not anything from the nvidia package, and that's where the problem was. At the point when I built XFree86, I had GCC 2.95.3 installed because i needed the old libs to build a new java SDK (it requires an old SDK to already be present... chicken and egg problem)... and apparently, somehow XFree's libGLU.so got linked with the old C++ libraries. I have a hard time understanding how, but that's what happened. So now I have rebuilt Xfree86 with no old libs in sight, and problem solved.

Thanks for the help bwkaz, the thing about the libGLcore error set me thinking in the right direction.

bwkaz 02-01-03 02:41 PM

Ahh, OK, that makes (some) sense.


All times are GMT -5. The time now is 03:52 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.