nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Solaris (http://www.nvnews.net/vbulletin/forumdisplay.php?f=45)
-   -   Trouble with Solaris x86 (1/06). (http://www.nvnews.net/vbulletin/showthread.php?t=70395)

Aerides 05-18-06 04:15 PM

Trouble with Solaris x86 (1/06).
This problem might be easy or difficult to fix; I'm stumped ether way. I have a GF FX 5700 Ultra installed in my x86 system. The NVIDIA drivers install and work great with the 3/05(GA) release of Solaris 10. With the 1/06 (U1) release, fresh install or updated, the system freezes while starting X with the nvidia driver.

It looks like all the devices and links where created and configured correctly (I don't see any difference between GA and U1) and the module is reported as being loaded. I don't have a lot of information about what's happening because the log files are incomplete and don't show any errors.

I've tried every solution that I could find that seemed even remotely related and I'm still stuck. If anyone has any ideas I would be most grateful.

marcdw 05-19-06 11:25 PM

Re: Trouble with Solaris x86 (1/06).
Sorry to say I have the same problems. Installation of drivers
and rebooting with reboot -- -r caused some problems and
I was told to go into failsafe mode (which I didn't have so
I updated the OS).

Anyway, when the driver is loaded and X starts to load
the system is completely frozen. The Xorg log file will
either be empty or have lines showing pci devices.
Checking I found the device in question (pci10de,1e8) is
my AGP slot.
So I reckon the problem is there but why I don't know.

I've since uninstalled the driver/packages.

nForce2 (Shuttle AN32N Ultra)
SunOS Solar10E 5.10 Generic_Patch_118844-30 i86pc i386
X Window System Version 6.8.2 (Sun Xorg Release 1.1 for Solaris 10)
SUNWxorg-server package version:,REV=0.2004.12.15
SUNWxorg-server patches applied: 118966-11 119062-01

johnmartin 06-02-06 03:10 PM

Re: Trouble with Solaris x86 (1/06).
The transition from Solaris 10 3/05 to 1/06 introduced ACPI support
which may have issues with some BIOSes. Search through your BIOS
options and disable items that sound like:

USB legacy support

Aerides 06-08-06 04:14 PM

Re: Trouble with Solaris x86 (1/06).
The solution in post #5 to thread "8762 still locks up like 8756" by marcdw fixes the problem I was having. I just had to disable NvAGP with:

Option "NvAgp" "0"

Turns out the problem was easy to fix, it just took a while to figure it out. Though, I was sure I tried this before without success.:o

marcdw 06-10-06 05:39 AM

Re: Trouble with Solaris x86 (1/06).
Heh, I thought I had tried it too but what I think is that I was trying NvAGP
options 1 and 3 (being in the Linux mindset). But when I looked through
the README I found out that there's only two options, NvAGP or nothing.

Option "NvAgp" "0" ... disables AGP support
Option "NvAgp" "1" ... use NVAGP, if possible
Option "NvAgp" "2" ... disables AGP support
Option "NvAGP" "3" ... use NVAGP, if possible

I wonder what hardware NVAGP supports. Having an nForce mobo I was sure
there wouldn't be a problem.
Well, we went through a lot of hassle and wind up with a simple solution. :)


seaexplorer 06-10-06 03:19 PM

Re: Trouble with Solaris x86 (1/06).
Hello, everyone,

I'm building a new box for Solaris 10. It will be a dedicated box

Mobo A8n-SLI Delux, AMD64 3700+ CPU, MSI 6600 GT Card, 1GB RAM, Native (on board) network, sound. NEC ND-3540a DVD Drive.

Understanding that you have some knowledge and experience installing and running solaris 10, AM I looking for trouble with this hardware. I have Solaris 10, built 3/05 DVD Installation set.

Thanks for an advice.

All times are GMT -5. The time now is 10:05 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.