nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Newby with lib problem (http://www.nvnews.net/vbulletin/showthread.php?t=7091)

aboe 02-03-03 05:26 PM

Newby with lib problem
 
I've installed the new drivers like the read me tells me to do... but when I change xf86config... x crashes...

so I've looked in the readme to find out what is wrong and found that the libGl.so link to libGl.so1 that is linked to libGl.so.1.4191 etc, is mangled...

I'm a newby at linux so I don't know how to repair this...

I tried to upgrade the GLX again... but it won't make the file....

Everything else is in it place as is in the readme where everything is installed....

I hope somebody can help me, and understands what I'm saying... (first time user of linux) so if my questions seems stupid it is because I'm still learning.


Thanks

Aboe

bwkaz 02-03-03 06:03 PM

It would help to know how the symlinks are mangled.

What does ls -l /usr/lib/libGL* print? That will tell us how "mangled" things are. Throw the output between code tags ([ code] and [ /code], without the spaces) to make it a bit easier to read.

aboe 02-04-03 03:06 AM

libgl output
 
When I give that command it tells:

-rw-r--r-- 1 root root 13 feb 4 00:13 /usr/lib/libGl.so.1

so it seems libGl.so is gone...
but when I browse with Konquer it tells me that libGl.so has 0kb. and the properties of that files

says they're linked to libGl.so.1.2 in a different directory

bwkaz 02-04-03 08:52 AM

Hang on, wait a minute, back up.

Linux filesystems are case-sensitive. When I said libGL, I meant libGL. Not libGl. That's a different file, and actually, it shouldn't exist.

Try getting rid of anything that starts with libGl.

Then try uninstalling the NVIDIA_GLX package, and reinstall it from tarball.

Then, do a find /usr -name 'libGL*' and post what it prints (it'll probably take a while to churn through your /usr directory, though). You may have to move some files manually if they exist in strange places where the driver won't move them for you.

Also, right after installing NVIDIA_GLX, do the ls -l /usr/lib/libGL* again, and make sure the right files are there, pointing to the right places (anything pointing at /usr/X11R6/anything is very likely wrong, unless it's libGLU).

aboe 02-04-03 01:01 PM

Fixed libGL
 
Thanks for your advise....

I removed GLX completly and reinstalled it...
this time with --allfiles... and that does the trick...

Sorry by the typing error in the libGI=L business.

Now I've checked everything with... nv_check.sh.txt...
and it says kernel module not loaded...

but with nv.chooser.sh put out... I downloaded the kernel with what it says...

NVIDIA_kernel-1.0-4191.rh80up.athlon.rpm...

I've checked the kernel... and it is there...

how come it doesn't load?

bwkaz 02-04-03 02:14 PM

Some versions of nv_check have major issues with some versions of the nVidia driver, and this is especially the case if your distro doesn't use devfs and you're using a version of nv_check that I screwed around with at all. You should be able to debug things manually, though.

First, check the output of lsmod for nvidia. You're using 4191, so the correct module name is nvidia.

If it shows up, you should be good to go.

If not, try an /sbin/modprobe nvidia as root. If that works, it will print no messages at all, and if it doesn't, it will. So if you see no messages, you should again be good to go. If you do see messages, post them here.

Once the module is loaded, try to startx. That should work. If not, post the X log.

To get the module to load automatically, there are a couple of different solutions. But make sure the module will load manually first.

aboe 02-04-03 04:50 PM

modprobe
 
Hi there,

i've tried running your command, modprobe nvidia
in the sbin directory, it does nothing linux tells me he

bash: modprobe: command not found.

but when I look in the display section of the config...
it tells me that nvidia driver is loaded, and I saw the logo when X started... so this means everything is loaded, despite nv_check says kernel module isn't loaded...

Am I right??

Thanks again for helping me...

bwkaz 02-04-03 05:00 PM

Having "the current directory" in your PATH is a fairly large security hole, so the majority of distros don't put it in there.

Which means that changing to /sbin and running modprobe is not the same thing as running /sbin/modprobe. In the first case, if /sbin is not in your PATH (and it isn't, unless you do a "su -"), you'll get the "bash: modprobe: command not found" error message, and the second won't fail. :)

If lsmod (or /sbin/lsmod, if just plaing lsmod doesn't work -- I'm not sure where lsmod normally gets put) reports nvidia, then the nvidia module is loaded. I don't trust any GUI config tools unless I wrote them (there's no other way to know for SURE what they do and don't work with), but since you do see the logo, your setup is probably working.

aboe 02-05-03 11:01 AM

thanks,
 
I want to thank you then for your help...with my problems...

I'm still figuring out how Linux works... but this helps a lot,

My last question:

When I check everything in the display menu...

I see the right driver nvidia there... and under it... is a box with
accelerated 3d but I can activate it...

Is the nvidia driver already 3d active or this there a command line which must be put in the XF86config file?

bwkaz 02-05-03 12:16 PM

Yay GUI apps that don't work! :D

There is no "magic switch" that turns on or off 3D acceleration with these drivers. Not having a Load "glx" in your config file is a good way to disable it, but you very likely have that line in there.

The best test is not to run something that was written to only understand the DRI drivers -- RH's (I'm assuming RH, is that right?) display settings dialog -- but something that actually looks at whether direct rendering is enabled -- glxinfo.

Run glxinfo | grep -i direct, and that should print out either "direct rendering: yes" or "direct rendering: no". If it says yes, then it is very likely that 3D acceleration is enabled. If it says no, then 3D won't work, and you'd have to look at your X log (or at the rest of the messages that glxinfo gives) to find out why. But I'm betting it'll say yes.

The other test you can do is to run glxgears. Every 5 seconds, glxgears prints a framerate to the console that you start it from. If this framerate is low ("low" meaning <1000fps given a decent video card), then you probably don't have 3D acceleration enabled -- check the X log and the console you used to start glxgears, for info on why.

The third test is to run tuxracer. If it runs at more than 1 frame every 3 seconds, you have a working OpenGL+glx setup.


All times are GMT -5. The time now is 03:21 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.