nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problems with g4 ti4200-8X (http://www.nvnews.net/vbulletin/showthread.php?t=7092)

antarius 02-03-03 06:47 PM

Problems with g4 ti4200-8X
 
Hi all! I have ASUS V9280TD-8X (Geforce4 ti4200 with AGP8X). I use Linux Mandrake 9.0. I downloaded drivers from nvidia web site and installed them according ot readme file. But after I "startx", I get blackscreen. The log file gives no good information about problem. I changed videocard to my old Geforce2MX and everything worked fine. But I want to use my new g4 card. What should I do?

I use: Gigabyte GA-7VAX, 512mb DDR333 Sony. Fujitsu 20gb hdd.

Thank you.
Alexander

antarius 02-04-03 08:58 AM

My log
 
1 Attachment(s)
i attached my log file. I tryed everything and i am stuck.

bwkaz 02-04-03 10:03 AM

Have you tried backing the AGP bus down to 4x in your BIOS? I seem to remember a lot of people having issues with AGP 8x in general. I don't know if it's just not well supported yet, or if the problem is devices that don't conform to the published standard, or if the standard isn't published, but it seems that 4x causes fewer issues.

antarius 02-04-03 10:15 AM

bios
 
the bios doesn't let me change the agp 8x to 4x. It detects it automatically.

bwkaz 02-04-03 03:07 PM

OK... umm...

You might be able to back down to 4x by installing the NVIDIA_kernel from source -- specifically, from .tar.gz.

Unpack the .tar.gz archive, cd into the new directory, and edit os-registry.c. At the bottom, in the nv_parms array, remove the two underscores from the "__ReqAGPRate" parameter, so it looks like "ReqAGPRate" instead. Then save & exit, and run a make in that directory. Then su to root, and run make install (make install has to be run without X running, so that it can remove the old kernel module from memory).

Then edit your /etc/modules (or whichever file it is that Mandrake uses to automatically load modules) to add an NVreg_ReqAGPRate=4 to the nvidia module command line. You could also do it with an options nvidia NVreg_ReqAGPRate=4 line in modules.conf if that's how this module is being loaded.

Then start X up, and see if that helps.

antarius 02-05-03 06:35 AM

=)
 
Thank you for your help. I just changed Option "NvAgp" an everythong started ok. =)

bwkaz 02-05-03 08:59 AM

Oh... OK then, whatever. :)


All times are GMT -5. The time now is 11:08 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.