nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   S2891 Linux Sata installation (http://www.nvnews.net/vbulletin/showthread.php?t=71557)

FC5AMD64User 06-09-06 10:42 PM

S2891 Linux Sata installation
 
Gosh, I thought this problem was solved with the latest Linux kernel in Fedora Core 5!

Firstly some system configs:

Hardware:
TYAN S2891 (K8SRE) mobo
2x Opteron 250 2.4 Ghz
2x 1G RAM (1G per CPU) - Total 2G
1x NVidia NProfessional 2200 MCP (Sata Controller)
4x SATA2 Western Digital WD800JD 80Gb -Total 300Gb
BIOS 2.01.2891 (Release Date: 09/28/05)

O/S install media:
Fedora Core 5 x86_64 DVD

Problem:
This is new Linux installation on 'straight-out-of-a-box' hardware. Bootup is fine. All system components recognised, especially the 4 SATA drives. I've tried various combinations of the follwoting options to get the Linux installation going, but all ended up with the same problem - the system hangs (black screen with cursor cross) after Anaconda starts installation:

BIOS settings:
BIOS Main: O/S Installed [Linux]/[Other]
NV Raid Configuration: [Disabled]
MTRR Mapping: [Discreet] - Onscreen help says that Linux O/S may need this setting - not sure what this does.
Enable ACPI: [No]
Interrupt Mode: [APIC]/[PIC]

I've also passed the following commands at boot time:
Boot: linux acpi=off nnoapic nolapic noprobe

The problem looks like an old one with the sata_nv driver causing a kernel panic. When I do not install the driver (using noprobe) Anaconda travels a little further but falls over when no hardrives are detected (as you would expect). This leads me to believe that the problem lies with the sata_nv driver and the kernel. I've researched this and I was under the impression that the kernel fix would have been included in Fedora Core 5.

Any suggestions / help to get around this. Perhaps another Linux distro that works with the above setup?

Cheers.

FC5AMD64User 07-19-06 04:42 AM

Re: S2891 Linux Sata installation
 
Just thought I'ld close the loop for those that may have had the same experience. I finally got Linux to install without any problems using SuSe 10.0. I used Tyan Support's advice and used a commercial distribution that they support. After 3 weeks of solid searching and trying, it's a pity that I'm no closer to understanding what or why I had problems with FC 5.

Cheers.


All times are GMT -5. The time now is 06:04 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.