nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   SUSE10.1 - nvsound - unable to install after 2.6.16 patch - prefetch.h error? (http://www.nvnews.net/vbulletin/showthread.php?t=71580)

interzoneuk 06-10-06 01:13 PM

SUSE10.1 - nvsound - unable to install after 2.6.16 patch - prefetch.h error?
 
Hi.

Although I loved Suse 10 I ended up wiping it and replacing it with Gentoo due to one reason - I was unable to install the nvidia Nforce driver (from www.nvidia.com). Alsa works o.k but the quality of sound is not as good as the nvidia oss driver.

The driver installs in Gentoo (2006), Mandriva 10.1, Fedora 5, Kubuntu 5.10 (+dapper!), however not Suse.

In Suse 10 the driver would actually install, but when I activated the nvsound driver my machine would freeze at random.

In Suse 10.1 the driver does not even install.

I gentoo when i upgraded to the 2.6.16 kernel I used a patch to get it working (or i would get the remap_page_range problem), this patch works with gentoo and fedora, on suse after appling the patch I get a different error:

Below is the nforce-installer log showing the error (after patching the driver).

--------------------------------------------------------------------------------------------
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /home/morgan/Desktop/NFORCE-Linux-x86-1.0-0310-pkg1/nv
sound/main/nvmain.c:27:
include/linux/prefetch.h: In function ‘prefetch_range’:
include/linux/prefetch.h:62: warning: pointer of type ‘void *’ used in a
rithmetic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:558,
from /home/morgan/Desktop/NFORCE-Linux-x86-1.0-0310-pkg1/nv
sound/main/nvhw.h:35,
from /home/morgan/Desktop/NFORCE-Linux-x86-1.0-0310-pkg1/nv
sound/main/nvmain.c:29:
include/asm/io.h: In function ‘check_signature’:
include/asm/io.h:258: warning: wrong type argument to increment
/home/morgan/Desktop/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c: A
t top level:
/home/morgan/Desktop/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c:21
91: error: expected ‘)’ before string constant
make[4]: *** [/home/morgan/Desktop/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/ma
in/nvmain.o] Error 1
make[3]: *** [_module_/home/morgan/Desktop/NFORCE-Linux-x86-1.0-0310-pkg1/nv
sound/main] Error 2
make[2]: *** [modules] Error 2
-> Error.
ERROR: The NVIDIA kernel module was not created.
ERROR: Installation of the audio driver has failed. Please see the file
'/var/log/nvidia-nforce-installer.log' for details. You may find
suggestions on fixing installation problems in the README available on
the Linux driver download page at www.nvidia.com.
--------------------------------------------------------------------------------------------

Does anyone know how I can fix this? I would love to keep using Suse but if i can't fix this i'm going to use gentoo/kubuntu as my main desktop.

Cheers

P.S - sorry for posting this in 2 forums - i have posted before and got 0 response.

niqingliang2003 06-18-06 08:42 AM

Re: SUSE10.1 - nvsound - unable to install after 2.6.16 patch - prefetch.h error?
 
the same question!!!!! where is NV's techniqal support?

netllama 06-18-06 05:34 PM

Re: SUSE10.1 - nvsound - unable to install after 2.6.16 patch - prefetch.h error?
 
The NFORCE driver package is only recommended for older kernels. The in-kernel ALSA driver is the current recommendation for 2.6.16 or later kernels.

Thanks,
Lonni

interzoneuk 06-22-06 10:36 AM

Re: SUSE10.1 - nvsound - unable to install after 2.6.16 patch - prefetch.h error?
 
Thanks for the replies. I have since moved back to gentoo and the new kubuntu - nvsound driver works fine in both (gentoo is running 2.6.16 kernel)

If anyone has a solution I would love to try.

Cheers

B. Williams 07-05-06 09:03 PM

Re: SUSE10.1 - nvsound - unable to install after 2.6.16 patch - prefetch.h error?
 
As netllama said, compiling ALSA into the kernel is the best way to deal with Nvidia sound in 2.6.16+. My guide to ALSA/NForce sound support via in-kernel support is located here:

http://www.nvnews.net/vbulletin/showthread.php?t=72907

Regards,
Bradley Williams
Owner, BW Services


All times are GMT -5. The time now is 11:39 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.