nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Module not found error (debian, 1.0.8762) (http://www.nvnews.net/vbulletin/showthread.php?t=71763)

emericpro 06-13-06 11:16 AM

Module not found error (debian, 1.0.8762)
 
Hello all,

I'm having a very strange problem with nvidia drivers since a few days...

I upgraded from 1.0.7174 to 1.0.8762 and nearly at the same time upgraded my kernel to the latest version of 2.6.16.
I had always manages without problems to install nvidia drivers with module assistant ( with any kernel )

As always, module-assistant built the package with no error, installed the files where they should be, etc. BUT "modprobe nvidia" simply returns : "FATAL: module nvidia not found."

I tried many things : check gcc versions (kernel was built with 4.0.3 while 4.1.1 is on my system too), install without module-assistant but still with debian packages... nothing was better.

Eventually I tried using the nvidia-?????.run package, which successfully compiled - not without difficulties since i had to modify the gcc symlink to redirect to the 4.0... It loaded, but when i reboot, it just crashed... :(

So I uninstalled latest kernel (and purged any configuration file), reinstalled it, and tried the debian way again : nothing better...

Does anyone have an idea of what I'm doing bad?



PS. I noticed that the fact of not having nvidia-glx installed crashes amarok with no explicit crash report... surprising...

GutsBlack 06-13-06 02:11 PM

Re: Module not found error (debian, 1.0.8762)
 
Backup your libglx.so :
mv /usr/lib/xorg/modules/extensions/libglx.so /usr/lib/xorg/modules/extensions/libglx.so.old

Move module and glx module :
mv /usr/X11R6/lib/modules/drivers/nvidia_drv.o /usr/lib/xorg/modules/drivers/
mv /usr/X11R6/lib/modules/drivers/nvidia_drv.so /usr/lib/xorg/modules/drivers/nvidia_drv.so
mv /usr/X11R6/lib/modules/extensions/libglx.so.1.0.8762 /usr/lib/xorg/modules/extensions/libglx.so

AaronP 06-13-06 06:13 PM

Re: Module not found error (debian, 1.0.8762)
 
@GutsBlack: The "FATAL: module nvidia not found." message is printed when the kernel module can't be found, not the X driver. It usually indicates that the driver wasn't actually installed. "it just crashed" sounds like the module was installed but didn't work for some other reason.

@emericpro: Please uninstall the Debian packages and use the .run installer, and then post an nvidia-bug-report.log after trying to start X.

[Edit: fix typo]

emericpro 06-14-06 02:49 PM

Re: Module not found error (debian, 1.0.8762)
 
Quote:

Originally Posted by AaronP
@emericpro: Please uninstall the Debian packages and use the .run installer, and then post an nvidia-bug-report.log after trying to start X.

Arggh. It's very strange. I can't reproduce the crash i experienced yesterday. Now it seems to install perfectly with the .run installer, but it doesn't load when kdm starts...
(while modprobe nvidia now works perfectly...)
Code:

(EE) Failed to load module "glx" (a required submodule could not be loaded, 0)
(EE) Failed to load module "nvidia" (module does not exist, 0)

I'm trying to reproduce yesterday's crash now...

[EDIT] i just found out that someone else described the same problem with the .run in another thread... will look at it right now.

emericpro 06-14-06 03:17 PM

Re: Module not found error (debian, 1.0.8762)
 
What I feared happenned... the crash is still there.
after installing xserver-xorg-dev and reinstalling the driver, which solved the failed to load module error, it happenned again.
The computer totally hangs just after the nvidia logo disappears (it also crashes with the nologo option on...).

the Xorg log shows that it apparently fails when loading glx...

Code:

(II) NVIDIA(0): Setting mode "1280x1024"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) NVIDIA(0): v4l[/dev/video0]: using hw video scaling [UYVY].
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX

I'll try without glx right now...

emericpro 06-14-06 03:33 PM

Re: Module not found error (debian, 1.0.8762)
 
1 Attachment(s)
Quote:

I'll try without glx right now...
And that was the clue !
But even if X started with nvidia drivers... I've fixed nothing at all ! glx just doesn't work.
Is there a link with the fact i use debian which usually works with the nvidia-glx package (which can't be installed when installing nvidia drivers manually...) ?
And also, the bug with amarok appeared again... since it only runs when nvidia-glx is installed, don't know why...

[EDIT] Attached the nvidia-bug-report.log

emericpro 06-14-06 04:21 PM

Re: Module not found error (debian, 1.0.8762)
 
Partially solved. not satisfactory at all...

I forced installation of nvidia-glx (which causes the package to appear to be broken of course) and now it works like a charm.

kabars_edge 06-21-06 12:48 PM

Re: Module not found error (debian, 1.0.8762)
 
I'm having this same problem. I finally got the driver to install and run, but no GLX. Even if I force the install of the nvidia-glx-legacy package, glx still seg faults. Can anyone help?

Thanks,

Mark

zander 06-21-06 01:06 PM

Re: Module not found error (debian, 1.0.8762)
 
@kabars_edge: please generate and attach an nvidia-bug-report.log file (see http://www.nvnews.net/vbulletin/showthread.php?t=46678). How did you install the driver? Please note that if you chose to install using the .run package and have previously had the nvidia-glx package installed, but didn't remove that package with the --purge option, the /etc/init.d/nvidia-glx script is likely to have been left behind, which typically results in crashes when GLX is attempting to initialize following a system restart (this is probably also true for the nvidia-glx-legacy package). If this is the case, please remove the script and reinstall the NVIDIA Linux graphics driver.

knobby 06-21-06 03:11 PM

Re: Module not found error (debian, 1.0.8762)
 
I'm getting exactly the same 2 errors and mine is a fresh install, with debian etch netinstall only running x-window-system-core and gnome-core.

I installed with sh NVIDIA-Linux.......... can anyone advise on any switch I should use to install or is this a driver or etch problem?

Thanks.

zander 06-21-06 08:04 PM

Re: Module not found error (debian, 1.0.8762)
 
Please also note that if you're using a version of Debian GNU/Linux that ships with Xorg 7.x, you'll need to install the xserver-xorg-dev package prior to the NVIDIA Linux graphics driver installation.

topocho 06-21-06 08:26 PM

Re: Module not found error (debian, 1.0.8762)
 
Knobby

I had the same problem then you; Do exactly what Gutsblack said (see above) it worked for me because I did a clean installation using sh NVIDIA.... as you

Regards


All times are GMT -5. The time now is 09:07 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.