nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   twinvie probs (http://www.nvnews.net/vbulletin/showthread.php?t=7177)

TozZMania 02-05-03 11:04 AM

twinvie probs
 
hey all

say my prob of twinview is like that i cant use it
if i config my XF86Config-4 like that
# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "speedo"
Load "/usr/X11R6/lib/modules/extensions/libglx.so"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Lite-On"
ModelName "Lite-On L150ATA"
HorizSync 24.0-61.0
VertRefresh 56.0-85.0

ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce (fbdev)"
Driver "nvidia"
Option "DPMS"
#Extra
Option "NvAGP" "1"
Option "CursorShadow" "1"
Option "CursorShadowAlpha" "64"
Option "CursorShadowYOffset" "2"
Option "CursorShadowXOffset" "4"
Option "DigitalVibrance" "2"
#TV TwinView
Option "TwinView" "1"
Option "ConnectedMonitor" "DFP, TV"
Option "SecondMonitorHorizSync" "30-60"
Option "SecondMonitorVertRefresh" "50-50"
Option "TwinViewOrientation" "Clone"
Option "TVOutFormat" "COMPOSITE"
Option "TVStandard" "PAL-B"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

i got only one screen that display the X desktop and thats on my tv screen but i want to i on both screens can someone tell me what is worng with my XF86Config-4 file

thx

TA00 02-09-03 05:56 AM

He I'm missing the "Metamode" option!
Read the /var/log/XFree.xx.log - there you can read whats wrong.
Have a look at the README file too.
I'm using SuSE 8.1, GF4 MX440, Twinview works.

regards Christoph

TozZMania 02-09-03 02:28 PM

say can you post u r metamodes or the XF86Config file

TA00 02-10-03 03:14 PM

Okay!

option "Metamodes" "1280x1024,1024x786;1024x786,1024x786;800x600,800x 600"
First 1280,x1024 on LCD and 1024x786 on TV
second 1024x786 on both
third 800x600 on both
I'm using
option "TwinviewOrientation" "Clone" means both displays shows the same.
Hope that will help.

regards Christoph

TA00 02-10-03 03:37 PM

1 Attachment(s)
I found something else what's differnt to my XF86Config
1) option "SecondMonitorVertRefresh" "50-60" - yes I know PAL-B normaly only have a refresh of 50 hz but - I'm in germany and use PAL-B to with a normal TV.
2) I don't use option "ConnectedMonitors"

Have a lock at my XF86Config.

regards Chrsitoph

TozZMania 02-10-03 04:55 PM

whene i use the "connectedMonitor" "DFP, TV" then only my tv has a signal and my tft screen is black :((

but i will check out u r config and if i have anny Q i will poste them

thx

TozZMania 02-11-03 12:49 PM

damn, with the metamodes it doesn't work :((
the F#@^g config file wont work on twinview
:((

klio 02-12-03 02:59 PM

hi, i use this XF86Conf:
...
Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
Option "NoLogo"
Option "CursorShadow" "on"
Option "DontZoom" "false"

Option "TwinView"
Option "TwinViewOrientation" "Clone"
Option "MetaModes" "640x480,640x480"
Option "ConnectedMonitor" "CRT, TV"
Option "TVStandard" "PAL-B"
Option "TVOutFormat" "Composite"


EndSection
...

When I wanna watch movies over TV I have to choose "MetaModes" both 640x480 cause my tv don't supports more ;( ... Else ich choose "1024x768" "640x480"


All times are GMT -5. The time now is 11:00 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.