nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Legacy Graphics Cards (http://www.nvnews.net/vbulletin/forumdisplay.php?f=37)
-   -   Suse 10.1 GeForce2 GO Dell Inspiron 2650 Blank Screen (http://www.nvnews.net/vbulletin/showthread.php?t=71806)

Bob Smith 06-13-06 11:03 PM

Suse 10.1 GeForce2 GO Dell Inspiron 2650 Blank Screen
 
1 Attachment(s)
Hello,

I've been struggling to get the nvidia driver installed for use by a GeForce2 GO card on my Suse 10.1 which is running on a Dell Inspiron 2650. I've attached the 'nvidia-bug-report.log' (zipped) for everyone's reading pleasure. :-) The default Suse-supplied "nv" driver works fine, but my goal is to install the "nvidia" driver so that I have acceleration and can utilize XGL.

I've downloaded and installed the patched 7174 driver as per the instructions from http://en.opensuse.org/NVIDIA#Legacy_chipset_support, no problem with that install as far as I know. After the installation and after having run 'sax2 -r -m 0=nvidia' I took a look at the xorg.conf and note that the driver is still set at 'nv' I manually change 'nv' to 'nvidia' and either restart X or reboot. Regardless of the restart process, the initial Suse boot screen comes up but before it displays the login screen, the screen goes blank/black and there is nothing that I can other than reboot the PC and restart in failsafe mode so that I can change the driver back to 'nv' so that I can log in again.

After having gone through the forums and trying a number of different things I am at my wits end on what to do next. A couple bits of information that might assist in debugging the problem:

1) Even after I've installed the 7174 driver and go into Yast-Software Management and search for 'nvidia' 3 items show up:
a) tiny-nvidia-installer
b) xorg-x11-driver-video-nvidia
c) xorg-x11-server-glx

Thinking that the default driver is getting in the way, I'm wondering what would happen if I uninstalled these - would doing so create a problem with me be able to ever log in again?

2) I've tried out the Kororaa .2 live CD. Using the XGL provided by that distro, the graphics and XGL are fine on this same laptop, leading me to think that the existing BIOS and video card are capable of using acceleration. When starting up Kororaa, the nvidia logo shows up.

If there are any suggestions that someone has I sure would appreciate it!

Best regards, Bob

nV`andrew 06-14-06 08:51 PM

Re: Suse 10.1 GeForce2 GO Dell Inspiron 2650 Blank Screen
 
bump

nemecb 06-14-06 10:14 PM

Re: Suse 10.1 GeForce2 GO Dell Inspiron 2650 Blank Screen
 
I'm afraid I stopped at kernel 2.6.7 on my 2650 due to issues with newer versions and various drivers (including nvidia IIRC), so about the only suggestion I can give is to possibly ask this question again in the linux forum. I think you're more likely to get the attention of the nvidia devs there.

Bob Smith 06-20-06 07:25 AM

Re: Suse 10.1 GeForce2 GO Dell Inspiron 2650 Blank Screen
 
Hi,

Thanks for the suggestion on posting my query on the Nvidia Linux Forum, I've done that. Meanwhile, I'll keep playing around with this problem. I really do think there's a solution since I can use the Kororaa Live CD on this same laptop and with that Live CD, use XGL and see the Nvidia splash page during startup.

- Bob

Bob Smith 06-29-06 06:44 PM

Re: Suse 10.1 GeForce2 GO Dell Inspiron 2650 Blank Screen
 
I continue to work on this issue, with the most recent effort using the new 7182 (legacy) driver. Some progress has been made in that I have absolutely no errors (EE lines) in the Xorg.0.log file. But I still have the problem that when I try to start X, the screen goes blank (and I can't get out of that mode) and I have to reboot to get back into the system (sans X).

I've tried several different NvAGP settings in the xorg.conf, but all with the same results.

If anyone has some ideas on what to try next and/or logs that might contain clues, I'd sure appreciate the help!

Thanks.

Bob Smith 07-09-06 08:56 AM

Re: Suse 10.1 GeForce2 GO Dell Inspiron 2650 Blank Screen
 
Hi,

I have this working now. Please visit http://www.nvnews.net/vbulletin/showthread.php?t=71907 for my steps.

Regards, Bob

nemecb 07-09-06 11:21 AM

Re: Suse 10.1 GeForce2 GO Dell Inspiron 2650 Blank Screen
 
Whew, that was quite the solution. Thanks for posting the steps though.


All times are GMT -5. The time now is 10:38 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.