nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   SuSE 8.1, 4191, garbled screen (http://www.nvnews.net/vbulletin/showthread.php?t=7214)

myitcv 02-06-03 08:03 AM

SuSE 8.1, 4191, garbled screen
 
Dear All,

Using NVIDIA provided 4191 SuSE 8.1 RPMS. Upgrade from the SuSE provided NVIDIA rpms (which work, if somewhat slowly). init 5 (or startx) to test new driver and I receive a terminal type screen with completely garbled text all over it. Machine is still responding, eg to Alt-Ctrl-Del, but no sensible screen output (even on a virtual console) - the screen appears to have locked.

Any help much appreciated.


Paul

TA00 02-09-03 05:52 AM

I have SuSE 8.1 working with the latest nv-driver - but I use the tar-files and compile it. No problems.
Do you use sax2 to configure X ??
For other tip's I need more informations.

regards Christoph

myitcv 02-11-03 05:48 AM

still no luck
 
no luck. I have an Asus A7V, GeForce 2 GTS. Using SuSE 8.1, gcc 3.2, recompile either via src.rpm or tar.gz I still receive a black screen (much like a console) with garbled text all over it. Cannot restart X, but machine is otherwise responsive (consolse still does not work).

TA00 02-11-03 06:32 AM

Do you want/use a grafic (X) login ?
The drivers can only be installed in init3 mode - no X server running ! If the X server ist running the nvidia-kernelmodule could not be changed - it's used. So if you come from a grafic login, you have to kill the X server (strg-alt-backspace)
If you want a grafic console - the framebufferdevice must set correctly. I don't know how to do this because I don't use framebuffers. I'm using vgamodes to display 40x80 char in consolemode.

regards Christoph

jtill 02-12-03 04:10 AM

same problem
 
Hi myitcv,
i had exactly the same problem as you. suse 8.1, newest nvidia driver, geforce 2 mx 400. When starting x, ascii-garbled screen and lockup with just ctrl-alt-del working. I solved it first by adding

Option "NvAGP" "0"

to the /etc/X11/XF86Config file in the device-section, directly below the "driver"-line. Then it worked, but without agp support. Setting the Option to "1" (See /usr/share/doc/packages/nv_glx/readme) should have enabled nvidias agp support, but didnt work (x started, but still no agp). setting it to "3" (enabling the kernel-modulized agp support via agpgart) reproduced the crash. that changed when i entered the BIOS and changed the agp rate to 1. Now it works!! With agp support. You can check if agp is working by typing: cat /proc/driver/nvidia/agp/status when x is running. Good luck!
But my problem still is: Every opengl game has short "locks" (about 0.3 sec) in regular intervals, although e.g. tuxracer runs with 70 fps. Does anyone know how to fix that?


All times are GMT -5. The time now is 12:27 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.