nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   suse 10.1 not suspending to ram. (http://www.nvnews.net/vbulletin/showthread.php?t=72158)

M3PH 06-20-06 08:59 PM

suse 10.1 not suspending to ram.
 
1 Attachment(s)
i know i posted about this before and i know this topic is old but it would seem each occurance of this is unique to an extent, so here goes.

i have an asus v9999GT, which for all those not up on your 3rd party model numbers is a Nvidia 6800GT AGP. I run it on a gigabyte GA-7n400 pro2 rev.2.0 (nforce2 chipset on there) with an AMD Athlon XP 3200+ and 1GB ram (ddr 333).

now i have done weeks worth of research on this and comp up with nothing much except what is contained in the following link: http://forums.suselinuxsupport.de/in...pic=38781&st=0

As you will see i have done quiet a bit towards finding a solution. even recompiling my kernel to remove all agp drivers.

anyway, I'm in desperate need of a fix for this because it's starting to stretch my patience to an extreme (i am normally a extremely patient person). I have a feeling it is something to do with the suspend software in suse 10.1 or something to do with the acpi features in the kernel.

anyway i hope someone has a solution for this. cheers for any help that you can provide.

M3PH

p.s. as a side note i would also like to know how to enable fast writes.

cheers again all

M3PH 06-21-06 01:38 AM

Re: suse 10.1 not suspending to ram.
 
right, i've stayed up all night looking round these wnderful forums trying to find some extra info on my issue and it would seem that i have only scraped the surface. Tbh i feel like a noob again. so i think the plan of attack now is to run me thru all the software suspend tools and give me a run thru all the relevenat driver options in as simple as you can language.

sorry for "moving the goal posts"

M3PH 06-22-06 10:23 AM

Re: suse 10.1 not suspending to ram.
 
hey all.

It's been a couple of days now and no one has replied :(. i signed up and posted because someone i respect highly from another forum said you guys were, and i quote, "friendly and helpful". so far you've proved him wrong, which isn't good.

FYI i think this issue is worse than first thought as i have tested suspend 2 disk and that is doing exactly the same thing as suspend 2 ram. so surfice to say i have no suspend function at all.

so some major help is need here and fast. hell if i have to bribe you guys with cold hard cash to help me then so be it. I'm get desperate.

oh btw before i forget, (bump) (foshiz)

septo 06-22-06 06:55 PM

Re: suse 10.1 not suspending to ram.
 
To enable fastwrites, add the following to /etc/modprobe.conf

Code:

options nvidia NVreg_EnableAGPFW=1
I wish I could help with your suspend to ram issue, but I don't have access to a suse box atm.

To fix this:

I can't mount my fat32 partition or my friends usb external hdd.

make menuconfig

->File Systems->DOS/FAT/NT Filesystems

and enable the stuff in the next page.

Quote:

To use suspend with the binary only driver for NVidia graphics cards, you need to take some extra precautions. Note that this apparently does not work on all NVidia graphics chipsets, YMMV:
Maybe have a look around for someone else who got it working using the same chipset?

M3PH 06-22-06 10:27 PM

Re: suse 10.1 not suspending to ram.
 
i solved the mount problem that compile was missing the utf8 codepage so it couldn't read the disks right, anyway i've got a working and optimized kernel know so i wouldn't worry about that.

Where exactly do i put the option for fast writes in modprobe.conf coz i had a look and it didn't seem obviuos for a location. cheers for the help tho.

scamiran 06-23-06 07:19 AM

Re: suse 10.1 not suspending to ram.
 
I have the same problem. AMD64 system, Nforce3 chipset, 6800GT.

S2RAM, S2DISK both fail. If I S2RAM or S2DISK in console mode my system DOES come back up, but I get no video; I can login as root (at console) and reboot my system.

I have so far determined nothing ;-) Fast writes don't help. Here's how you work modprobe.conf.local, on suse (by the way, the file you want is modprobe.conf.local, not modprobe.conf . Don't touch modprobe.conf)

options nvidia <insert module options here>

so for fastwrites type what septo wrote in the bottom line of modprobe.conf.local .

SuSE sources modprobe.conf.local AFTER modprobe.conf , so anything there will get loaded. Additionally, you could create a separate file in modprobe.conf.d/ , called "nvidia" , and drop that line in it. the entire contents of modprobe.conf.d/ will be sourced by modprobe


I'm determined to get Suspend working, too, but I don't have a lot of time. Please post your solution here if you get it, I will as well.

M3PH 06-23-06 08:47 AM

Re: suse 10.1 not suspending to ram.
 
cool cheers for the advice. i'm in windows atm but when i get back into linux and get time to look at it i will make those changes and see about doing so more research.

digulla 06-24-06 04:36 AM

Re: suse 10.1 not suspending to ram.
 
Hello,

I'm seldom in this forum, so I saw this only today.

Have a look at http://en.opensuse.org/NVIDIA. At the bottom are links to the NVIDIA Suspend HOWTO with a couple of tips.

I managed to get S2DISK working with using a patched NVIDIA-Linux-x86-1.0-7174 driver (an old one). See the page for instructions.

Right now, I'm trying again with the 8762 driver which just came out (June, 22th).

I'll post my results on the NVIDIA page on opensuse.org, so they're all in one place.

Regards,

M3PH 06-24-06 08:24 AM

Re: suse 10.1 not suspending to ram.
 
hang on, isn't the 8762 driver like a month old. or is the suse patched one that actually works?

M3PH 06-24-06 11:13 AM

Re: suse 10.1 not suspending to ram.
 
i've had time to do a bit more research today into my problem. and it would appear i missed a switch when installed the drivers. but it would appear my sound card is not compatable wit suspend2 and my nforce board is know to have issues too, so i give up. I'll just have to accept that suspend2 is gonna take a while to support my system but as i'l be upgrading to a x86_64 system within the next 8 months or so i'll just have to make so clever purchase's so suspend2 will give me support out of the box.

cheers for all your help guys. it's been much appreciated.

M3PH.

digulla 06-24-06 03:29 PM

Re: suse 10.1 not suspending to ram.
 
Hello,

I've now installed 8762 and it works without any changes with suse 10.1 with S2DISK. I didn't try S2RAM.

Regards.

M3PH 06-26-06 05:08 PM

Re: suse 10.1 not suspending to ram.
 
what's your systems/vitual info. it helps to know more than it just works, buddy


All times are GMT -5. The time now is 02:10 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.