nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Recover from GLX update "bug" (http://www.nvnews.net/vbulletin/showthread.php?t=7217)

Gozer 02-06-03 09:52 AM

Recover from GLX update "bug"
 
I have a fresh install of RH8. I ran NVchooser.sh to determine the correct drivers. I was able to update the NVIDIA_kernel just fine. However, when I went to install NVIDIA_GLX-1.0-4191 I could not find the current GLX version to rpm -e. I ran `rpm -gla | grep GLX` and found nothing. I also checked /usr/share/doc/ for the GLX docs and found nothing. I skimmed around the Gnome2 system utilities and found nothing. So, I went ahead and ran rpm -Uvh on the new NVIDIA_GLX driver without first doing the prescribed rpm -e. Well, as the README indicated, it messed everything up. I ran rpm -e on the new GLX driver I just installed and it let me startx without any perceivable problems. However, it's still not happy and when I log out of X it displays a list of errors apparently related to the now missing files. And, I'd like to make sure I have installed the latest drivers correctly.

What steps do I take to clean up the mess so I can start over? And, where did I go wrong trying to find my current version of GLX to erase first? I suspect I'm not the only one that had their impatience get the better of them.

Thanks

bwkaz 02-06-03 01:06 PM

rpm -qa | grep GLX prints nothing? If it prints nothing, then you don't have an older version of the NVIDIA_GLX package installed. Many distros (Mandrake, for example) don't. I know SuSE does, but I don't know about RH.

If you don't have an older package installed, then go ahead and install the version you have again.

Are you sure you made the necessary changes to /etc/X11/XF86Config (or XF86Config-4 if it exists)? This is detailed in the README, so I would think you did. But you say nothing about it, so I figure it's probably a good idea to ask. ;)

If it still doesn't work after installing NVIDIA_GLX and editing your X config file, then attach your /var/log/XFree86.0.log file. It will probably have some indications of what to do in it.

Gozer 02-06-03 02:19 PM

Apparently there must not have been a previous version of GLX then. I'll take another look at the XF86Config and the directions to make sure I made the correct changes/additions.

Thanks

Gozer 02-07-03 09:18 AM

As it turns out, RH8 does not install GLX on the initial install. I also had a typo in my XF86Config that would have prevented it from starting.

bwkaz 02-07-03 02:18 PM

So is it working then?

Gozer 02-07-03 02:27 PM

Yep, working just fine. As mentioned elsewhere in these forums, this newest version isn't spectacular with 2D. Have yet to try 3D, but soon.

Thanks for the help!


All times are GMT -5. The time now is 12:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.