nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X won't load due to GLX error? Reverting to old config file doesn't help! (http://www.nvnews.net/vbulletin/showthread.php?t=7238)

arsenius 02-06-03 06:43 PM

X won't load due to GLX error? Reverting to old config file doesn't help!
 
1 Attachment(s)
Hi guys,
Having some trouble installing drivers obviously. I've tried installing from source, and from rpm on two machines, and I'm having the same problem on both. One card is a Geforce 4 and the other a Geforce 4 MX. Fresh installs of Redhat 8.0 psyche on each.

If I just leave the XF86config file the way it is, it works fine, and I can get into X, but obviously that is unaccelerated (which pretty much renders these machines useless, since we are using them for graphics at my work:) )

I'm installing the drivers exactly as it says in the README, and making only the changes it specifies. When I startx it errors out, giving me the following error:

Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) [GLX]: Initializing GLX extension

Fatal server error:
Caught signal 4. Server aborting

Changing back to the old config file DOES NOT fix the problem, nor does commenting out the 'load "glx"' line in modules. I also have tried commenting out the 'Section "DRI"' part as I also saw that suggested on these forums.

I did a search on this forum for "[GLX]: Initializing GLX extension", and didn't come up with anything (aside: why does the search function not let quotes designate a string to be searched for? it just parses it up as though they weren't even there) The only thing I can think of at this point is that it is a bug with redhat 8. I use debian on my personal machine, and haven't had problems like this w/ the drivers.

My XF86Config is below, and I am attaching my XFree86 log as well.

thanks in advance


# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Mouse1" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

FontPath "unix/:7100"

EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
# Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"

# Option "AutoRepeat" "500 5"

# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
#Option "XkbVariant" ""
#Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection


Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30.0-96.0
VertRefresh 48.0-160.0
Option "dpms"


EndSection

Section "Device"
# no known options
Identifier "NVIDIA GeForce 4 (generic)"
# Driver "vesa"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"

#BusID
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 16

Subsection "Display"
Depth 16
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

EndSection

#Section "DRI"
# Mode 0666
#EndSection

bwkaz 02-06-03 08:59 PM

Re: X won't load due to GLX error? Reverting to old config file doesn't help!
 
Quote:

Originally posted by arsenius
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!

This one is a symptom of not having removed the Load "dri" line in XF86Config (or XF86Config-4, if it exists). Remove it, and try again (though this probably isn't why you're seeing the error...).

Quote:

Fatal server error:
Caught signal 4. Server aborting

According to man 7 signal (the list of the "standard" signals for a Linux system), signal 4 is SIGILL, or illegal instruction.

Which processor is installed on these systems? Which driver files (what were their names) did you install?

zatnktel 02-07-03 09:51 AM

i need some more info which driver did you install i have redhat 8 running fine with ti4200 but what i had to do to install the driver was install the glx the the kernel rpm then install the tar ball because the kernel rpm has problem installing nvidia.o but the tar ball does but you have to install the kernel rpm as well that is how i got it wroking with mine and the changes you made to the XF86Config looks right

what sort of system do you have

email me if you like at
akiross@optushome.com.au

arsenius 02-07-03 12:35 PM

i have tried the 4191, 4180, and 3123 versions all in tarball format. i have also tried the 4191 version with rpm.

The systems are a dual processor P3 500 512MB RAM GF4MX, and a 2GHz Pentium 4 1024MB RAM GF4 (not sure what version in that one). Beyond that I don't know much about the systems, the first is a dell, the second is something else.

What is really bothering me though, is the fact that I get the same error even if I go back to the XF86Config that was installed with the system.

bwkaz 02-07-03 02:26 PM

Reverting XF86Config wouldn't help if the old one loaded glx as well, and the illegal instruction was inside the libglx.so file. Which was why I was thinking that was the problem.

How about you get rid of ALL versions that you have (ESPECIALLY 4180, because 4180 isn't even for your processor), and try 3123 from scratch -- the .tar.gz 3123. Make sure you run X before installing the drivers, and try again immediately after installing them and modifying XF86Config. Then, if you get the same signal 4 error, revert XF86Config and uninstall the drivers with a make uninstall from the directory you did the make install from, and try X again. If it still doesn't work, then, well, you're seeing something very, very strange.

If it does work, then the problem may be that the files got corrupted. Possibly. Before decompressing, run md5sum on each tarball, and make sure the checksum matches what's posted on the driver download page, to try to prevent that.

Are you positive your memory, memory->CPU bus, L2 cache, and L1 i-cache are all flawless? If instructions are getting changed in one of those places, then that would do it. You might want to try memtest86 if you suspect one of those.

arsenius 02-09-03 02:40 PM

I have tried commenting out the GLX line in the config file also, but GLX still loads.

Almost forgot, make uninstall doesn't work for either the kernel module or GLX. You can do make clean for the kernel module, but not for GLX.

bwkaz 02-09-03 06:40 PM

make uninstall doesn't work? Hmmm. Well, anyway, this should:

find /lib/modules \( -name nvidia.o -o -name NVdriver* \) -exec rm -f {} \;

Once that's done, do the following:

find /usr/X11R6/lib -name nvidia_drv.o -exec rm -f {} \;
find /usr/X11R6/lib -name libglx*.so -exec rm -f {} \;
find /usr/lib -name libGLcore* -exec rm -f {} \;
find /usr/lib -name libGL.so* -exec rm {};
(this one will ask for confirmation -- make SURE it doesn't delete anything that isn't nVidia!)
find /usr/X11R6/lib -iname libxvmcnv* -exec rm -f {} \;

And that should get rid of everything. Run through that, and then start over with 3123.

EDIT: WAIT A MINUTE! Are you still using Driver "vesa"? According to that log file, you are. This is NOT right, you should be using Driver "nvidia" instead!


All times are GMT -5. The time now is 08:47 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.