nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nForce4 Onboard sound card (http://www.nvnews.net/vbulletin/showthread.php?t=72834)

MiKuS 07-03-06 01:00 AM

nForce4 Onboard sound card
hi there, i'll start off by saying i'm using ubuntu dapper drake.

basicly my problem is as follows- i have a 8.1 speaker set up in my room, but the problem is linux will only use left and right speakers, not even the bass (tinny bass annoys me) so all day today i've been bashing away tring to get these damn drivers to work (the ones that nvidia provides)

also just won't cut it i've been changing sliders and menus for the last 2 hours and i've only managed to make it sound worse.

i've tried using the nvidia installer and it ran fine but i have nfi how to 'activate' the drivers i tried adding a module in modprobe or whatever it's called, i've tried rebooting after each change and no luck, i hope you guys can help me.

also i should add when i try to run the command (after running the nvidia installer) 'nvmixer' i get the error " nvmixer: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory "

TheTaz 07-03-06 10:42 PM

Re: nForce4 Onboard sound card
If the install completed, I think you have to edit your /etc/modprobe.conf file (with sudo) and change the driver to nvidia's.

It's been a long time since I messed with that.

For fast answers jumping on Ubuntu's IRC channel is the best idea.


But your XChat should already be pre-configured to point to Ubuntu's channels by default, in Dapper Drake.

Hope that helps,


MiKuS 07-04-06 01:56 AM

Re: nForce4 Onboard sound card
unfortunatly i've tried all of the above.

when i went into the IRC channel i got told exacly what you said about the modprobe thing (i'm still pretty new to using linux and have nfi with that group of files)

i posted in thier forum (http://www.ubuntuforums.org/showthread.php?t=207631) but the post got 23 views and no replys even after BUMPing it once.

do you know if this card works 100% with linux, or that it's possible for sure?
i have spend a large portion of today trying to make it work, i've manage to make my sound go back to how it was (after borking it trying to activate nvidia drivers)

i hope you can still help.


TheTaz 07-04-06 10:53 AM

Re: nForce4 Onboard sound card
When you ran the nvidia installer... did you do it a terminal window with sudo?

Or did you just double click the installer in the Nautilis file manager?

Whenever you install something for the system or 'all users'... you have to install it as the 'root user' (administrator). In ubuntu and most other distros, you predicate the command with sudo. That only works once per command.

So.... you get package by vendor... use Nautilis to 'un-tar' or 'unzip' (usually in your home directory)... open a terminal window and type:

cd /home/username/new_directory (or wherever the new directory may be located)

now for nvidia nforce you type

sudo sh NFORCE-Linux-xXX.-X.X-XXXX-pkg1.run

It will ask for your password, then Follow the installation prompts.

For software that you may have to compile....
sudo ./config
sudo make
sudo make install

For running a graphic program as root.... the command is gksudo.

gksudo nautilis

Brings up a graphic password check, then a file manager with root user priveleges. (dangerous for a newbie)

Anyway... that last one you can add in an icon shortcut, and use a root nautilis to navigate around when you have to edit system files like /etc/modprobe.conf. ;)

Ok... about editing modprobe... this is straght out of the nvidia documentation:

Configuring the audio driver
For SuSE Linux Enterprise Server 9, at the time of writing it isn't possible to use YaST to configure the nvsound audio driver. Following the instructions in other distributions to edit the configuration file /etc/modprobe.d/sound.
Red Hat
For Red Hat Enterprise Linux version 3, Red Hat 8, Red Hat 9 and Fedora Core 1, follow the instructions in other distributions to edit the configuration file /etc/modules.conf.

For Fedora Core 2 and later, follow the instructions in other distributions to edit the configuration file /etc/modprobe.conf.
Mandrake / Mandriva
At the time of writing, it isn't possible to use Mandrake Control Center to configure the nvsound audio driver.

Follow the instructions in other distributions to manually edit the configuration file. For Mandrake 10 or other Mandrake distributions running 2.6 kernels, the configuration file is /etc/modprobe.conf. For earlier distributions that run 2.4 kernels, the configuration file is /etc/modules.conf.
Other distributions
If the distribution you are using provides a configuration mechanism for audio drivers, use it to select the nvsound driver module for use with the nForce audio device. Otherwise, manually edit the module configuration file.

If your configuration file already contains an entry for the i810_audio or snd-intel8x0 drivers (open-source audio drivers that supports the nForce audio controller), that entry needs to be commented out with a # or removed:

# alias sound-slot-0 i810_audio

Add the following lines to the configuration file:

alias sound-slot-0 nvsound
alias snd-intel8x0 off
alias i810_audio off

On some distributions, you may need to replace sound-slot-0 with snd-card-0.

If you wish to have nvmixer audio settings automatically restored each time the nvsound driver loads, add the following lines to the configuration file for 2.4 kernels:

post-install nvsound sleep 1; /usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1 ||:
pre-remove nvsound /usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1 ||:

For 2.6 kernels:

install nvsound /sbin/modprobe --ignore-install nvsound ; sleep 1; /usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1 || :
remove nvsound { /usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove nvsound

For both 2.4 and 2.6 kernels, you should add the following code to /etc/rc.d/init.d/halt, or /etc/init.d/halt.local on SuSE distributions. On Mandriva distributions, add the code at the end of function stop_mixer() in /etc/rc.d/init.d/sound.

if grep -q "\(nvsound\)" /proc/modules && [ -x /usr/bin/nvmix-reg ]; then
/usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1

(In /etc/rc.d/init.d/halt, this code is best located next to any existing code that saves ALSA mixer settings.)

For Red Hat Enterprise Linux 4, Fedora Core 3 and later, add the following line in /etc/rc.local:

/usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1

Loading The Drivers

The installer may or may not leave the new modules loaded after the installation, depending on the existing configuration. You can force the module to be loaded using insmod or modprobe :

insmod <modulename>


modprobe <modulename>

On subsequent reboots, the modules should load automatically.

Hope that helped,


MiKuS 07-04-06 04:57 PM

Re: nForce4 Onboard sound card
i know about sudo and gksudo ;) and yes, i ran the file as root by:

typing sudo into terminal then dragging the file (puts the path/to/file in there for me) which installed fine. i'm currently running the 2.6 kernel which is where my problem is, i have no sbin directory in / only a sbin in usr, and even still in my usr/ directory there is nothing to do with modprobe, at all. after some more investigation ubuntu uses a system where the modprobe is a directory full of files. the files are only like..one mod it's kinda hard to explain, but there is no one file (like modprobe.conf)
the directory where the files reside is - etc/modprobe.d/

in there theres a file called alsa base, here is it's contents


# autoloader aliases
install sound-slot-0 modprobe snd-card-0
install sound-slot-1 modprobe snd-card-1
install sound-slot-2 modprobe snd-card-2
install sound-slot-3 modprobe snd-card-3
install sound-slot-4 modprobe snd-card-4
install sound-slot-5 modprobe snd-card-5
install sound-slot-6 modprobe snd-card-6
install sound-slot-7 modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd modprobe --ignore-install snd $CMDLINE_OPTS && { modprobe -Qb snd-ioctl32 ; : ; }
install snd-pcm modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { modprobe -Qb snd-pcm-oss ; : ; }
install snd-mixer modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { modprobe -Qb snd-mixer-oss ; : ; }
install snd-seq modprobe --ignore-install snd-seq $CMDLINE_OPTS && { modprobe -Qba snd-seq-midi snd-seq-oss ; : ; }

# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 modprobe --ignore-install saa7134 $CMDLINE_OPTS && { modprobe -Qb saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2

i tried to make a nvidia module in there but that didn't work at all and as for nvmixer i got that working by installing the kde librarys, which was only really a fluke, as i was installing amarok and when i was looking for a fix for the missing library i saw the only users that were being effected were those of KDE so i decided to try it and bam it works but whenever i try to change the volume on some of the sliders it gives me an error.

here is my nvidia file from the modprobe.d directory:


alias sound-slot-0 nvsound
alias snd-intel8x0 off
alias i810_audio off
install nvsound /sbin/modprobe --ignore-install nvsound ; sleep 1; /usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1 || :
remove nvsound { /usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove nvsound

All times are GMT -5. The time now is 07:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.