nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GForce 5500 Blank screen & no response with debian 2.6.8-2 & Xorg 7.0 & 1.0.8762 (http://www.nvnews.net/vbulletin/showthread.php?t=73000)

andr01d 07-06-06 10:27 AM

GForce 5500 Blank screen & no response with debian 2.6.8-2 & Xorg 7.0 & 1.0.8762
 
1 Attachment(s)
Hi all,

Though I'm new here I already like this forum - everyone look very professional & helpful... :)

My problem is as follows:
I'm running a Debian testing release with 2.6.8 kernel (tried 2.6.15 & 2.6.16 too) Xorg 7.0 & Nvidia drivers (from nvidia site) ver. 1.0.8762.

When I try to start X (kdm for example) I get a blank black screen.
Cannot switch to other console (CTRL+ALT+F1 doesnt respond),
cannot restart X server (CTRL+ALT+Backspace doesnt respond),
cannot break (CTRL+C doesnt work).

The only thing I can do is CTRL+ALT+DELETE which reboots my machine as expected.

Moreover, immediately after I get switched to graphic mode - my PC beeps. Attempting one of the above mentioned key sequences results in another single beep.

If I let it be - not touching anything, after about 40 sec my screen returns to ASCII mode and starts FLASHING RED AND GREEN :)
It is very amusing, but is a little annoying after a while.
Once that happens - the machine stops responding to keyboard and has to be hard-reseted.

I have tried running kernels 2.6.14, 2.6.15, 2.6.16 with same success.
Tried installing debian repository drivers with module-assistant and all - nothing... I'm totaly frustrated with this.

I have a Gigabyte GeForce 5500 w/ 256MB connected to 2 17" CRTs.

Logs show that the hangup happens right after GLX component is loaded.

Also, there are very weird lines appearing in Xorg log:
(WW) NVIDIA(0): WAIT (2, 3, 0x8000, 0x00000000, 0x00000dc8, 0)

Any ideas?

netllama 07-06-06 10:43 AM

Re: GForce 5500 Blank screen & no response with debian 2.6.8-2 & Xorg 7.0 & 1.0.8762
 
I have a few questions:
0) If you unset NvAGP or set it to 0, does that have any impact?
1) If you remove the ConnectedMonitor option from your xorg.conf does that have any impact?
2) If you boot with the acpi=off and/or noapic kernel parameters, does that have any impact?
3) Does this only reproduce with TwinView?
4) Have you verified that you're using the latest BIOS for the motherboard?

Thanks,
Lonni

andr01d 07-06-06 11:49 AM

Re: GForce 5500 Blank screen & no response with debian 2.6.8-2 & Xorg 7.0 & 1.0.8762
 
Hello Lonni,
thanks for the prompt reply.

Regarding your questions:
0. Tried changing to 0-3 & removing from config - no impact.
1. Tried removing - same behaviour.
2. Tried booting with acpi=off & noapic - same behaviour.
3. This happens without TwinView too.
4. Haven't updated the bios since I've purchased the mobo, will try it now.

Also, I forgot to mention that the same setup was working perfectly before upgrade to Xorg7, so it doesnt look like hardware failure.

GuGle 07-09-06 08:36 AM

Re: GForce 5500 Blank screen & no response with debian 2.6.8-2 & Xorg 7.0 & 1.0.8762
 
I have the same problem, but with GeForce 6200.
Operating system: Suse Linux 9.2,Gentoo linux
Card: NV GeForce 6200
Before this card I had Radeon 9600XT, drivers worked.
At Window$ all works.

andr01d 08-23-06 07:07 AM

SOLVED! Re: GF5500 Blank screen& no response w/ debian 2.6.8-2 & Xorg 7.0 & 1.0.8762
 
Sorry for the bump.

The issue was RESOLVED! :)

The problem was as follows.

Apparently /usr/src/linux was symlinked to the wrong directory of kernel-headers!
I was running 2.6.8-2 & the kernel headers that /usr/src/linux linked to were from 2.6.15-1!

What I did to resolve the issue:
1. Installed kernel 2.6.16-2-k7 (didnt upgrade before because I thought it was the thing that caused the problem).

2. Installed kernel headers for the kernel above. KERNEL HEADERS MUST MATCH KERNEL PRECISELY!

3. Removed all Debian packages related to Nvidia.

4. Using the official nvidia installer - installed the drivers.

5. Started X! And it worked!

Commands to run:

apt-get install linux-headers-2.6.16-2-k7 linux-image-2.6.16-2-k7
cd /usr/src/ && rm -f linux && ln -s linux-headers-2.6.16-2-k7 linux
dpkg --purge `dpkg -l | grep ^nvidia | awk '{print $2}'`
export CC=/usr/bin/gcc-4.0 && sh NVIDIA-Linux-x86-1.0-8762-pkg1.run
startx

PLEASE NOTE:
1. I'm pretty sure I could just install the nvdia packages back using apt-get & module-assistant. I just chose not to.

2. You will probably want to choose the kenel & headers that fit your architecture (I run Athlon XP 2500+, so it's k7 for me).

3. The "export CC..." was used because the kernel in question was compiled with gcc 4.0 and my default gcc is 4.1. If the gcc version doesn't match - Nvidia installer will be kind enough to notify you about it - so just use CC=/usr/bin/gcc-X.Y, where X.Y is the version of the gcc.

Thank you for your help!
Hope this helps anyone!

P.S: Dear NVIDIA team - i'd be more than glad if the installer would check if the headers version matches the kernel, could eliminate hours of debugging :D


All times are GMT -5. The time now is 09:30 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.