nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Redhat Beta 8.1 / Intel HT cpu (smp). Installation impossible! (http://www.nvnews.net/vbulletin/showthread.php?t=7342)

Barlad 02-09-03 09:36 AM

Redhat Beta 8.1 / Intel HT cpu (smp). Installation impossible!
hello there,
I tried to compile the nvidia drivers (the latest version and the 3123 one).
Everytime I launch the compilation, I get the following error :


+ install -m 0444 nvidia.o /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.20-2.21smp/kernel/drivers/video
install: cannot stat `nvidia.o': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.59450 (%install)

RPM build errors:
user buildmeister does not exist - using root
group buildmeister does not exist - using root
user buildmeister does not exist - using root
group buildmeister does not exist - using root
Bad exit status from /var/tmp/rpm-tmp.59450 (%install)
That's if I do it from the src.rpm, that error is not really "talkative" but If I launch a make from the tar archives, I get this :


/lib/modules/2.4.20-2.21smp/build/include/linux/highmem.h: In function `bh_kmap':
/lib/modules/2.4.20-2.21smp/build/include/linux/highmem.h:20: warning: pointer of type `void *' used in arithmetic
nv.c: In function `nv_get_phys_address':
nv.c:2182: warning: implicit declaration of function `pte_offset'
nv.c:2182: invalid type argument of `unary *'
make: *** [nv.o] Error 1

I get the very same error for both versions.
Any idea please ?
I am using Redhat 8.1 beta (rc3?) with a Asustek E7205 motherboard and Intel PIV 3,06Ghz HT CPU (thus I have a SMP kernel)

Thanks in advance,


binro 02-09-03 10:38 AM

I tried to install the 4191 drivers on Red Hat 8.0.92 Beta (Phoebe).
If I compiled from the tarball against the suppied kernel source, the make
succeeded. The installation of the binary GLX libraries from the tarball also
worked okay (well, it would, wouldn't it!). However, when I started the X server
it segfaulted at the "load glx" statement. Removing this statement allowed the drivers
to load and the desktop started but without OpenGL acceleration. :-((

I successfully installed the 4191 drivers on a RH 8.0 (Psyche) system against a
2.4.20 kernel, so I think there is an incompatibility between the binary GLX
libraries and the XFree86 shipped with Phoebe.

bwkaz 02-09-03 11:17 AM

No, there is an incompatibility between the drivers as shipped and the 2.5 kernel backports that RedHat found it necessary to include in Phoebe's default kernel. The reason the drivers worked with your 2.4.20 is that the following features do not exist in 2.4.20:

There is now support for stuff like thread-local storage (aka TLS), and whatnot else. This probably isn't a problem unless you also use glibc 2.3 (though I could be wrong on that). Unfortunately, in order to do TLS, the kernel has to use extra segment registers in the x86 architecture (fs & gs). And these segment registers' values get clobbered by, you guessed it, the nVidia drivers.

The compilation problem (pte_offset) is a side effect of this. The kernel's definition of pte_offset changed to support TLS better (or for some other reason), and RH kept this change in their Phoebe kernels as well. The nVidia drivers call pte_offset with the old interface, which doesn't work.

There is no fix that nVidia has put out yet, because they don't support the 2.5 kernel (its interface changes too often to make it worthwhile). But seeing as RH saw fit to backport those changes into their Phoebe release, nVidia might want to hurry up on that one...

If you check around on this forum, someone posted a Phoebe HOWTO a while back. It involves patching your nVidia drivers, then passing extra options to the kernel or glibc that shut off TLS (and possibly some VM speedups, but I'm not sure on that one). The subject of the post was "RH Phoebe HOWTO" or something along those lines.

EDIT: Never mind, I went looking for that thread and didn't find it until page 4 or 5. Here's a direct link:


Barlad 02-09-03 11:46 AM

Thanks much for all the infos.
I guess I will look into the thread and try to solve the problem or wait till Nvidia solves it :)

3777 02-09-03 11:22 PM


Originally posted by Barlad
Thanks much for all the infos.
I guess I will look into the thread and try to solve the problem or wait till Nvidia solves it :)

Not going to happen. I gave up on the rpm's & that buildmeister crap a long time ago, now I only install via Tar. gz .....much easier too. Just do a search with my username, I'm sure I posted the instructions somewhere :D

Barlad 02-10-03 05:10 AM

Yeah, following the thread that was posted up there, I installed the drivers without any difficulty using the tar.gz.
That said WineX is royally ****ed on RH8.1 and that is the only reason why I wanted to have those drivers work ;)

binro 02-10-03 09:32 AM

Thanks to bwkaz for the detailed explanation. I think the way to
go is to reinstall Phoebe and then build a stock 2.4.20 kernel. I
never did trust RedHat patched kernels anyway!

All times are GMT -5. The time now is 11:32 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.