nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem of 1.0-8762 installation in 2.4.21--need help! (http://www.nvnews.net/vbulletin/showthread.php?t=73595)

100plus 07-18-06 05:39 AM

Problem of 1.0-8762 installation in 2.4.21--need help!
 
Hi,
I am trying to install a Quadro FX540 on RHEL3.0(2.4.21-27 X86_64) running on a DELL machine. From NV website, FX540 is supported by 1.0-8762. I setup and configure the 2.4.21 kernel-source. When I run the installer, there is an error occured during compilation of nv kernel, "vmap() appears to be unavailable in this kernerl". I wonder if this means that 1.0-8762 cannot be installed on 2.4.21 kernel, or I did something incorrect during the installation. I also applied the 8762's patch, but it doesn't work. Any comment? Thanks!

netllama 07-18-06 11:38 AM

Re: Problem of 1.0-8762 installation in 2.4.21--need help!
 
You stated that "I setup and configure the 2.4.21 kernel-source". If you're running RHEL3, all you need to do is install the kernel-source RPM that Redhat provides. If you've done anything beyond that, that's likely the source of your problem.

If you need further assistance, please post the NVIDIA installer log.

Thanks,
Lonni

100plus 07-18-06 10:58 PM

Re: Problem of 1.0-8762 installation in 2.4.21--need help!
 
1 Attachment(s)
Thanks for your reply Lonni. I installed SRPM instead RPM from redhat, and according to NV, the installation should be done without X server, then I am running under Level 3. I setup the kernel source in the default location /usr/src/linux. To configure the kernel source, I copied config file in /boot to /usr/src/linux/.config. Then in /usr/src/linux, I executed "make oldconfig" "make dep". After that, I think it should be a configured kernel source tree, am I right? I attached the log file, hope it helps. Thanks!!

netllama 07-18-06 11:47 PM

Re: Problem of 1.0-8762 installation in 2.4.21--need help!
 
You need to install the kernel-source RPM, not the SRPM.

-Lonni

100plus 07-19-06 03:15 AM

Re: Problem of 1.0-8762 installation in 2.4.21--need help!
 
After install kernel-source RPM, driver install succeed. thanks for ur advice!! However, when I reboot with X, although I saw Nvidia Logo already, the video card still cannot be detected. I checked system setting, the display card driver has been changed to "nvidia", but the "Memory Size" and "Video Card Type" remian unchanged. How can I detect the correct Video Card type after installed the driver??

netllama 07-19-06 12:09 PM

Re: Problem of 1.0-8762 installation in 2.4.21--need help!
 
The NVIDIA X driver should detect your videocard correctly automatically. Redhat's tools will likely not detect everything correctly if you are using the nvidia X driver.

Are you experiencing a functional problem beyond what Redhat's tools are reporting?

Thanks,
Lonni


All times are GMT -5. The time now is 07:17 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.