nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Anyone else with hard lockup with PCI-express? (http://www.nvnews.net/vbulletin/showthread.php?t=73671)

justinj 07-19-06 04:50 PM

Anyone else with hard lockup with PCI-express?
 
I know there are a few threads regarding a lockup on a PCI express 6200 with ATI RS480 bridge, but I'm trying to figure out if this is related ONLY to the 6200, or to ALL nvidia pci-express video cards paired with the ATI RS480 bridge.
I have random full system lockups just sitting idle about once a day, and it fails within the first few minutes of trying to watch a video. I have a gigabyte 6600LE card. I don't want to waste my time looking for another problem if this problem is for all nvidia pci-express cards on the rs480 chipset.

Basically, I'm asking - Does anyone else have hard lockups (a crash requiring reboot), with the NVIDIA pci-express cards (other than the 6200, a pr has evidently been opened for the 6200) using the latest linux drivers from NVIDIA? So has anyone else seen this on the 6600, 6800, or the 7300, or am I the only one?

My lockups go away when I use the open source driver, but my TV output goes away when I use the open source driver. I bought the card for TV output, so thats not really an option for me. I really don't want to have to buy a new motherboard or new graphics card to be able to use linux...

nukem 07-19-06 08:29 PM

Re: Anyone else with hard lockup with PCI-express?
 
Ive havnt had any lock ups with my evga 7800 GT on my ASUS A8N-SLI Premium(nForce 4 chipset). Mixing an ATI chipset with a nvidia gfx cards seems to be asking for trouble though. You might want to try getting the latest BIOS update.

asdere 07-21-06 11:55 AM

Re: Anyone else with hard lockup with PCI-express?
 
Yes, this problem has been around for a while if you're using the system under these circumstances:
PCI-Express or onboard 6150. Tested with 6200TC, 6600, 6150 all same result.
DVI output
Interlaced resolution

Playing any video file will either hard lock the whole system and/or the X windows system. If you use the VGA port instead of DVI, along with a VGA->Component transcoder like the 9a60, everything works fine without any changes to the xorg.conf.

avaspell 07-21-06 10:30 PM

Re: Anyone else with hard lockup with PCI-express?
 
Do you know if there a fix for this problem coming? I'm running into the same problem with a 7300 using 1080i component output. Hard locks when using Xv.

asdere 07-23-06 01:55 PM

Re: Anyone else with hard lockup with PCI-express?
 
Quote:

Originally Posted by avaspell
Do you know if there a fix for this problem coming? I'm running into the same problem with a 7300 using 1080i component output. Hard locks when using Xv.

Oh I forgot that it had the problem with direct component out also. The only workaround I know of is to setup a twinview configuration with the VGA port. You don't have to have anything connected to the VGA port, basically a "fake" twinview config.
Since the VGA port will be the primary sync device, you will see 'tearing' of the video every now and then, but the system will be 'mostly' usuable. After spending a few hundred dollars (multiple PCI-E cards, multiple motherboards and alot of time with kernel/xorg.conf) trying to get a pure digital 1080i, I gave up and spent another $100 on an external VGA->Component transcoder - less headaches.
It's not a hardware problem since 1080i output with video files under Windows works.

ange70 08-03-06 02:04 AM

Re: Anyone else with hard lockup with PCI-express?
 
Quote:

Originally Posted by justinj
I know there are a few threads regarding a lockup on a PCI express 6200 with ATI RS480 bridge, but I'm trying to figure out if this is related ONLY to the 6200, or to ALL nvidia pci-express video cards paired with the ATI RS480 bridge.
I have random full system lockups just sitting idle about once a day, and it fails within the first few minutes of trying to watch a video. I have a gigabyte 6600LE card. I don't want to waste my time looking for another problem if this problem is for all nvidia pci-express cards on the rs480 chipset.

Basically, I'm asking - Does anyone else have hard lockups (a crash requiring reboot), with the NVIDIA pci-express cards (other than the 6200, a pr has evidently been opened for the 6200) using the latest linux drivers from NVIDIA? So has anyone else seen this on the 6600, 6800, or the 7300, or am I the only one?

My lockups go away when I use the open source driver, but my TV output goes away when I use the open source driver. I bought the card for TV output, so thats not really an option for me. I really don't want to have to buy a new motherboard or new graphics card to be able to use linux...


Same problems on a 7300GS with accelerated 'nv' driver
No problema at all with 'nvidia' driver

:(


All times are GMT -5. The time now is 01:41 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.