nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Mandrake 9/Drivers/Dual Head support (http://www.nvnews.net/vbulletin/showthread.php?t=7378)

headbanger 02-10-03 11:45 AM

Mandrake 9/Drivers/Dual Head support
 
Like many, I had struggled to get my ti 4200 device functioning on Mandrake 9. First, I had a curious error installing the kernel RPM. Stupidly, I did not write it down, but the error said something to the effect that by installing the rpm, I am violating the GPL and the insmod line failed even though the hash progress showed 100%.

I cannot UNINSTALL the RPM since the message RPM is not installed appeared. When I try to reinstall it or update, I get the message all packages installed.

NONETHELESS, checking all the files and symbolic links, I seem to have everything except the files /dev/nvidia1, /dev/nvidia2, and /dev/nvidia3. The device did boot, and various checks on loaded drivers seem to indicate success.

I upgraded to this device in order to get dual head support. I could not achieve it with the Radeon VE I had.

After much work, I have both monitors working (sans Twinview) and wanted to share my settings in the hope it helps someone else.

XFConfig-4

Key highlights. 2 Monitors must be defined; 2 nVidia devices must be defined with Screen 0 and Screen 1 noted for each head; 2 Screen sections must be defined correlating to each Monitor and nVidia device; Server layout must mention each screen and use the Leftof or Rightof tag.

Key problems. No matter what I do, X always boots to the monitor attached to the DVI port with a DVI to VGA connector. Looking through the XFree86.0.log file seems to indicate the card sees the DVI monitor as head 0 EVEN THOUGH I program in the correct information.

Cannot shut X down to a terminal screen. Get black screen and can't reboot from there.

Some wavering of images on both screens.

However, I was able to get both monitors working at different resolutions and here are the excerpted parts of the relevant sections.

# here the two monitors are defined. nothing fancy.

Section "Monitor"
Identifier "Viewsonic"
VendorName "ViewSonic"
ModelName "ViewSonic PF95+"
EndSection

Section "Monitor"
Identifier "Envision"
VendorName "Envision"
ModelName "EN-5100"
EndSection

#here I identify the "two" cards that will drive each device. For some reason, Screen 0 is always the device on the DVI port.

Section "Device"
Identifier "device0"
BoardName "NVIDIA GeForce4 V"
Driver "nvidia"
Screen 0
BusID "PCI:1:0:0"
Option "DPMS"
#Option "ConnectedMonitor" "CRT"
Option "UseEdidFreqs"
EndSection

Section "Device"
Identifier "device1"
BoardName "NVIDIA GeForce4 E"
Driver "nvidia"
Screen 1
BusID "PCI:1:0:0"
Option "DPMS"
#Option "ConnectedMonitor" "DFP"
Option "UseEdidFreqs"
EndSection

#Here I try and match Screens to Devices

Section "Screen"
Identifier "screen 0"
Device "device0"
Monitor "Viewsonic"
DefaultColorDepth 24

Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubsection

Section "Screen"
Identifier "screen 1"
Device "device1"
Monitor "Envision"
DefaultColorDepth 24

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

# Here I try and place screens properly.

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen 1"
Screen "screen 0" Leftof "screen 1"
EndSection

#I did try switching Screen 0 and 1 and using Rightof instead of leftof. What happened was that I could not move Left of the RIGHT screen. If I went RIGHT of the right screen I would wrap around to the LEFT screen. I just swallowed it and left it as above. At least left is left, and right is right!
----------------------
The problems are that no matter what, X always boots to the screen 1 device. While frustrating, I can work with that!

I see one of two possible problems. 1) the kernel driver is broken, or 2) X is broken. There is a cryptic message in the log file:

(WW) NVIDIA(0): Multiple displays connected, but only one display allowed;
(WW) NVIDIA(0): using first display

Also, in the log file, Screen 0 (the Viewsonic attached to Device 0 comes in as Device 1!

(**) NVIDIA(1): Validated modes for Display Device 1:
(**) NVIDIA(1): Default mode "1280x1024": 157.5 MHz, 91.1 kHz, 85.0 Hz
======================

I can easily move my cursor across both screens and, as expected, cannot drag between them. The Viewsonic is coming in at 1280x1024 res, and the Envision at 1024x768. I am satisfied with the results. As I mentioned, there is some wavering of characters and images, but I do NOT do a lot of gaming. I just need two displayes for my work.

I hope this helps others.

bwkaz 02-10-03 05:06 PM

Where to start...

Your "non-GPL license" message is not an error, it's just a warning. insmod did not fail, and the driver installed just fine.

You can't uninstall the RPM because you were probably using the .rpm file name as an argument to rpm -e, right? That's not right, the rpm database entry does not contain version numbers or file extensions. Do an rpm -qa | grep -i nvidia to see the rpm database's package name, and run rpm -e on that in order to uninstall it.

/dev/nvidia[123] didn't exist because you are using devfs, and only the device files that exist as hardware are going to be in /dev. You're fine.

If you want full dualhead support, trash Xinerama, and enable TwinView instead. That way, you don't need multiple Device or Monitor sections at all. Read through the README for how to set it up.

You can't set the primary display regardless of how you set up dual-head support, though, I don't think.

headbanger 02-10-03 06:10 PM

Thx for the clarification! Not sure what I typed when trying to uninstall. But then, I don't really care that much, the thing works.

One point. I don't use Xinerama at all or Twinview. I actually wanted to have two screens separate and working before I tried Twinview. I actually had tried to get Twinview going but it failed each time and in many combinations. SO I decided to backtrack and simplify. I am not unhappy with this setup, although the documentation could have been better!

I still think there is a bug in either the nV driver or something's broken in X when it comes to dual head support. Oh well.


All times are GMT -5. The time now is 08:43 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.