nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Cannot get Resolution to Work. (http://www.nvnews.net/vbulletin/showthread.php?t=73968)

tama102 07-25-06 09:22 AM

Cannot get Resolution to Work.
I am using the latest Nvidia 8762 drivers.

I am using an infocus 4805 projector and I am trying to 1:1 pixel map my playback. I used the infocus modeline from the wiki which is 848x480 at 60 Hz I disabled all other modelines, and I commented out DPMS = true. When I start the computer, the projector displays that the signal is correctly set to 848x480. By the end of the boot sequence, when the Nvidia splash comes on the screen (just prior to the myth GUI starting) The image flickers and the resolution on the projector changes to 1024x768. I have already gone to the appearance settings and set everything to be viewed at 848x480. I also exited and opened an X shell and typed xrandr. It output that I was at my desired resolution of 848x480, with no other choices to switch to.

I have tried xwininfo and xvidtune, both display the 848x480 resolution.

Here is some more information:

I checked /var/log/XFree86.0.log and this is what I got in the relevant section:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): NVIDIA GPU GeForce 6200 TurboCache(TM) at PCI:5:0:0
(--) NVIDIA(0): VideoRAM: 262144 kBytes
(--) NVIDIA(0): VideoBIOS:
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 6200 TurboCache(TM) at
(--) NVIDIA(0): PCI:5:0:0:
(--) NVIDIA(0): IFS InFocusSP4805-D (DFP-0)
(--) NVIDIA(0): IFS InFocusSP4805-D (DFP-0): 155.0 MHz maximum pixel clock
(--) NVIDIA(0): IFS InFocusSP4805-D (DFP-0): Internal Single Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "848x480"
(II) NVIDIA(0): Virtual screen size determined to be 848 x 480
(WW) NVIDIA(0): No size information available in DFP-0's EDID; cannot compute
(WW) NVIDIA(0): DPI from EDID.
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
(--) Depth 24 pixmap format is 32 bpp

Here are some details from my XF86Config-F file
Section "Monitor"
# Warning: This may fry old Monitors
# Very conservative. May flicker.
# VertRefresh 50.0 - 62.0 # Extreme conservative. Will flicker. TFT default.
# Default modes distilled from
# "VESA and Industry Standards and Guide for Computer Display Monitor
# Timing", version 1.0, revision 0.8, adopted September 17, 1998.
# $XFree86: xc/programs/Xserver/hw/xfree86/etc/vesamodes,v 1.4 1999/11/18 16:5$
# 640x350 @ 85Hz (VESA) hsync: 37.9kHz
Identifier "Monitor0"
HorizSync 31.5 - 80.0
VertRefresh 50.0 - 85.0
Modeline "848x480" 37.293 848 936 984 1104 480 508 509 563 +hsync +vsync
# Option "DPMS" "true"
# Option "IgnoreEDID" "True"
# HorizSync 28.0 - 78.0 # Warning: This may fry very old Monitors

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "848x480"

Here are some other details, if I change Display subsection to:

SubSection "Display"
Depth 24
Modes "848x480" "800x600"

Then when I restart my computer, my projector again displays 848x480 during the boot, then switches to 800x600 (as opposed to 1024x768) after the Nvidia splash comes on the screen.

So it is almost like that after the boot, it ignores my 848x480 in the modes section, and switches to the default "1024x768" "800x600" "640x480" display resolutions through some 'hidden modeline.

I also tried "un-commenting" the default modelines to see what xrandr allows. It comes back with:


And when I switch to any resolution through xrandr, the projector flickers, and displays the correct resolution that I called out. Except when I switch to "848x480", the projector then shows "1024x768"

I know the 848x480 modeline is good. It is posted on the knoppmyth wiki.

I most recently tried to add these following lines in hope that it would work:

Option "NoDDC" "1"
Option "IgnoreEDID" "true"
Option "UseEdidFreqs" "false"

This still didn’t change my problem. Does anyone know why my projector displays the correct 848x480 modeline during boot up, but then switches to 1024x768 once X starts? I will be eternally grateful to anyone who helps me solve this frustrating problem.

netllama 07-25-06 11:36 AM

Re: Cannot get Resolution to Work.
I'm not completely clear on how you've setup the boot process to provide an 848x480 mode. Is this with a framebuffer console, or an X server?

Additionally, please start X with the following command:
startx -- -logverbose 6

and then generate and post an nvidia-bug-report.log


tama102 07-25-06 01:13 PM

Re: Cannot get Resolution to Work.
I am running knoppmyth (based on Knoppix)

I will follow your instructions when I get home today, and report back with my nvidia-bug-report.log

tama102 07-26-06 08:59 AM

Re: Cannot get Resolution to Work.
Alright, I seemed to have fixed my problem. Like I said above I used the following options:

Option "NoDDC" "1"
Option "IgnoreEDID" "true"
Option "UseEdidFreqs" "false"
Option “DPMS” “false”

This still did not work. But Then I decided to change my H-sync range from 31.5-80.0 to 25.0-80.0. Doing this with all four options active give me my 848x480 modeline. I am glad it works, but this makes no sense to me.

It scared the crap out of me to change my Hsync with all the safety options turned off. My projector is only rated for Hsync 31.5-80.


And according to my modeline shown above, the Hsync is set to 33.77, so my original Hsync value should have been fine. Anyway, I am just happy that it all works. Maybe this thread can help some other poor noob in the future. Thanks again.

HannibalX 08-08-06 09:40 PM

Re: Cannot get Resolution to Work.
tama102 --

Many, many thanks for this thread!

I started out with an ATI card in my MythTV box, and it picked up the resolution for my SP4805 with no issues at all... Very quickly, I upgraded (felt like a downgrade...) to an NVidia card so I could use XvMC... I spent about 3-4 days trying to get 848x480 working again. I got so frusterated, I took a break... it was only supposed to be for a few days, and it turned into 6 weeks because of real life issues.

Anyways, your instructions worked perfect. For the sake of completeness, here is my working monitor section:


Section "Monitor"
        Identifier  "Monitor0"
        Option      "VendorName" "Infocus SP4805"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "NoDDC" "1"
        Option      "IgnoreEDID" "true"
        Option      "UseEdidFreqs" "false"
        Option      "DPMS" "false"
        HorizSync  25 - 80.0
        VertRefresh 50.0 - 85.0
        Modeline    "848x480" 37.293 848 936 984 1104 480 508 509 563 +hsync +vsync

Thank you for your persistance!

All times are GMT -5. The time now is 07:55 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.