nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   rdesktop requires glx?? (http://www.nvnews.net/vbulletin/showthread.php?t=74126)

blekenbleu 07-28-06 12:12 PM

rdesktop requires glx??
 
migrated from FC4 with 1.0.8178

linux 2.6.17-1.2157_FC5smp
xorg-x11-apps-7.0-1
NVIDIA-Linux-x86-1.0-8762-pkg1.run + NVIDIA_kernel-1.0-8762-U072006.diff.txt
Quadro FX 4500
Xinerama, dual Dell 3007WFP 2560x1600
rdesktop-1.4.1-3.2.1

Without glx:

% which rdesktop
/usr/bin/rdesktop
% rdesktop labxp
X Error of failed request: BadValue (integer parameter out of range for
operation)
Major opcode of failed request: 78 (X_CreateColormap)
Value in failed request: 0x0
Serial number of failed request: 7
Current serial number in output stream: 8

.. but rdesktop works ok with Load "glx" in Section "Module" ..

Lithorus 07-28-06 01:03 PM

Re: rdesktop requires glx??
 
You should talk to the rdesktop developers instead. Glx is not anything nvidia specific.

blekenbleu 07-28-06 01:33 PM

Re: rdesktop requires glx??
 
Quote:

Originally Posted by Lithorus
You should talk to the rdesktop developers instead. Glx is not anything nvidia specific.

I have not tested extensively,
but this appears to be associated with the latest version of nVidia's binary driver
and perhaps then only with Xinerama. For example,
I used with FC4 rdesktop for over a year with NVidia's 1.0.8178 driver,
and throwing the same FC5 rdesktop (1.4.1-3.2.1) to another
non-nVidia, non-glx Xinerama X server does not manifest this problem.

The main reason we thought to try glx was that google hits for that error message
seem most often associated with GL apps.

AaronP 07-28-06 04:05 PM

Re: rdesktop requires glx??
 
XCreateColormap failing with BadValue when Xinerama is enabled and GLX is not loaded is a known bug (bug 240536). For now, the simplest workaround is simply to load GLX.

Mr. Sinister 01-10-07 06:15 PM

Re: rdesktop requires glx??
 
I started getting the same error with rdesktop when I added xinerama support to my xorg.conf file. I have glx loaded, my Xorg.0.log file says:
Code:

(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.9746
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.1
(II) Loading extension GLX

Is there a glx/xinerama bug, or am I missing something?

netllama 01-10-07 06:19 PM

Re: rdesktop requires glx??
 
This is the same bug that Aaron noted earlier.

Mr. Sinister 01-10-07 07:32 PM

Re: rdesktop requires glx??
 
So why am I seeing it with glx loaded? Or am I mistaken in my belief that I have glx loaded?

AaronP 01-10-07 08:09 PM

Re: rdesktop requires glx??
 
Make sure Composite is disabled.

Mr. Sinister 01-12-07 01:22 PM

Re: rdesktop requires glx??
 
Quote:

Originally Posted by AaronP
Make sure Composite is disabled.

That did it. Thanks.

Vincas 02-09-07 12:30 PM

Re: rdesktop requires glx??
 
I tried with composite disabled, and I get the same error. Except the error occurs when I run glxgears or wine.


All times are GMT -5. The time now is 08:11 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.