nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   7950 GX2 - Failed to Initialise SLI with unknown error (http://www.nvnews.net/vbulletin/showthread.php?t=74361)

Aphax 08-01-06 08:47 PM

7950 GX2 - Failed to Initialise SLI with unknown error
 
1 Attachment(s)
I am trying to get SLI working with my XFX 7950 GX2 card on Gentoo Linux (kernel 2.6.17) with the 8762 drivers. Unfortunately during X startup, SLI fails to initialize, leaving the following message in my Xorg log:

Quote:

671 (**) NVIDIA(0): Option "SLI" "yes"
672 (**) NVIDIA(0): Enabling RENDER acceleration
673 (**) NVIDIA(0): NVIDIA SLI enabled; using auto-selected rendering method.
674 (WW) NVIDIA(0): Failed to initialize SLI! Reason: Unknown error (2). Only
675 (WW) NVIDIA(0): one GPU will be used for this X screen. Please see the SLI
676 (WW) NVIDIA(0): Appendix in the README for troubleshooting suggestions
I have checked the README SLI section but all seems to be in order, I have ACPI enabled in the kernel, and lspci seems to indicate that both devices are detected and connected to the PCI Bridge:

Quote:

03:00.0 3D controller: nVidia Corporation Unknown device 0294 (rev a1)
Subsystem: XFX Pine Group Inc. Unknown device 2214
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at e0000000 (32-bit, non-prefetchable) [size=16M]
Memory at c0000000 (64-bit, prefetchable) [size=256M]
Memory at e1000000 (64-bit, non-prefetchable) [size=16M]
I/O ports at 9000 [size=128]
[virtual] Expansion ROM at e2000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [68] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
Capabilities: [78] Express Endpoint IRQ 0

04:00.0 VGA compatible controller: nVidia Corporation Unknown device 0294 (rev a1) (prog-if 00 [VGA])
Subsystem: XFX Pine Group Inc. Unknown device 2214
Flags: bus master, fast devsel, latency 0, IRQ 20
Memory at e3000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at e4000000 (64-bit, non-prefetchable) [size=16M]
I/O ports at a000 [size=128]
[virtual] Expansion ROM at e5000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [68] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
Capabilities: [78] Express Endpoint IRQ 0
And the tree output (EDIT: Looks like some whitespace got stripped, the [0000:04] device is right below [0000:03]:

Quote:

-[0000:00]-+-00.0 Intel Corporation 945G/GZ/P/PL Express Memory Controller Hub
+-01.0-[0000:01-04]----00.0-[0000:02-04]--+-00.0-[0000:03]----00.0 nVidia Corporation Unknown device 0294
| \-01.0-[0000:04]----00.0 nVidia Corporation Unknown device 0294
+-1b.0 Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller
+-1c.0-[0000:05]--
+-1c.2-[0000:06]----00.0 Broadcom Corporation NetLink BCM5789 Gigabit Ethernet PCI Express
+-1d.0 Intel Corporation 82801G (ICH7 Family) USB UHCI #1
+-1d.1 Intel Corporation 82801G (ICH7 Family) USB UHCI #2
+-1d.2 Intel Corporation 82801G (ICH7 Family) USB UHCI #3
+-1d.3 Intel Corporation 82801G (ICH7 Family) USB UHCI #4
+-1d.7 Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller
+-1e.0-[0000:07]--
+-1f.0 Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge
+-1f.1 Intel Corporation 82801G (ICH7 Family) IDE Controller
+-1f.2 Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller IDE
\-1f.3 Intel Corporation 82801G (ICH7 Family) SMBus Controller
My mainboard (if it matters) is a Gigabyte 8I945PL-G, but I should probably also note that SLI works perfectly under Windows. I have attached a zipped bug-report file.

Thunderbird 08-02-06 04:33 AM

Re: 7950 GX2 - Failed to Initialise SLI with unknown error
 
Does your motherboard support SLI? Although the card is a single board you still need a motherboard with SLI support and I don't think this Intel board supports that. But I'm not 100% sure though (some 945/965 can do it).

Or perhaps the drivers just don't support SLI on Intel boards yet that can also be the case.

Aphax 08-02-06 07:26 AM

Re: 7950 GX2 - Failed to Initialise SLI with unknown error
 
Well, SLI seems to work under Windows so yeah I believe it does, despite the board not being listed on the compatibility list. (the 7950 GX2 was actually traded for a defective 7900 GTX, unfortunately the PC shop assistant failed to mention the fact that it only works on a limited number of motherboards =/ )


All times are GMT -5. The time now is 08:04 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.