nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Quadro fx3500 not working (Debian/Ubuntu) (http://www.nvnews.net/vbulletin/showthread.php?t=74382)

mrtom852 08-02-06 06:02 AM

Quadro fx3500 not working (Debian/Ubuntu)
 
1 Attachment(s)
Hi,

We've got a couple of machines here with Quadro 3500 cards that we're trying to use with Debian and Ubuntu. After installing the nvidia (8762) drivers and starting X I get the following error....

(WW) ****INVALID IO ALLOCATION**** b: 0xb000 e: 0xb07f correcting
(EE) Cannot find a replacement memory range
(EE) NVIDIA(0): Resource conflicts detected
(EE) Screen(s) found, but none have a usable configuration.

Full log is attached.

Thanks,
Tom

mrtom852 08-02-06 06:30 AM

Re: Quadro fx3500 not working (Debian/Ubuntu)
 
1 Attachment(s)
Just adding another log file as the other had a broken xorg.conf

netllama 08-02-06 10:31 AM

Re: Quadro fx3500 not working (Debian/Ubuntu)
 
I have a few questions:
0) Why are you booting with the noapic kernel parameter? Does this problem persist without that parameter or with acpi=off instead?
1) This error is coming from the core X server, not the nvidia X driver:
(EE) Cannot find a replacement memory range
Are you able to start X with the 'nv' or 'vesa' X driver?
2) It looks like you're using an IBM workstation. Which model is it?

Thanks,
Lonni

mrtom852 08-02-06 11:17 AM

Re: Quadro fx3500 not working (Debian/Ubuntu)
 
0) The noapic option was added by mistake. Without it makes no difference though and acpi=off gives me ide errors.
1) I tried with nv after posting and get the same error. So you're right in that it's not a driver problem and so I guess it is some sort of issue with the PCI setup.
2) The machine is an Intellistation A Pro 6217. I'm running a 32-bit Debian (sid) and my colleagues are running 64-bit Dapper.

Googling for the various errors in dmesg doesn't turn up much. The following looked particularly bad...
PCI: Failed to allocate mem resource #6:20000@e0000000 for 0000:84:00.0

84:00.0 is the graphics adapter. :-P

I will try to contact IBM for support and see what they think.

netllama 08-02-06 11:25 AM

Re: Quadro fx3500 not working (Debian/Ubuntu)
 
I'm afraid that this is either a BIOS or kernel bug, although I suppose it might be an X bug, but that seems unlikely based on the error in dmesg.

Thanks,
Lonni

r0b0t 08-09-06 05:46 PM

Re: Quadro fx3500 not working (Debian/Ubuntu)
 
I'm having exaclty the same issue with my Intellistation A Pro here, except for me the offending card is a 7800 GTX (the Quadro 3400 that ships with it works just fine, I get the error when swapping the card). The error I get is exactly the same though.

I did a BIOS update to the latest version which didn't help at all. Anyone have any further hints as to how to get this to work? I can't believe you're not able to swap the video card in these crazy-expensive workstations...

mrtom852 08-16-06 10:08 AM

Re: [FIXED] Quadro fx3500 not working (Debian/Ubuntu)
 
I've since applied the patch attached to the following bug and the card now works:

https://bugs.freedesktop.org/show_bug.cgi?id=6377

(yes, I did notice the irony with the source of the patch ;-) )

The warnings/errors that seemed to be reported in dmesg were obviously red herrings.

I think Suse (and possibly others) already have a similar patch and I have sucessfully tested it with Suse 10.1.


All times are GMT -5. The time now is 07:37 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.