nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   TwinView not working: FX 5200 on Ubuntu 6.06 LTS (http://www.nvnews.net/vbulletin/showthread.php?t=74423)

dereks 08-02-06 05:59 PM

TwinView not working: FX 5200 on Ubuntu 6.06 LTS
 
1 Attachment(s)
TwinView does not work for me. I have tried every option combination I could find. Every time the result is the same:

(EE) NVIDIA(0): The requested configuration of display devices is not
(EE) NVIDIA(0): supported in the hardware.



I have tried not using TwinView, and instead use two X "Screens", as described here: https://help.ubuntu.com/community/NvidiaTVOut . I get the same result as above.

I have read on a forum post that a newer driver broke TV-Out TwinView for some people that it used to work for, and so I tried the older "legacy" driver:

root@geode:/etc/X11# dpkg -l | grep nvidia-glx-legacy
ii nvidia-glx-legacy 1.0.7174+2.6.15.11-3 NVIDIA binary XFree86 4.x/X.Org 'legacy' dri
root@geode:/etc/X11#


This gives the same result.

If I supply the config option

Option "UseDisplayDevice" "TV-0"

then my TV (and only my TV) works fine, at 1024x768. If I do Option "UseDisplayDevice" "CRT-1" then my LCD monitor (and only my LCD monitor) works fine. If I try Option "UseDisplayDevice" "CRT-1,TV-0" then I get the same old error "The requested configuration of display devices is not supported in the hardware.".

The fact that the log file shows

(--) NVIDIA(0): Connected display device(s) on GeForce FX 5200 at PCI:1:0:0:
(--) NVIDIA(0): Dell 1800FP (CRT-1)
(--) NVIDIA(0): NVIDIA TV Encoder (TV-0)


makes me think that both the TV and the LCD monitor are being detected okay.

The fact that the log file shows

(II) NVIDIA(0): Requested modes:
(II) NVIDIA(0): "1024x768,1024x768"
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): MetaMode "1024x768,1024x768":


makes me think that the MetaMode line is okay, and that my simple setting of 1024x768,1024x768 should extend the desktop from the LCD to the TV.


I am stuck. What else to try? I have built myself an awesome MythTV box, I want to run MythTV on the T.V. and have a nice Gnome Desktop on my LCD for websurfing and email.

The nvidia-bug-report.log is attached, which includes my /var/log/Xorg.0.log and my /etc/X11/xorg.conf files.

Any help is greatly appreciated.

Thanks,
Derek

netllama 08-02-06 06:26 PM

Re: TwinView not working: FX 5200 on Ubuntu 6.06 LTS
 
I see a few potential problems in your X log:
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.

Since your X configuration is requesting the glx module, the above error suggests that the nvidia driver is not installed correctly. Have you reinstalled the driver to correct this problem?

You did not use the TwinViewOrientation option to specify the orientation of your display devices when using TwinView. I doubt that this is why X is crashing, however it doesn't hurt to add it in.

The majority of the times that I've seen the following error:
(EE) NVIDIA(0): The requested configuration of display devices is not
(EE) NVIDIA(0): supported in the hardware.

its when someone is trying to run TwinView across a TV and another display device. In most of those cases the VBIOS on their videocard is not setup to allow this configuration (TV+some other display device simultaneously). Have you verified whether TwinView works with two non-TV display devices?

As a side note, it looks like the bug report that you posted was manually edited, as its missing several sections which should appear by default.

Thanks,
Lonni

dereks 08-02-06 07:13 PM

Re: TwinView not working: FX 5200 on Ubuntu 6.06 LTS
 
1 Attachment(s)
Lonni,
Thank you for your prompt response.

Regarding "Failed to initialize the GLX module", this happened because I installed the older Ubuntu NVidia driver package. When I update to the latest (with apt-get install nvidia-glx) then that error message goes away.

Regardless of whether or not that message appears, my results are the same.

Regarding the lack of "TwinViewOrientation", I did add that option during the course of my troubleshooting and it did not affect the results. (I was planning on adding that option after I got X to run with both output devices.)

Nevertheless, I made both of the changes you requested so you can see that GLX is working and that I have tried the "TwinViewOrientation" option. The updated nvidia-bug-report.log is attached. The result is the same.

Regarding your comment, "In most of those cases the VBIOS on their videocard is not setup to allow this configuration (TV+some other display device simultaneously).", I have seen your response about the VBIOS before, in a forum thread by a guy having the example same problem as me. I wondered if maybe my card simply does not support TV-OUT dual head.

However, I believe that the FX 5200 does support dual-head with TV-OUT, as I have read forum claims that it has worked for others, and I believe that my problem is a driver bug as described here: http://www.nvnews.net/vbulletin/show...ghlight=tv-out and here: http://www.nvnews.net/vbulletin/show...ghlight=tv-out .

The other guy that had the same problem as me (on an FX 5200) had a working dual-head with TV-OUT until the latest driver broke it for him. I can't find that other thread right now... it was in this forum... drat!

Is there some way to test (other than having two CRTs) if my card will support dual-head display with a TV-OUT? This is a PNY "Verto" GeForce FX 5200 AGP 8x card.

Please advise...

dereks 08-02-06 07:19 PM

Re: TwinView not working: FX 5200 on Ubuntu 6.06 LTS
 
Quote:

Originally Posted by dereks
Is there some way to test (other than having two CRTs) if my card will support dual-head display with a TV-OUT?


One other thing I wanted to add... when I launch X with "startx" I can see my TV and my LCD monitor (CRT) both flicker very briefly, like they have gotten some kind of signal (like the FX 5200 has detected both the devices). However, X immediately dies because of my "not supported" error.

--Derek

netllama 08-02-06 08:29 PM

Re: TwinView not working: FX 5200 on Ubuntu 6.06 LTS
 
FX 5200 cards do support dual head with a TV, however the VBIOS on yours may not.

Thanks,
Lonni

dereks 08-02-06 09:42 PM

Re: TwinView not working: FX 5200 on Ubuntu 6.06 LTS
 
I've solved the problem. It works and I am absolutely thrilled with my MythTV box!


I was wondering why my X log said "TV-0" and "CRT-1", instead of "TV-0" and "CRT-0". I noticed in my X log that it was still recognizing my motherboard's built-in SiS video display chipset, so I thought that might be causing some kind of hardware conflict.

After futzing around with the hardware, looking for jumpers to disable the onboard SiS video chipset, I decided to try something very simple: I moved my LCD monitor from the right-most VGA plug to the left-most VGA plug. It worked!

Suddenly CRT-1 was gone, but CRT-0 showed up, and I am able to use TwinView with CRT-0 and TV-0 without any problems! ROCK!

I am shocked that in all my reading about this problem (the README, many Google results, several dozen forum postings, etc.) nobody mentioned this even once. Weird. Lonni, if you work for NVidia you might want to have them drop a note about that in the README.


Thanks for all your help!
--Derek


All times are GMT -5. The time now is 11:23 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.