nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen (http://www.nvnews.net/vbulletin/showthread.php?t=74655)

rob40 08-07-06 10:08 AM

GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
2 Attachment(s)
I ve got a problem with a GeForce 6100 - I am running SUSE 10.0-64.
I can see only 70% of the picture on my 19''-TFT Screen.
Autoadjust and/or manual adjusting don't help.
Code:

/proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86_64 Kernel Module  1.0-8762  Mon May 15 13:58:14 PDT 2006
GCC version:  gcc version 4.0.2 20050901 (prerelease) (SUSE Linux)

/proc/driver/nvidia/cards/0
Model:          GeForce 6100
IRQ:            50
Video BIOS:      05.51.22.28.10
Card Type:      PCI
DMA Size:        39 bits
DMA Mask:        0x7fffffffff

Code:

mij:~ # uname -a
Linux mij 2.6.13-15.11-default #1 Mon Jul 17 09:43:01 UTC 2006 x86_64 x86_64 x86_64 GNU/L
mij:~ # lsmod | grep nvidia
nvidia              5433432  12
i2c_core              25752  1 nvidia
mij:~ # hwinfo | grep GeForce
mij:~ # modprobe nvidia
mij:~ # modprobe -f nvidia
mij:~ # cat /var/log/messages | grep nvidia
Aug  7 15:29:11 mij kernel: nvidia: module not supported by Novell, setting U taint flag.
Aug  7 15:30:06 mij kernel: nvidia: module not supported by Novell, setting U taint flag.
Aug  7 15:32:11 mij kernel: nvidia: module not supported by Novell, setting U taint flag.
Aug  7 15:34:52 mij kernel: nvidia: module not supported by Novell, setting U taint flag.
Aug  7 15:34:52 mij kernel: nvidia: module license 'NVIDIA' taints kernel.

Thank s a lot in advance.

netllama 08-07-06 11:28 AM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
In your X log, I see:
(WW) NVIDIA(0): No valid modes for "default"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".

Because you're requesting a mode called "default" which doesn't exist in your xorg.conf.

I'd suggest commenting out all the modelines in your xorg.conf, and requesting a valid mode name (1280x1024).

Thanks,
Lonni

rob40 08-08-06 10:47 AM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
Lonni,

thanks for your quick reply. Good hint.
still I do have some trouble. I m checking and get back asap.

rob40 08-09-06 05:23 AM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
1 Attachment(s)
I restored a clean system, installed driver again and corrected xorg.conf - it s working fine now.

still one ('cosmetical') thing:
when rebooting or powering ON right after the SuSE menu
again I do have only 70% of the screen.
It switches to 100% (=normal) shortly before KDE and final (GUI-)Desktop appears and works fine after that stage.

You got a hint for this last problem ?
Thanks again for your help.

rob40 08-11-06 11:46 AM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
Does anyone have a hint for this last problem ?
Thanx in advance.

Alchemist 08-11-06 12:13 PM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
Edit /boot/grub/menu.lst

Add the proper vga= for your monitor's resolution from:

/usr/src/linux/Documentation/fb/vesafb.txt

netllama 08-11-06 12:24 PM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
According to your X log:
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1280x1024"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024

You didn't comment out the modelines, as I suggested, so its quite possible that those modelines are invalid (as has been the case with others using SuSE in the past).

If you need further assistance, please start X with the following command:
startx -- -logverbose 5

and then generate and post a new bug report.

Thanks,
Lonni

rob40 08-14-06 05:39 AM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
1 Attachment(s)
Thank you for your help ! :)

In /boot/grub/menu.lst I tried different vga settings, now changed to "vga=0x318"
I commented out the modelines, started X with "startx -- -logverbose 5" and created the attached log.

Now with "vga=0x318", when rebooting or powering ON right after the SuSE menu
I DO have 100% of the screen, but it is text-based. It switches to normal blue SuSE_boot_image after runlevel 5 then final (GUI-)Desktop appears and works fine after that stage.

Final question:
how do I get the normal blue SuSE_boot_image right from the beginning ?

netllama 08-14-06 01:18 PM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
Are you saying that the problem is resovled after booting with "vga=0x318"?

I'm afraid I don't understand what you mean by "normal blue SuSE_boot_image". You'd probably need to ask that question in a SuSE forum.

Thanks,
Lonni

rob40 08-14-06 01:53 PM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
The problem is partly resolved.
Normally after boot menu the standard blue SuSE_boot_image appears:
ONLY pressing "ESC" switches to text-mode.

After booting with "vga=0x318", I do have 100% of the screen, but text-mode right away.
It switches to normal blue SuSE_boot_image after runlevel 5 and after few seconds the
final (GUI-)Desktop appears and works fine after that stage.
You got a hint how to fix that ?

Thanx
Rob

netllama 08-14-06 02:28 PM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
I'm not clear on where you're seeing a problem. The nvidia X driver only impacts what appears in X. If you're experiencing issues with a framebuffer console, that isn't configured by the nvidia X driver.

Thanks,
Lonni

rob40 08-14-06 03:06 PM

Re: GeForce 6100, SUSE 10.0-64, only 70% of the picture on the screen
 
ok.
Thanx again for you help.
Rob


All times are GMT -5. The time now is 06:48 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.