nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55) (http://www.nvnews.net/vbulletin/showthread.php?t=74738)

jt99 08-08-06 05:28 PM

Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
Like the title says...

I have a new system:
- ASUS M2N32-SLI-Deluxe motherboard, Athlon-64x2 4800
- SuSE 10.1 -- 2.6.16.13-4-smp x86_64

Yast is able to recognize and configure (static address) either/both of the onboard ethernet controllers (the mobo has two MCP55 devices). Afterward, ifconfig reports (properly) that the device is up, has its IP address and netmask, and everything is fine. The route command shows the default gateway properly.

I can ping the loopback interface successfully, and I can ping my own IP address properly. Any attempt beyond that returns a "network unreachable" error.

IP address -- 135.149.52.90, netmask 255.255.254.0 (yes, 25*4*)
default gateway -- 135.149.52.1


I have not loaded any Nvidia drivers. The forcedeth.ko module reports as being installed.


If I boot up in (boo hiss) Windows, the controller configures itself w/ DHCP (as specified) and all the network stuff works. We don't want to boot Linux w/ DHCP, but attempts at that have failed to acquire an address for the ports, in any event.




Any thoughts, hints, or ideas? I'm not sure what other info would be useful, but can gather and post it here if requested.

netllama 08-08-06 05:31 PM

Re: Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
What is the output from running "ethtool -i eth0" ?

jt99 08-08-06 05:42 PM

Re: Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
driver: forcedeth
version: 0.49
firmware-version:
bus-info: 0000:00:10.0




Oh... as another point of info, I had initially installed SuSE using the CDs, which don't have 64-bit support. The 586 version of the kernel and software was loaded, and DHCP was able to grab an IP address, and everything worked (well, except that it was 32-bit and I'd paid for all 64). ;) When I installed from DVD, I wiped (and re-partitioned) the hard drive, so there's no chance that anything remained. But the 32-bit stuff was working at one point....

netllama 08-08-06 05:46 PM

Re: Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
I'm not sure that forcedeth-0.49 has support for MCP55. The fact that it worked in x86 might have been luck. Please test with the latest 2.6.17.x kernel.

jt99 08-08-06 06:13 PM

Re: Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
Okay... now I'm going to sound dumb.

The DVD doesn't appear to have any later kernels, and when I poked around on the novell.com/suse site, I wasn't able to find any kernel updates to 10.1.

Where/how would I go about getting the 2.6.17.x kernel?

netllama 08-08-06 06:16 PM

Re: Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
You're going to have to build your own from www.kernel.org

jt99 08-08-06 06:28 PM

Re: Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
Oh Joy. :)

Is there an Nvidia driver module, as opposed to the forcedeth module? (I assume not, since you didn't suggest it, but hope springs eternal).

netllama 08-08-06 06:43 PM

Re: Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
forcedeth is the NVIDIA driver for 2.6.16 and later kernels. Sorry.

jt99 08-08-06 10:25 PM

Re: Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
Ah well... it was worth the query, at least.

I think that to start with, I'll install a spare, boring PCI ethernet card that should be old enough to be supported by Linux, but new enough to be supported by Linux. :)

Once I have network access from the new box, I'll see about downloading and building the newer kernel.

Thank you *very* much for your answers, and especially for the speed of those replies!

-- jt --

Jecos 08-08-06 11:39 PM

Re: Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
I have an Asus M2N32-SLI-Deluxe-wifi, its works great in ubuntu dapper x86 with noapic (64bit also worked great), both nics work fine, wifi shows up like it would work perfectly fine but I don't have any wifi access to test it on.

Nico.Laus 08-09-06 05:18 AM

Re: Can't access network... SuSE 10.1, ASUS M2N32-SLI-Deluxe (nVidia MCP55)
 
Kernel 2.6.17.7 is available from suser-jengelh on ftp://ftp.gwdg.de/pub/linux/misc/sus...SE-10.1/x86_64
-> it is configured slightly different, so maybe some things don't work or look different (for example the terminal now has colored fonts depending on if you're root or not).
-> This kernel is not supported by SuSE!

I am booting my ASUS M2N32-SLI-Deluxe with this kernel and it's working fine (although I think the "cannot find a way to set hardware clock"-error did not occur before, bot that's not that important)

Be informed that if you upgrade to Bios 304 you have to boot with the option noapic (simply type it in grub or configure the preferred option to use it).


All times are GMT -5. The time now is 04:12 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.