nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem starting X Server (http://www.nvnews.net/vbulletin/showthread.php?t=7475)

stickl2 02-12-03 11:48 AM

Problem starting X Server
 
I am having trouble getting my X server to work. I am trying to install the NVIDIA driver for my card (Riva TNT2). Everything seems to go OK and I type startx then I get the following

(II) [GLX]: Initializing GLX extension

Fatal server error:
Caught signal 11. Server aborting

I have read the other threads and have the lines

Load "dri"
Load "GLcore"

commented out and made sure the line

Load "glx"

is there. Also I have the drivers set as "nv"

The man pages say that signal 11 is an "invalid meory reference"? But I don't know what that referrs to or how to fix it. Thanks in advance.

Jen

fresk 02-12-03 01:24 PM

If you're using the nvidia kernel driver (from nvidia.com) you should use the 'nvidia' driver instead of 'nv' - I've had the same problem (segfaulting XFree), after this change it works pretty good for me.

stickl2 02-12-03 01:29 PM

When I change the driver to "nvidia" I get the following

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel nodue!
(EE) NVIDIA(0): ***Aborting***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screen found

Thanks for you help.

Jen

bwkaz 02-12-03 02:16 PM

Check dmesg for that one. More than likely, you either have PnP OS enabled in your BIOS, or you have "assign IRQ to VGA" disabled.

These have to be disabled and enabled, respectively.

Well, wait a minute, it might be that the kernel module isn't loaded when you startx. Do an lsmod and make sure you see "nvidia" listed. If you don't, /sbin/modprobe nvidia as root, then exit the root shell and try to startx again.

stickl2 02-12-03 02:38 PM

I checked the lsmod and nvidia is not listed there. When I try /sbin/modprobe nvidia I get

modprobe: Can't locate module nvidia

Did I forget to install something?

bwkaz 02-12-03 04:33 PM

Did you install version 4191? Did you install the files that NVchooser told you to?

What does find /lib/modules -name nvidia.o -o name NVdriver tell you? If it prints nothing, then you haven't installed the NVIDIA_kernel package. If it prints NVdriver, then you installed 3123 or older -- either upgrade, or try /sbin/modprobe NVdriver instead. Either one should work.

If it prints <some path>/nvidia.o, then you installed the wrong driver. Make sure you use what NVchooser tells you to.

stickl2 02-12-03 04:44 PM

When I gave that command I got

/lib/modules/2.4.18-14/kernel/drivers/video/nvidia.o

However I ran rpmbuild --rebuild on the kernel to install it under a newer version of RH8.0's kernel (2.4.18-24.8.0). There are different folders under my /lib/modules for each of the kernel updates that I have an nvidia.o is only under the 2.4.18-14 one.

When I run rpm -q NVIDIA_kernel and rpm -q NVIDIA_GLX I get

NVIDIA_kernel-1.0-4191
NVIDIA_GLX-1.0-4191
which I think are the latest versions from the website

Thanks for you help,

bwkaz 02-12-03 08:03 PM

Yeah, uninstall the NVIDIA_kernel RPM, it'll only work under that version of the kernel. The driver is a kernel module like everything else (for example, your sound card driver), so it needs to change with every kernel version.

You say you rebuilt the srpm under the kernel you run, but did you then install the resulting .rpm file? I don't think so, since the old nvidia.o still exists. You will probably have to remove the old package first to be able to install the new one, though. rpm -e --nodeps NVIDIA_kernel should work -- note that normally, --nodeps is NOT a good idea, as it bypasses all the dependency checking. But in this case, the dependency will get filled by the new version you're going to install, so it should be OK. Note that the path to the built RPM should have been printed during the build process, but if you don't remember (or didn't see it), you can just --rebuild the .srpm file again.

If in doubt, rpm -e NVIDIA_GLX first, and rpm -ivh it again when you're done.

stickl2 02-13-03 12:27 PM

OK I uninstalled the version of the NVIDIA-kernel that was installed and tried to rebuild the kernel again with

rpmbuild --rebuild NVIDIA_kernel-1.0-4191.scr.rpm

and I get the following errors

install: cannot stat 'nvidia.o': No such file or directoy
error: Bad exit status from /var/tmp/rpm-tmp.17700 (%install)

and there is no rpm built. Also I noticed that my kernel source was not matching what kernel I am running so I uninstalled it (rpm -e) and tried to install the newest one from RH. But my rpm command does nothing? I type

rpm -ivh kernel-source-2[2].4.18-24.8.0.i386.rpm

and nothing happens. Thanks for helping a newbie figure out what is happening

bwkaz 02-13-03 02:49 PM

Nothing happens? Are you SURE? I don't think I've ever seen ANYTHING like that...

Does rpm --help do anything? What does which rpm tell you, and what about file $(which rpm) (in other words, could the rpm executable somehow be a symlink to something else that does nothing)? What about rpm -qa -- does it list all the packages that are installed on your system?

First, it is EXTREMELY unlikely for rpm to be somehow borked. But if it is, then perhaps installing cpio (from source) if it isn't installed, then running the rpm2cpio.pl Perl script that I found floating around the 'Net, on the kernel-source RPM, would help? That'll give you a cpio file that you can use cpio (from inside /usr/src) to extract. Then try installing the NVIDIA_kernel and NVIDIA_GLX packages from tarballs.

Obviously you're going to want to fix rpm if that's the problem, but it's going to be hard to do if rpm itself is screwed up...

stickl2 02-13-03 03:07 PM

Nothing was happening....so I reinstalled rpm from the RH CDs. It seems to work now. I am downloading the latest kernel source now and will try to rebuild the src rpm when that is finished.

stickl2 02-13-03 05:46 PM

I got rpm working again and installed the kernel source. I was able to compile the src rpm with no problems now.

I installed the rpm and checked lsmod for the module. It says it is install but that it is tainted. I don't know if this is a problem.

Also then when I try startx I get

(WW) warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to lad module "nvidia" (module does not exist, 0)
____other lines in log file_____
(EE) No drivers available

Fatal server error:
no screen found

What did I not get installed?


All times are GMT -5. The time now is 07:20 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.