nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini (http://www.nvnews.net/vbulletin/showthread.php?t=74816)

mlesin 08-10-06 08:00 AM

8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
3 Attachment(s)
My system looks as "rock stable" except one, reproduceable thing.
When I press "f" key in mplay utility from Houdini by SideFX Software (www.sidefx.com), which means "fit window to image size, with image like 1024x768 or 1280x1024 resolution loaded (it may be loaded from disk, because in apprentice you can't render it such big), X process hangs, and such messages appear in "/var/log/messages":

Code:

Aug 10 16:19:56 pixel kernel: NVRM: Xid (0001:00): 13, 0001 bfef000c 0000009f 00000300 0000fe00 00000002
Aug 10 16:20:03 pixel kernel: NVRM: Xid (0001:00): 28,  L1 -> L0
Aug 10 16:20:04 pixel kernel: NVRM: Xid (0001:00): 13, 0002 beef4201 00003062 00000304 00002000 00000002
Aug 10 16:20:20 pixel kernel: NVRM: Xid (0001:00): 28,  L0 -> L0
Aug 10 16:20:20 pixel kernel: NVRM: Xid (0001:00): 7, Ch 00000000 M 00000404 D ff89b1f5 intr 00010000

I've seen similar bug in different PC configurations, the only one common thing were that there always 87xx nvidia drivers were used and OS was SuSE 10.1.

I've discussed that with Houdini developers here: http://www.sidefx.com/index.php?opti...ewtopic&t=6050, and they think it some combination of kernel/driver (maybe xorg?) version, because they cannot reproduce it on their debian with the same driver.

I've tried to load kernel with noirqbalancer, pci=noapic, acpi=off - it has no effect.

bug report is attached (it was splited up in 3 parts because of 100kb limit on this forum)

mlesin 08-13-06 04:28 AM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
It's an easy reproducable bug, the only things you need to have is a SuSE, nvidia board and apprentice version of Houdini (freely available at www.sidefx.com)
Please help!

netllama 08-13-06 01:47 PM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
Please provide an image which reproduces this problem. I'd also like detailed instructions on how to run mplay, as I've never run it before.

Thanks,
Lonni

mlesin 08-13-06 03:43 PM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
After Houdini is installed, you'll need to run it's license server.
For single run you may just run "/etc/init.d/sesinetd start" command as root, or you may use Yast to make this service started at boot time.
After that, as a regular user:
Code:

cd /opt/hfs8.1.692    (or wherever you installed houdini)
source houdini_setup_bash    (to initialize all environment, now you may run houdini commands)
houdini                (will start houdini, let it be opened in the background)
mplay                (starts the image viewer)

after first Houdini run maybe it should ask about apprentice license creation, just Agree with that.

in mplay, you may open image from "File/Open" menu, or use "mplay <image>" syntax.
The image contents is insignificant, the only it's only should be more then 1024x576 in resolution, so you may just open any photo you like.
After image is opened, resize mplay window a bit to make it smaller and press "f" hotkey, that should "fit the window to the image size".
After that, if X process is still alive (it's hangs in 90% cases for me), anyway check "dmesg | tail" for NVRM messages..

BTW, I forgot to say (but it was in bug report) I'm using SuSE 10.1 x86_64 on amd64 x2 3800+ CPU.
Tried both 64 and 32 bit houdini - it doesn't matter.
For my friend, he have the same bug on 32bit SuSE 10.1 on Athlon XP 2600 and nVidia FX 5600 with 8756 driver.

mlesin 08-13-06 04:16 PM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
2 Attachment(s)
Here is bug report from my friend's PC I've told, Athlon XP 2600 and FX5600

netllama 08-14-06 12:58 PM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
I've now reproduced this X hang, and opened bug 247193.

Thanks,
Lonni

mlesin 08-14-06 01:05 PM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
Wow! Thanks!
Is there any public bugzilla or similar tool to see bug progress or it's private information?

netllama 08-14-06 01:18 PM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
I'm afraid that this bug is not publicly viewable. You can request status updates here or by emailing linux-bugs@nvidia.com.

Thanks,
Lonni

mlesin 08-14-06 03:50 PM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
Anyway, thanks!

winterlove 08-14-06 03:59 PM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
My attention was dragged onto this post because I have similar problems also with SL 10.1 on an ASUS A6JM Notebook (Geforce go 7600). However, it was dosbox that caused freezes right after startup (just after the window was created, and you can see a black window without contents - openGL is used to render on it) on a random basis.
From a remote ssh-login I could still examine what's going on though. dmesg shows
Code:

Aug 11 14:47:45 eliza kernel: NVRM: Xid (0001:00): 12, COCOD 00000000 01015c00 0000005c 00001900 02f2005c
Aug 11 14:48:41 eliza kernel: NVRM: Xid (0001:00): 28,  L1 -> L0

X process was at 100% and oprofile showed where it actually stuck:
Code:

CPU: CPU with timer interrupt, speed 0 MHz (estimated)
Profiling through timer interrupt
vma      samples  %        app name                symbol name
000473bc 214722  48.7231  nvidia_drv.so            _nv000194X
000473bf 1        4.7e-04
000473c0 1096      0.5104
000473c1 1        4.7e-04
000473c7 2        9.3e-04
000473cf 1073      0.4997
000473de 212543  98.9852
000473e2 6        0.0028

The name is obviously of no use to me.
After reading this thread I thought the problems are related so I installed houdini and what I got was even worse. Right after opening a larger file in mplay it not only gets stuck for a few seconds, after that "something" is shown and after some window resizes parts of the picture are "scattered" over my desktop (and even remain there after closing mplay). Note that i wasn't even doing the "f"-key trick yet.
Even though my problem seems worse than the one of the thread starter I still think its the same problem. I mean it always has to do with creating/resizing of some window (which also remains true for my initial problem)

PS: I'm using driver 1.0-8762
I don't think it's neccessary to post the nvidia-bug-report.log

netllama 08-14-06 04:07 PM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
winterlove, I'm not convinced that the instability you are reporting is related to the rest of this thread. I'd suggest starting a new thread with a bug report. Also, I'm not sure what a dosbox is in Linux.

Thanks,
Lonni

winterlove 08-14-06 04:27 PM

Re: 8762 driver on SuSE10.1 and mplay utility from Sidefx Houdini
 
Quote:

Originally Posted by netllama
winterlove, I'm not convinced that the instability you are reporting is related to the rest of this thread. I'd suggest starting a new thread with a bug report. Also, I'm not sure what a dosbox is in Linux.

Thanks,
Lonni

I never had any problems with other applications, even games that extensively use openGL. Other than that my system seems stable.
Dosbox is a IBM-PC Emulator designed to play old dos games (http://dosbox.sourceforge.net/)
It uses openGL (as one of several options) to hardware accelerate scaling of the graphics output. I can also turn of openGL in which case I don't experience any problems.
So it seems openGL related also (AFAIK mplay also uses openGL).

With dosbox the problem is very indeterministic so I couldn't track down a function sequence causing the hang. Sometimes it launches fine for many times (especially if you try to debug it ;-) and then I get it twice.

PS: If you still think the problem is a different one i will post this again in a new thread tomorrow when I come back

Many thanks!


All times are GMT -5. The time now is 08:07 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.