nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   NVIDIA nForce 590 SLI support? (http://www.nvnews.net/vbulletin/showthread.php?t=75161)

spejarn 08-16-06 12:06 PM

NVIDIA nForce 590 SLI support?
 
I have purchased a ASUS M2N32-SLI Deluxe motherboard (with the NVIDIA nForce 590 SLI chipset) and I experience some problems when trying to run Centos 4.3. The problems are related to network and sound.

First, are there any nForce 590 SLI drivers for Linux at all? I have looked around in this forum and as I understand NVIDIA support for Linux is not the best.

Network problem:
I can not get an IP-address from my DHCP server. Both the server and the network card are ok since everything works fine under MS Windows XP. dhclient fails since there is no answer from any DHCP sever but according to the server logs no request has been done. During the installation of Centos the forcedeth driver is installed but this does not work. I have tried the Unix nForce driver 1.0-0310 but with no success.

Sound problem:
There is no sound from my speakers. A sound card is detected during installation but this does not work. This was the same for MS Windows XP but a new driver could be downloaded from nvidia.com that solved the problem.

I really appreciate any help on this since I am quite new to Linux. I really like Centos and I would like to use it on this new computer as well.

spejarn 08-16-06 03:35 PM

Re: NVIDIA nForce 590 SLI support?
 
I have managed to solve the network problem now. I found some info on the forum regarding dual boot with MS Windows XP. According to this info MS Windows XP locks the NIC somehow. Prior to booting Linux, the system needs to be power off and the power cord removed for some seconds. After this, Linux boots fine and the network works perfectly!

I still got the sound problem though! Can someone give me some information about this. I am using the latest kernel available for Centos 4.3 which is 2.6.9-34.0.2.
Is this kernel version to old to include sound support without bugs? If so, what should I do to fix this, install some new driver or install a newer kernel?

Grateful for any information regarding this!


Best regards,
Magnus

netllama 08-16-06 08:02 PM

Re: NVIDIA nForce 590 SLI support?
 
That kenel is too old to support the hardware you're using. You'll need a 2.6.17.x kernel for MCP55.

Thanks,
Lonni

spejarn 08-17-06 03:54 PM

Re: NVIDIA nForce 590 SLI support?
 
OK!

Thank you for your answer! I will look/wait for an updated kernel to my dist.


Best regards,
Magnus

collinm 08-28-06 07:31 PM

Re: NVIDIA nForce 590 SLI support?
 
Quote:

Originally Posted by spejarn
I have purchased a ASUS M2N32-SLI Deluxe motherboard (with the NVIDIA nForce 590 SLI chipset) and I experience some problems when trying to run Centos 4.3. The problems are related to network and sound.

First, are there any nForce 590 SLI drivers for Linux at all? I have looked around in this forum and as I understand NVIDIA support for Linux is not the best.

Network problem:
I can not get an IP-address from my DHCP server. Both the server and the network card are ok since everything works fine under MS Windows XP. dhclient fails since there is no answer from any DHCP sever but according to the server logs no request has been done. During the installation of Centos the forcedeth driver is installed but this does not work. I have tried the Unix nForce driver 1.0-0310 but with no success.

Sound problem:
There is no sound from my speakers. A sound card is detected during installation but this does not work. This was the same for MS Windows XP but a new driver could be downloaded from nvidia.com that solved the problem.

I really appreciate any help on this since I am quite new to Linux. I really like Centos and I would like to use it on this new computer as well.

i have your problem with a hp a1540n computer (nvidia chipset)
i use suse 10.1
any way to resolve that?

netllama 08-28-06 08:43 PM

Re: NVIDIA nForce 590 SLI support?
 
See: http://www.nvnews.net/vbulletin/showthread.php?t=73925

collinm 08-28-06 10:18 PM

Re: NVIDIA nForce 590 SLI support?
 
Quote:

Originally Posted by netllama


i checked the link

i use kernel: 2.6.16.21-0.13

do you know if the newest kernel include directely forcedeth module?

how to build the forcedeth.c file?


All times are GMT -5. The time now is 11:26 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.