nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nVidia Driver breaks X Server on SuSE 10.1 (http://www.nvnews.net/vbulletin/showthread.php?t=75219)

darkhammer81 08-17-06 10:15 AM

nVidia Driver breaks X Server on SuSE 10.1
 
SuSE Linux 10.1
nVidia 7900 gs
nForce4 SLi Intel(i dont know if this matters)

ok so im trying to get 3d rendering running on my computer. iv been working on this for the better part of a month. So i get a fresh install of SuSE 10.1. i install gcc and kernel-source. i do the tiny-nvidia-installer/kmod and use the nvidia-xconfig. then the x server is wierd. what happens is several programs wont open windows. for instance wine will give me an error saying X11 failers to open a window and My Computer wont open on the desktop. when i click it i get sysinfo:/: died unexpectedly.

i also tried using the packages from download.nvidia.com/novell. i added the installation source and got the two packages i needed. sysinfo:/: worked fine but i couldn't use wine. also when i reboot the computer i cant get x server to start again. i tried this method on both a fresh install and after i installed teh kmod and both had the smae results.

anyone know how to fix the problem? iv installed the OS and tried this over and over again about 20 times. currently i have the kmod way installed and sysinfo:/: isnt working. it is a bare bones install other then that.

haveaniceday 08-17-06 02:16 PM

Re: nVidia Driver breaks X Server on SuSE 10.1
 
Hi Darkhammer81,

you might try:

- do SuSEs online-update to get current kernel and matching kernel sources
- reboot
- download NVIDIA-Linux-x86-1.0-8762-pkg1.run
- run as root: ( prepare kernel settings to reflect your current kernel )
Code:

cd /usr/src/linux
make cloneconfig
make modules_prepare

- set runlevel to 3 ( no graphic ) also as root
Code:

init 3
cd "<where you put NVIDIA-Linux-x86-1.0-8762-pkg1.run>"
sh ./NVIDIA-Linux-x86-1.0-8762-pkg1.run

- reboot
- as root ( go to non graphic level again )
Code:

init 3
sax2 -m 0=nvidia

- sax2 should guid you now to a configuration.

Best regards,

Haveaniceday

Firewing1 08-17-06 07:04 PM

Re: nVidia Driver breaks X Server on SuSE 10.1
 
If you're using Xorg v7.0 / 7.1, add:
Option "RenderAccel" "0"
to the "Devices" section in your xorg.conf
Firewing1

darkhammer81 08-17-06 07:56 PM

Re: nVidia Driver breaks X Server on SuSE 10.1
 
the method for installing the driver is exactly what i did. and i tried adding the option renderaccell line but it did nothing.

also iv never seen the nvidia slash screen until now. people always talked about how anoying it was. when i start x it flashes just long enough to see the icon and dissapears. this is the first time iv ever seen it. i dont know it that will mean anything to anyone.

currently im dealing with a fresh install with the nvidia kernel module installed and sax2 configured. everyting is updated. i am running xorg 7.1. the module is the newest version on nvidias site. all that seems to be messed up so far is that sysinfo:/: doesn't work but i havnt tried any programs. im assuming if i reinstalled wine and tried runngin winecfg it would do the same thing as it did every other time, give me an error X11 couldn't open window, driver not found. i also have xgl/compiz running perfectly, it was part of the instructions i followed to install the driver.

anyone else have any thoughts how i could fix this?

haveaniceday 08-18-06 09:36 AM

Re: nVidia Driver breaks X Server on SuSE 10.1
 
http://www.nvnews.net/vbulletin/show...01&postcount=4

May be a non supported 7.1 is the reason ? ( I do not know if the other thread is right).

xorg-x11-server-6.9.0-50.20 contains my X server.

Haveaniceday

darkhammer81 08-18-06 01:13 PM

Re: nVidia Driver breaks X Server on SuSE 10.1
 
idno im pretty sure people have gotten it running on x 7.1 before. im like 99 percent sure


All times are GMT -5. The time now is 09:41 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.