nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Error when using NVEmulate :-/ (http://www.nvnews.net/vbulletin/showthread.php?t=75263)

Linuxhippy 08-18-06 03:04 AM

Error when using NVEmulate :-/
 
Hi there,

Because I would like to play a bit with shaders on my GF460Go powered laptop I decided to give NVEmulate a try - just to see how/wether it works.

However when using NVEmulate, the engine I am using bails out with a strange error:
Quote:

org.lwjgl.opengl.OpenGLException: Invalid operation (1282)
at org.lwjgl.opengl.Util.checkGLError(Util.java:56)
at org.lwjgl.opengl.Display.swapBuffers(Display.java: 567)
at org.lwjgl.opengl.Display.update(Display.java:583)
at com.jme.renderer.lwjgl.LWJGLRenderer.displayBackBu ffer(Unknown Source)
at com.jme.app.BaseGame.start(Unknown Source)
at Terrain.main(Terrain.java:40)
lg Clemens

Thunderbird 08-18-06 04:31 AM

Re: Error when using NVEmulate :-/
 
I'm not sure what the old NVEmulate option for the xconfig file / the old environment variables still do. The NV-CONTROL api which is supported by nvidia-settngs and nvclock can set nvemulate aswell. Though nvidia-settings doesn't support it. You can use beta2 of nvclock (commandline version) to enable it aswell. It can be set to multiple values from geforce3(nv20)/geforce4(nv25) to geforcefx(nv30).

Linuxhippy 08-18-06 05:08 AM

Re: Error when using NVEmulate :-/
 
How exactly an this be archieved?

I tried it with:
ce@cehost:~/nvclock0.8b2> src/nvclock -nvemulate nv30
ce@cehost:~/nvclock0.8b2> src/nvclock -nvemulate=nv30


However still the game engine I am playing with reports at startup:
18.08.2006 11:04:29 com.jme.scene.state.lwjgl.LWJGLShaderObjectsState checkProgramError
SCHWERWIEGEND: null

lg Clemens

Thunderbird 08-18-06 05:16 AM

Re: Error when using NVEmulate :-/
 
nvclock -l shows the nvcontrol options it supports. It should mention nvemulate in it aswell. Then using nvclock -q nvemulate you can ask what values are supported. The option can be enabled using nvemulate: nvclock -a nvemulate=30

Note that no matter what option you use for enabling nvemulate, check if the opengl renderer string has changed (check glxinfo for it).

Linuxhippy 08-18-06 05:26 AM

Re: Error when using NVEmulate :-/
 
Thanks for the explanation, yes you're right "nvemulate" is listed as option and can be set and queried. When I set it to 30, nvclock tells me it is 30 when I do nclick -q nvemulate.

However my engine still does not work and the renderer string did not change either:
Code:

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce4 488 Go/AGP/SSE2
OpenGL version string: 1.5.6 NVIDIA 87.62

lg Clemens

Linuxhippy 08-18-06 10:45 AM

Re: Error when using NVEmulate :-/
 
I tried it on my "legacy" system which has a FX5200 built-in and there my demo works "perfectly". It seems nvemulate isn't working correctly :-/

Does anybody have a GF4MX card running and could also try wether it works or not - maybe its a bug in current drivers, could that be?

Thanks, lg Clemens

AaronP 08-18-06 03:31 PM

Re: Error when using NVEmulate :-/
 
NVEmulate isn't really supported any more, I'm afraid. You could try an older driver.


All times are GMT -5. The time now is 12:45 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.