nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nx7800 and linux driver support (http://www.nvnews.net/vbulletin/showthread.php?t=75395)

ptit_blom 08-20-06 05:17 PM

nx7800 and linux driver support
 
Hello,

I have just bought a nx7800 to fit into my old motherboard ( wich does agp 8x).
I am currently using an Ubuntu linux distribution "drapper drake"
I already have "anoyed" people on their forum to get some hints on getting my card to work.
I'll just do the same here.

First:
I installed the nvidia driver accordingly to their procedure... wich got me stuck with a gnome freezing after five ( or so ) minutes of work.
Second i installed the nvidia driver via the ".run" installer availaible at nvidia.
This got me the same problem and may be more.

Explanation:
I first tried the drivers on a Gentoo.
on this case: i had a launching Xorg but it freezed as soon as the Kde i installed started. When i rebooted the system i had always got loss of inodes ( fschk and reparing had been possible the few first times). Biut as the test were going on i had a "unreparable' file system.

I choosed a less 'technical' distribution (although i think even if it needs consoles and compiling , Gentoo stays user friendly).. goto Ubuntu

As i loaded the latest driver avalaible on ubuntu : the '8762' version of the driver
I had got an Xorg loading but freezing after a few minutes of work (same as Gentoo). I then choosed a less new version of the driver ... the first offering support for the nx7800 ( version: '8756' ).
After trying this one i get the same error.

One thing tha bugs me...
as i look into the /proc/ directory:
Code:

jerome@cherokee:~$ cat /proc/driver/nvidia/cards/0
Model:          GeForce 7800 GS
IRQ:            209
Video BIOS:      ??.??.??.??.??
Card Type:      AGP
jerome@cherokee:~$

However when the driver is loaded into Xorg:
Code:

(II) NVIDIA(0): NVIDIA GPU GeForce 7800 GS at PCI:1:0:0
(--) NVIDIA(0): VideoRAM: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.71.22.21.09

Why does it bugs me ? is the Video BIOS : ??.??.??.??.?? or 05.71.22.21.09 ???

I tried the "AGP" debugging discussed into the README file.
But my Ubuntu seems to disagree on unloading the agpgart and sis_agp modules... ( always used ) ... i'll see it through into the ubuntu forum ... however changing the NvAGP option changes the behavior of Xorg as when i set it to 0 or 1 i get a screen for some short time ( Xorg loads ... works then freezes ) and when i set it to 2 or 3 Xorg seems to load but i only get a black screen.

netllama 08-20-06 05:35 PM

Re: nx7800 and linux driver support
 
Please generate and post an nvidia-bug-report.log.

Thanks,
Lonni

ptit_blom 08-20-06 10:54 PM

Re: nx7800 and linux driver support
 
here

could not attach it to the post (129k is more than 100k)

nvidia-bug-report.log :: please download sources you will see nothing by http

netllama 08-20-06 11:45 PM

Re: nx7800 and linux driver support
 
I don't understand what "please download source" means, however the URL you provided for the bug report results in a 404 error.

You can zip the bug report to attach it here.

Thanks,
Lonni

ptit_blom 08-21-06 03:17 AM

Re: nx7800 and linux driver support
 
Misspelled the url.
Just click on it... it works here.

My ... Appologies

netllama 08-21-06 10:30 AM

Re: nx7800 and linux driver support
 
According to your bug report, you're using the vesa X driver, not the nvidia X driver.

Thanks,
Lonni

ptit_blom 08-21-06 01:23 PM

Re: nx7800 and linux driver support
 
Well ...
if i have issues starting a Xorg ( it freezes ) with the nivdia drivers ...
i then reconfigured my Xorg for using vesa drivers...
"Freezing" means: Xorg loads but after a few minutes (if not seconds ) i lose my keyboard ( no keys for typing text ) and the Xorg insterface ( menus...) doesn't respond too... well i keep my mouse for some time ( re... if not seconds ) i lose then the mouse ... with no mouse... no keyboard and no menus... should i be able to run "nvidia-bug-report.sh" ???
Meaning that: i get a REALY UNSTABLE SYSTEM

The configurations i used for starting the X server "with the nvidia driver" are located at :
http://www.angelfire.com/planet/dust0

Please ...accept my appologies if i seem to over-react...
i should have said it before...
And as i understand it ... it should be a lot easier for you to help me if you had a clean bug report ...

netllama 08-21-06 01:28 PM

Re: nx7800 and linux driver support
 
Can you telnet/ssh to the system when X has hung? If not, then you should generate the bug report after rebooting yet before starting X.

Thanks,
Lonni

ptit_blom 08-21-06 02:16 PM

Re: nx7800 and linux driver support
 
I have no ssh acces on this machine
I will : freeze it and re run "nvidia-bug-report" after a reeboot.

ptit_blom 08-21-06 03:07 PM

Re: nx7800 and linux driver support
 
here...
nvidia-bug-report.log
what i saw: a Gnome loading and freezing during the splash image ( the first window showing the Gnome modules loading )

netllama 08-21-06 03:15 PM

Re: nx7800 and linux driver support
 
I have a few questions:
0) Does this reproduce if you set NvAGP to 0 in xorg.conf ?
1) Does this reproduce if you set RenderAccel to false in xorg.conf?
2) Have you verified that you're using the latest BIOS for the motherboard?
3) Does this also reproduce with a more recent kernel (2.6.17.x)?

Thanks,
Lonni

ptit_blom 08-21-06 03:52 PM

Re: nx7800 and linux driver support
 
- with "NvAGP" "0" in the xorg.conf: same result
- i'll test right now to disable renderaccel
- this is the latest BIOS for the motherboard
- the actual kernel is the latest stable kernel provided with the "ubuntu" distribution i use, howerver i will try and get a newer kernel ( that will require some compiling and some documentation reading )


All times are GMT -5. The time now is 04:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.