nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Suse Linux 8.1 + Nvidia problems! (http://www.nvnews.net/vbulletin/showthread.php?t=7569)

freakypriest 02-14-03 12:56 PM

Suse Linux 8.1 + Nvidia problems!
 
Hi,
please help me!

I installed the newest drivers for my SuSe Linux 8.1 :
NVIDIA_GLX-1.0-4191.suse81.i586.rpm
NVIDIA_kernel-1.0-4191.suse81.i586.rpm

They seem to work. The Nvidia logo appears before x starts.
But when I want to activate 3D-Acceleration it just says I do not have the drivers and I should download them with YaST Online Update.

Please help me.

Btw there is no driver update package in the YaST YOU.

bwkaz 02-14-03 04:39 PM

You have to get rid of the default drivers that SuSE installs for you before you install newer ones. Did you do that?

Otherwise, there's this thread, where I quote a SuSE admin guide thingy I found:

http://www.nvnews.net/vbulletin/show...8185#post68185

Might help.

freakypriest 02-15-03 05:35 AM

I deleted both old packages before and I tried it a second time. Nothing works.

bwkaz 02-15-03 08:10 AM

You ran the switch2nvidia_glx script thingy? Were you in X when you tried to remove the drivers? That might cause issues... maybe.

Actually, does tuxracer play at more than one frame every 3-5 seconds? If so, then disregard the 3D Acceleration checkbox, because you have 3D acceleration already. If not, though, I'm not quite sure.

freakypriest 02-15-03 08:21 AM

yes x was running when i deleted the drivers. i'll try it again in runmode 3.

switch2nvidia works. switch2nvidia_glx does not give me any information if it works. no message on the screen.

i dont think tux racer willl work because sax2 shows "3D Acceleration disabled".
i will test it now.

freakypriest 02-15-03 09:00 AM

I tried tux racer. it runs perfectly. but there is a black border around the game. so i think it runs in smaller resolution than my desktop (desktop: 1024+768).

when i start the game i get the message that i don't have configured a 3d card yet. i click okay and it runs. is it possible that it runs in a software mode? i have got a quite fast PC (1,7ghz).

where can i find gears? is it possible that it is not included in suse 8.1? i know the proggy from suse 7.3 but i can't find it now.


i tried this:

init 3

rpm -e NVIDIA_GLX-1.0-4191.suse81.i586.rpm

I got the message: NVIDIA_GLX-1.0-4191.suse81.i586.rpm is not installed

rpm -e NVIDIA_kernel-1.0-4191.suse81.i586.rpm

I got the message: NVIDIA_kernel-1.0-4191.suse81.i586.rpm is not installed


Okay! Then I thougt the driver is not installed and tried to install it again:

rpm -ivh NVIDIA_kernel-1.0-4191.suse81.i586.rpm

I got the message: NVIDIA_kernel-1.0-4191 is already installed.

rpm -ivh NVIDIA_GLX-1.0-4191.suse81.i586.rpm

I got the message: NVIDIA_GLX-1.0-4191 is already installed.


What is wrong?

freakypriest 02-15-03 09:19 AM

This is what nv_check.bs says:

All the files seem to exist. Now I'm going to see if your kernel
module is loaded correctly...
the NVdriver kernel module does not seem to be loaded. The 3D
drivers will not work without it...please compile it for your
kernel, set it up to insert the module on boot, then run
this script again.


Okay, but how can I do that?

bwkaz 02-15-03 11:03 AM

On the rpm question, the issue there is that the RPM database doesn't store the filename as the internal package name. The argument that rpm -e is expecting is an internal package name, which is either NVIDIA_GLX-1.0-4191, or NVIDIA_GLX. Try NVIDIA_GLX first, and if that doesn't work, then do an rpm -qa | grep NVIDIA to find out what the real internal name is. You should be able to rpm -e those. It's confusing, I know.

On the nv_check question, I think you're just using an old version of nv_check. I wouldn't worry about it.

TuxRacer, on my Athlon 1800, in software mode, runs at about 1 frame per second. So if you've got a 1.7GHz something, and it's playable, then you have OpenGL working fine. The black border is probably because the VidMode extension is either not being used or isn't available. You should be able to edit your ~/.tuxracer/options file to increase the resolution it runs at to match your desktop.

If you want to try another test, though, glxgears is probably installed (it's not gears anymore, it's glxgears, I don't know why).

freakypriest 02-16-03 08:37 AM

Yeah,
I got it!

"rpm -qa | grep -i NVIDIA" told me that the old kernel was installed at the same time.

so I foud out the real names of those packets and deleted them. after installing them again and some sax2 crashes it works.

thank you very much!

how can i change the resolution of tux racer? it looks crappy and i hate those black borders.

bwkaz 02-16-03 09:36 AM

Open up ~/.tuxracer/options in an editor, and look for "set xresolution xxxx" and "set yresolution yyyy". Change them to your desktop resolution.

It probably is set already, but you might also want to look at "set fullscreen {yes|no}" -- make sure it's "yes".


All times are GMT -5. The time now is 10:37 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.