nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVIDIA DRIVERS...Try an older version........ (http://www.nvnews.net/vbulletin/showthread.php?t=7638)

nickb834 02-16-03 11:47 AM

NVIDIA DRIVERS...Try an older version........
 
After several hours trying to get the latest NVIDIA drivers working with Redhat 8 and trawling the net for help, it became apparent that there was absolutely no reason why these drivers should not work on my system and yet they still refused to, showing me a nice black screen instead of a nice gui. I had tried tar's / src.rpm's and precompiled rpm's to no avail so I tried an older set (ver 3123) of linux drivers and lo and behold 'in like flynn!'. Then I remebered something spooky, when NVIDIA were upto version 40.72 for the windows driver my Card (GeForce 3 ti 200) was fine, when they moved to version 41 something (I think 41.09) my computer suddenly refused to boot XP. So here I am with both XP Pro SP1, and Linux Redhat 8 both refusing to boot with 41.xx version drivers and yet quite happy with pre 41.xx version drivers. If you have done everything required (edited your XF86Config, checked modules.conf etc etc.......) and yet still no joy with nvidia and linux, try using an older Nvidia driver. Does anybody else out there think that Nvidia is trying something new in these post 41.xx drivers that neither Linux nor Windows likes? Does anybody know what it is?..............

g.krist 02-16-03 04:03 PM

odd, I must be one of the few people who don't have problems installing 4191 driver on RH 8.0. I can install the source tarballs with no problems.

But I also did downgrade to 3123 because tv-out in 4191 is borked

nickb834 02-16-03 06:07 PM

You lucky, lucky b*****d!!
 
Man why does everybody but me have good luck with stuff!!

Seriuosly tho, could you tell me exactly what you did and what lines you edited / added to your config files? I am sure I didn't miss anything but you never know!!

Just out of curiousity here's my specs, how much different are they to yours:

Athlon XP 2200
Abit KX7-333
256MB XMS 3200
Creative Geforce 3 Ti 200

Redhat 8 (2.4.18-14)
X Server 4.2.0

I used source tarballs, rpms and source rpms all the same result (black screen)

I edited:

XF86Config

Added:Load "glx" Removed: Load "dri"

Checked for:

modules.conf

alias-char-major-195 nvidia

Checked XFree86.0.log (Not a single warning or error when using: startx -- -verbose 5 - logverbose 5)

All files existed and in the right place and am still at a loss, as I said in previous post changed to version 3123 of driver and all ok!!

Delleon 02-16-03 08:33 PM

I built a new computer a few days ago and I had no luck with the latest drivers either. I managed to get into X only once, and doing so required me to throttle AGP down to 4x, and even then it froze after only a couple of minutes. It's been working great since I downgraded to the 3123 drivers, however according to the /proc/driver/nvidia entries, the card now only supports AGP 1x and 2x, whereas with the 4191 drivers it reported back 4x and 8x. (The card is 8x capable.) You'd think that an NVidia card running on an NVidia chipset would work well, so I'm hoping that they can fix this soon.

Athlon XP 2100+
Abit NF7 (Nforce2 chipset)
512MB PC2700 DDR
Asus V9280/TD Geforce4 Ti4200 8x
Gentoo Linux w/ 2.4.20 kernel

g.krist 02-17-03 01:47 AM

Well as I said I had no problems with X under 4191 but my tv-out was really f*cked up also UT 2003 did run less smooth. So downgraded ... It works pretty good now.

And btw you might check your os-registry.c and recompile the kernel module ...

Oke my config (partly) as you requested:

Section "Module"
#Load "GLcore"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "pex5" #Load "dri"
Load "glx"
Load "gle"
Load "pex5"
Load "record"
Load "xie"
EndSection

Section "Device"
# no known options
#BusID
#BusID "1:0:0"
Identifier "NVIDIA GeForce 2 MX (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 2 MX (generic)"
BoardName "NVIDIA GeForce 2 MX (generic)"
"1024x768,1024x768;800x600,800x600"

Option "NoLogo" "on"
Option "WindowFlip" "on"
Option "DigitalVibrance" "1"
Option "HWCursor" "on"
Option "CursorShadow" "on"
Option "RenderAccel" "true"
EndSection

Section "Screen"
Option "UBB" "on"
Identifier "Screen0"
Device "NVIDIA GeForce 2 MX (generic)"

Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1152x864"
EndSubSection

EndSection

disney 02-17-03 12:33 PM

try moving your pci devices around
 
I originally had the precise problem as the first poster and after tweaking things for a few hours, I tried unplugging my cards one by one.

I unplugged a device using IRQ 11 (if I remember correctly) and afterwards everything worked. To fix this issue, you can either hard set your IRQs or just trying moving stuff around.

Remember, I'm not sure it was IRQ 11, but I believe that's the one. My problem was definitely related to IRQ conflicts and this may be your problem as well.

Delleon 02-17-03 03:18 PM

I managed to get the 4191 drivers working now. After increasing my AGP aperture size in the BIOS to 256MB, they started working, but only at AGP 4x. 8x still yields a black screen.


All times are GMT -5. The time now is 07:11 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.