nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X freezes on start (http://www.nvnews.net/vbulletin/showthread.php?t=7738)

raymo03 02-18-03 09:20 PM

X freezes on start
 
I just did a fresh install of redhat 8.0.

Aopen AK77-8XN Mobo
Nvidia Ti 4200

Installed driver and glx from src rpms and edited the XF86Config and modules.conf files. Whenever i try to start X, the screen flickers a couple of times and then just comes up with random ASCII characters (smiley faces mostly...ironicly) and the system is completely frozen. CTRL+ALT+DEL, CTRL+ALT+BACKSPACE, CTRL+ALT+MASHING-EVERY-KEY doesn't do anything. The only way to recover is to reset the system.

Has anyone had a similar issue? I looked over the posts and could only find one other person with the random character issue, and that was just as a side comment.

I can, however, still get into X if i don't load glx and use the vesa driver.

hanha014 02-25-03 05:16 AM

My solution
 
I got excactly the same problem as you, what I did was looking under the XF86 logfile under /var/log/... on the last line I saw AGP4x initializing or something similar. Now the problem is that I only have a motherboard that supports AGP2x.. So what I did was that I wrote in

Options "NvAGP" "0" directly under the
Driver "nv" module in my XF86Config file...

that makes X boot up without using AGP... (which might not be a good Idea in the long run) I mean things run pretty smoothely. But I'm going to see if I could fix the problem.

DrLou 02-28-03 08:48 PM

Not sure if it's exactly the same problem (I never saw the strange characters you reported), but I did get lots of X freezes, also un-recoverable.

Sounds like we both tried the Ctrl-alt-smash-all-keys option, though, to no avail...

As you reported, I got itworking with the "NvAgp" "0" option, but also I had luck using the option which forces nVidia AGP; if I recall, this was the "NvAgp" "2" option.

In any case, the default (NvAgp "3", per the docs) which forces the kernel-based AGP to be tried first, NEVER worked for us...

It was elusive, too, as the module gave every apperance of loading normally, then would crash intermittently.

Lou

Athlon
VIA chipset
GeForce 4200

hanha014 03-01-03 03:39 PM

After I choosed to set this option to 0 it worked but with a few freezes. Then I set the value to 1 (the Nvidia Agp driver) and then it also started. But with random freeses (but the mouse is still movable)

If I looked in the log file, it said something that it couldn't determine the agp mode or something (a warning).

What I did then, was to upgrade the bios to the latest version, and that solved all the problem. I could even set the option to 3 which is the default. and I haven't had any crashes so far.

Since you have some KT133 motherboard (it was wasn't it) maybe a bios upgrade would fix your problem too maybe. anyway hope it helps :-)

raymo03 03-08-03 03:19 PM

update
 
Thanks for the help. I was able to get the driver working using NvAGP 0. Was hoping the bios update would do it for me, but I'm not that lucky.

Thanks again.

DiggyDogZiggy 03-08-03 08:48 PM

THANKS
 
I have had the SAME problem for a week now. Where did you edit? And a great post akin to my problems thanks for it. Also will "NvAGP" "0" allow me to play games? Thanks.

DiggyDogZiggy 03-08-03 09:17 PM

mine is working
 
I got mine screaming thanks to your post and you guys replies. bless ya. this is so great you have made my day big time. Now NVIDIA needs to make this process easier for folks so you dont need a B.S in computer science to configure your card in LInux.

DrLou 09-09-03 10:46 AM

SuSE 8.2 notes/question
 
We've just done a new install of SuSE 8.2, with all updates as of Sep 2003. This includes gcc 3.3. NVIDIA driver 1.0-4496 has been successfully installed.

In case it helps someone: The IGNORE_CC_MISMATCH - per the drivers 'README' file, was absolutely required in this case. Also, in any configuration which tries AGPART first, the system freezes. IE, if we use Option "NvAGP" "2" or Option "NvAGP" "3".

On the other hand, Option "NvAGP" "1", selecting NVIDIA internal AGP support, WORKS, but always leaves AGP disabled. IE, '# cat /proc/driver/nvidia/agp/status' reports 'Disabled'.

We still get about 1200 FPS from glxgears, though, so shouldn't be too unhappy...

BUT, as this is an AGP card, could we get better performance somehow forcing AGP? Is this something worth spending more time on? Does anyone have any suggestions?

Card is a GeForce 4200 (AGP)

hanha014 09-09-03 11:17 AM

I'm not really sure, but I think there is an option to force the AGP rate in the XF86Config file, read the Nvidia, document for syntax.

And again, upgrading my BIOS solved my problems with intermittent hangings.


All times are GMT -5. The time now is 07:58 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.