nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   geforce2 (pci) driver hangs system (http://www.nvnews.net/vbulletin/showthread.php?t=78260)

koanhead 10-15-06 05:08 PM

geforce2 (pci) driver hangs system
 
I have:

PCCHIPS m848lu mobo
GeForce2 MX 400 (32MB) in PCI slot
Ubuntu 6.06 ("Dapper Drake"), up-to-date

I'm currently running the "nv" driver (no acceleration) because the "nvidia" driver hangs the system a few minutes after X starts. I have plain-vanilla Ubuntu, which means X.org and GNOME instead of KDE if that makes any difference.
I purchased this PCI card for my previous machine that had no AGP slot, but did have integrated graphics. The "nvidia" driver always worked fine on the old machine (VIA Centaur mobo).
I am unclear as to whether the "nvidia-legacy" or "nvidia" driver is the appropriate one for this particular card. X will not start using the "nvidia-legacy" driver. Everything seems copacetic under the "nvidia" driver but, as mentioned, it hangs the system after a few minutes. No keyboard or mouse input is recognized. The display becomes static. Bummer.
Is there anything I can do to make this card work?

whig 10-15-06 05:59 PM

Re: geforce2 (pci) driver hangs system
 
I would tinker with the NvAGP variable, like set it to 0. The readme has info on this.

koanhead 11-16-06 11:46 PM

whoops

koanhead 11-16-06 11:50 PM

Re: geforce2 (pci) driver hangs system
 
1 Attachment(s)
Thanks, but that didn't help. set it to NvAGP=0, same result. Reread the readme while I was at it. I'm pretty sure what I need is to keep agpgart and any other agp driver from loading... in other words, to disable agp entirely. Sadly the m848lu BIOS does not have such an option. Something I read (probably in grub docs) indicated that I could append it as a kernel argument in grub.conf... yet I have no grub.conf! WTF? Ok, I added it in menu.lst as that seemed the nearest similar alternative (this is after trying to manually pass the argument agp=off at the grub menu prompt) but to no effect. No matter what I do agpgart shows up in lsmod.
Can anyone tell me how to disable agp so my dang pci card will work? I hate to go buy a new card for this dilapidated machine. I have attached nvidia-bug-report, with the nvidia driver running (I think. I'm not sure what runlevel Ubuntu's "failsafe terminal" runs in, or if it makes a difference.)

whig 11-17-06 02:41 AM

Re: geforce2 (pci) driver hangs system
 
To get rid of kernel agp, custom compile your own kernel. This howto is ubuntu specific.

http://www.howtoforge.com/kernel_compilation_ubuntu

koanhead 11-18-06 06:21 PM

Re: geforce2 (pci) driver hangs system
 
Many kilothanks! I've been spooked by the idea of compiling a custom kernel for ubuntu, even though I always used to do it back in the bad old slackware 2.0 days. I never heard of howtoforge before. It makes me very happy.

HankNV 11-18-06 11:07 PM

Re: geforce2 (pci) driver hangs system
 
Shouldn't have to recompile a custom kernel. I would venture to say that your problems are PC CHIPS related. But if you'll send me a list of what hardware you're running and what the exact motherboard you're running, I'll shoot you a config file you can use to compile your own custom kernel. Should just take a minute or two to make: the config file that is.

I've got a PC CHIPS board running a Pentium III 1Ghz chip. But I can't even get the GeForce2 Card to boot on it. It's supposed to support up to 4X AGP.

But I'm amazed that you've got it working at all on that motherboard. Those VIA chipsets on those PC Chips motherboards are a major pain in the neck.

I finally switched to a Voodoo 5 AGP card on that motherboard and it runs pretty good. But they only need AGP 1X anyway. So it works out kind of well, if you have a PC CHIPS board.

But I think the only NVIDIA card I succeed using on my PC Chips board was of the TNT2 64 variety. I think anything faster the just drives the board haywire.

I see from your log report that you're getting errors from a /dev/wacom for your mouse. And that the PS/2 mouse setting succeeds.

You might try uninstalling the nvidia drivers and then generating a generic xorg.conf file.

Try this as root:

Xorg -configure

That should generate a xorg.conf.new file in the directory in which you're in.

Check the Mouse section. Usually, you have to edit the settings there and adjust your modes and DefaultDepth in the Screen and Display sections.

Option "Device" "/dev/mouse"

change to

Option "Device" "/dev/input/mice"

You can then test the new file like this.

Xorg -config xorg.conf.new

If it works, as root you can copy it to your /etc/X11 directory.

cp -fv xorg.conf.new /etc/X11/xorg.conf

You can then recompile your nvidia module and edit by hand the /etc/X11/xorg.conf file to use the "nvidia" module instead of the "nv" module.

Hank


All times are GMT -5. The time now is 12:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.