nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia-9626, Cedega and World of Warcraft (http://www.nvnews.net/vbulletin/showthread.php?t=78382)

CyD 10-17-06 11:40 AM

nvidia-9626, Cedega and World of Warcraft
 
Hi,

Many transparent textures in World of Warcraft are showing up black using nvidia betas. Transgaming devs have been notified as well. I have posted a screenshot at www.nuevoma.com/files/wowscreen01.jpg . The bottom left of the screen shows the problem.

The bug report is available at www.nuevoma.com/files/nvidia-bug-report.log

I have sent a mail to linux-bugs@nvidia.com as well.

Thunderbird 10-17-06 12:41 PM

Re: nvidia-9626, Cedega and World of Warcraft
 
It can also be a bug in Cedega. I'm a wine developer and opengl is one of my areas and on Wine these issues (in case of opengl mode and also using d3d9) don't happen. The opengl code is still more or less the same in Cedega and Wine, though the pbuffer code is different and that is what is used by WoW, so it could be a bug in that pbuffer code in Cedega.

netllama 10-18-06 04:55 PM

Re: nvidia-9626, Cedega and World of Warcraft
 
I've reproduced this problem, and opened bug 261397.

Thanks,
Lonni

tmchardy 11-05-06 06:29 PM

Re: nvidia-9626, Cedega and World of Warcraft
 
:) Yeah, both 9625 and 9626 are the same. I only started noticing the little black square in the bottom left after actually logging in. You should have taken a screenshot after you log in. ;-) The game is completely unplayable (I remember where all my hotkeys are, but I don't know what's in my bags off by heart. :p )

Oh well, it's been a couple weeks with this problem. Hope a fix presents itself soon. Really would like to be able to play WoW on my laptop one day.

Ikshaar 11-07-06 02:48 PM

Re: nvidia-9626, Cedega and World of Warcraft
 
I reported it here when drivers came out... and filled bug on cedega...
http://transgaming.org/forum/viewtop...912&highlight=

Too bad I did not know at the times where to get in touch with nVidia...

EDIT: and bug is not fixed in 9629

syncomm 11-07-06 07:10 PM

Re: nvidia-9626, Cedega and World of Warcraft
 
Same issue here (also running non-beta 9626), doesn't happen using the last stable driver release on the same box and setup.

xbobmx 11-07-06 10:04 PM

Re: nvidia-9626, Cedega and World of Warcraft
 
Note that World of Warcraft still works fine if you use it in OpenGL mode ("-opengl" parameter). It's faster than the D3D one anyway.

Ikshaar 11-08-06 10:49 AM

Re: nvidia-9626, Cedega and World of Warcraft
 
Quote:

Originally Posted by xbobmx
Note that World of Warcraft still works fine if you use it in OpenGL mode ("-opengl" parameter). It's faster than the D3D one anyway.

Please don't make generalization ... i have terrible performance and/or terrible artefacts if I use opengl. So it might work for some but it's not "faster anyway"...

sir_tez 11-09-06 07:50 AM

Re: nvidia-9626, Cedega and World of Warcraft
 
Just wanted to confirm that I was seeing the same problem on *stable* 9629.

Ikshaar 11-10-06 08:57 AM

Re: nvidia-9626, Cedega and World of Warcraft
 
Quote:

I've reproduced this problem, and opened bug 261397.
netllama: is there public access to that bug report progress or is it inside nVidia only ?

Thunderbird 11-10-06 09:24 AM

Re: nvidia-9626, Cedega and World of Warcraft
 
It is internal to Nvidia people only. The only way to get the status of the bug is by asking it to an Nvidia employee with the bugreport number attached.

netllama 11-20-06 03:07 PM

Re: nvidia-9626, Cedega and World of Warcraft
 
After investigation this was determined to be a cedega bug, not an nvidia driver bug.


All times are GMT -5. The time now is 12:03 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.