nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GeForce4 locks the screen (http://www.nvnews.net/vbulletin/showthread.php?t=7874)

ZekeVarg 02-22-03 01:30 PM

GeForce4 locks the screen
 
I've just bought a new grafic-card, a Leadtek WinFast A170T with the GeForce4 mx 440 se chipset, I got the drivers from Nvidia installed and working with my old card (TNT).
The problem is that the new card locks up my screen and keyboard after a little while, the mouse still moves thou, so I have to reset the computer.
I'm running a fresh RH7.3 (kernel 2.4.18-3) installation with Gnome 1.4 on a AMD K6-2 500 MHz processor.
Anyone got some idée to solve this problem?
Regards Zeke

bwkaz 02-22-03 02:25 PM

I don't know if this is related or not, but you'll probably want to update that kernel. 2.4.18-3 had quite a few bugs in it, IIRC.

After you update, boot to the new kernel and rerun NVchooser, then reinstall the driver.

However, if this same kernel worked with your old card, then I'm not entirely convinced it isn't a hardware problem; there's a good chance that it is...

ZekeVarg 02-23-03 06:15 AM

Just tried to upgrade to the latest RH7.3 kernel 2.4.18-24.7 whitout any luck. It still freezes my screen.
Any other idé's?
Regards Zeke

Delleon 02-23-03 10:33 AM

Which version of the drivers are you using? Have you tried using the 3123 version?

ZekeVarg 02-23-03 12:37 PM

I've the 4191 version installed. I tried the 3123 version but got a error: can't load NVdriver, any known problem/solution to that?
Zeke

bwkaz 02-23-03 02:16 PM

Can't load NVdriver? That's really not very descriptive; what did you type, and what was the exact error?

ZekeVarg 02-23-03 05:19 PM

Sorry for the short description.
This is the message I get when installing the NVIDIA_kernel-1.0-3123.i386.rpm that I rebuilt from the source-rpm.

nvidia: 10de0173 - unknown PCI id
nvidia: no NVIDIA graphics adapter found
/lib/modules/~/NVdriver: init_module : No such device
/lib/modules/~/NVdriver: insmod NVdriver failed

The NVIDIA_kernel-1.0-4191 rpm install whithout any problems, but the screen locks.
Zeke

bwkaz 02-23-03 07:00 PM

What happens when you do a make install using the .tar.gz drivers? (after rpm -e 'ing the old kernel, that is)

Stanley Tweedle 02-24-03 07:55 AM

Quote:

Originally posted by ZekeVarg
nvidia: 10de0173 - unknown PCI id
This message means your graphic adapter isn't supported by that driver (0173 is the code for Geforce4 MX 440 SE). First driver version to support that gpu is 4191.
Greetings
Peter

ZekeVarg 02-24-03 12:23 PM

I see! I will download the 4191 source tar files and try them tomorrow.
I report how it goes later.
Zeke

ZekeVarg 02-25-03 11:53 AM

I tried the 4191 driver from source tar-files but still the same lockup of the screen :-( No error messages during instalation.
Guess I have to wait for next version of the driver.
Regards Zeke

ZekeVarg 03-01-03 11:16 AM

I found the soulution in another thread.
I added
Option "NvAGP" "0"
to my XFree86config-4 and it worked.
I don't know what it does, but it works.
So to citate Homer Simpson "YOOHOOO"


All times are GMT -5. The time now is 04:07 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.