nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nforce/nvnet/nvnet.c and linux kernel 2.5.63 (http://www.nvnews.net/vbulletin/showthread.php?t=7915)

bisailb 02-23-03 07:02 PM

nforce/nvnet/nvnet.c and linux kernel 2.5.63
 
1 Attachment(s)
Problem:
Cannot compile nvnet module with linux kernel 2.5.63 source code.

Warnings:
`_MOD_INC_USE_COUNT' is deprecated
`__MOD_DEC_USE_COUNT' is deprecated

Errors:
nvnet.c: In function `nvnet_remove':
nvnet.c:1172: structure has no member named `driver_data'

Solution:
Please see attached patch. It may even work for earlier 2.5 kernel versions. I just chose the 2.5.63 kernel version. By the way, rename it from nvnet-patch-2.5.63.diff.txt to nvnet-patch-2.5.63.diff because this forum only accepts the .txt extension and some others.

Testing:
I did not test it yet but since it compiles just fine it should work. The function you want to test is nvnet_remove. If anyone has any success with this patch write a reply post to let everyone know it worked.

bisailb 02-23-03 07:04 PM

Use of patch command
 
I forgot to mention to use patch -p0 < nvnet-patch-2.5.63.diff

Just make sure you put the diff in the directory one level below the nforce directory (not within it!).

Luguber 02-27-03 08:46 PM

Link
 
The link to the patch doesn't seem to work for me. Can you please point me to another link or maybe just post the patch as text in the forum so I can do the changes manually.

I really hope this patch work as it is the only thing that is still problematic for me in switching to the 2.5 kernel.

Regards.
-Luguber

Luguber 02-27-03 08:50 PM

Re: don't bother
 
:D I got it working in mozilla. It didn't work in Konqueror, I guess it's because the mimetype for the php-script isn't set, but you probably can't do anything about that.

I'll try the patch emediatly and let you know my result :)

Luguber 02-28-03 11:20 AM

I tried this patch agains the NVIDIA_nforce-1.0-0248.tar.gz package and then tried to compile it against both
linux-2.5.62-mm3 and linux-2.5.63-mm1
(This is the kernel with Andrew Morton's patchset).
In both cases it complains about missing declaration of a IRQ_<something>.

I'll try to compile against the plain vanilla-linux sources tomorrow, just a little bit sick of rebooting for today :)

Btw. If you are using the nvnet driver, then you might have an A7N8X motherboard, so I'm just curious, did you get the 3Com NIC to work?

Regards.
-Luguber.

kvh 04-06-03 06:38 PM

invalid module - nvnet + patch + 2.5.65
 
I tried that patch for nvnet. I got it to compile. However, when I try to insmod with 2.5.65 kernel I get error :

% insmod nvnet.o
Error inserting 'nvnet.o': -1 Invalid module format

% insmod.old nvnet.o
insmod: QM_MODULES: Function not implemented

kernel : 2.5.65
nforce : NVIDIA_nforce-1.0-0248.tar.gz + nvnet-patch-2.5.63.diff.txt
gcc : 3.2.2

Any ideas?


All times are GMT -5. The time now is 06:25 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.